Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> вывести отчет по реквизиту          
4andriy Подменю пользователя
сообщение 27.10.16, 22:52
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 112
Спасибо сказали: 0 раз
Рейтинг: 0

1C: Предприятие 7.70.027
Бухгалтерский учет для Украины

В справочнике контрагентов отдельно вносили форму налогообложения. Задача создать отчет где есть форма выбора формы налогообложения (создал) и собственно код для его отображения. Тоесть в отчет должны попасть названия фирм с налогообложением из формы. Поле ввода для выбора добавил. При выполнении вижу пустой листок.

//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |ОбрабатыватьДокументы все;
    |НалогОбл = Справочник.Контрагенты.ТекущийЭлемент;
    |Группировка налогОбл;
    |Условие(налогОбл = ВыбналогОбл);
    |"//}}ЗАПРОС
;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей налогОбл
        Таб.ВывестиСекцию("налогОбл");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры

4andriy Подменю пользователя
сообщение 28.10.16, 0:23
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 112
Спасибо сказали: 0 раз
Рейтинг: 0

тоесть нужен очень быстрый минималистический поиск по реквизиту справочника контрагенты

nysysimara Подменю пользователя
сообщение 28.10.16, 7:08
Сообщение #3

Оратор
Иконка группы
Группа: Местный
Сообщений: 307
Из: Бердянск
Спасибо сказали: 109 раз
Рейтинг: 0

ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |ТекущЭлемент= Справочник.Контрагенты.ТекущийЭлемент;
    |НалогОбл = Справочник.Контрагенты.ТекущийЭлемент.<Имя реквизита налогоображения>;
    |Группировка ТекущЭлемент;
    |Условие(НалогОбл = ВыбналогОбл);
    |"


или создайте запрос с помощью конструктора запросов


nik389 Подменю пользователя
сообщение 28.10.16, 10:48
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 117
Из: Украина
Спасибо сказали: 33 раз
Рейтинг: 30

вот так правильнее, я думаю:
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
    |ТекущЭлемент= Справочник.Контрагенты.ТекущийЭлемент;
    |НалогОбл = Справочник.Контрагенты.<Имя реквизита налогоображения>;
    |Группировка ТекущЭлемент;
    |Условие(НалогОбл = ВыбналогОбл);
    |"

nysysimara Подменю пользователя
сообщение 28.10.16, 11:05
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 307
Из: Бердянск
Спасибо сказали: 109 раз
Рейтинг: 0

nik389 @ Сегодня, 10:48 * ,
да, так правильней
|НалогОбл = Справочник.Контрагенты.<Имя реквизита налогоображения>;

копипаст подвел ))

Спасибо сказали: 4andriy,

4andriy Подменю пользователя
сообщение 29.10.16, 21:18
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 112
Спасибо сказали: 0 раз
Рейтинг: 0

заработало)

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.11.20, 20:29
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!