Версия для печати темы (https://pro1c.org.ua/index.php?s=7c92a56ad678e6a183b5ce8914e5a490&showtopic=67521)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ раскраска строки FormEX

Автор: 4andriy 01.04.24, 8:05

для 1с 7.7
для раскраски использую FormEx
надо раскрасить текущую строку
выделеная ячейка сейчас синяя, а надо что-бы ячейка была одним цветом, а строка другим

если пишу такой код тогда красит всю таблицу:

Если ПустоеЗначение(ТекущийЭлемент().Наименование)=0 Тогда Возврат "BRUSH[" + ПолучитьЦвет(200,200,100) + "]"; КонецЕсли;

Автор: denis84 01.04.24, 9:03

4andriy @ Сегодня, 9:05 * ,
Доброго дня, в журналі документів розфарбована ТЧ за ознакою "КонтрольДокументів", якщо контролюємо контрагента:

//==========================================
Функция ПроверитьВид()
    Если ПустоеЗначение(ТекущийДокумент) = 0 Тогда
        //Если ТекущийДокумент.ЗапретРедактирования = 1 Тогда
        //    Возврат "BRUSH["+глПолучитьЦвет(204,204,204)+"]";      //серый фон
        Если ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 1)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255,255,255)+"]"; //белый  фон
        ИначеЕсли ((ТекущийДокумент.Контрагент.КонтрольДокументов = 1) И (ТекущийДокумент.Проверен = 0)) Тогда
            Возврат "FONT["+глПолучитьЦвет(0,0,0)+"] BRUSH["+глПолучитьЦвет(255, 222, 179)+"]"; //красный  фон
        КонецЕсли;
    КонецЕсли;
    Возврат "";
КонецФункции

Автор: denis84 01.04.24, 11:27

ось функція з глобал.модулю

Функция глПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
        // функция для формирования значения цвета из составляющих (RGB)
    Возврат Макс(0,Синий)*65536+Макс(0,Зеленый)*256+Макс(0,Красный);
КонецФункции


Автор: 4andriy 01.04.24, 13:26

тільки там не ТекущийДокумент, а Текущая строка

Автор: denis84 01.04.24, 14:07

4andriy @ Сегодня, 14:26 * ,
в мене це приклад для журнала надходження ТМЦ, а у Вас

Автор: 4andriy 01.04.24, 14:44

denis84 @ Сегодня, 14:07 * ,
довідник співробітників

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua