Версия для печати темы (https://pro1c.org.ua/index.php?s=d79b4d5aa0f7fc29b8ab4a756b8db450&showtopic=67505)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ УНФ загрузка внешный данных

Автор: burza 13.03.24, 12:39

в УНФ штатная загрузка внешных данных, делаю загрузку из ексель. В справочники номенклатуры добавил поле КатегорияОбмена- ведет на другой справочник(поле выбора). При загрузке все показывает а когда создаеться номен то поле пустое.Если поле простое строка то все ок, а если там стоит выбор то не как. Вроде по аналогии добавил в модули но ничего. Может кто-то сталкивался.
Это в менеджере Номенклатуры

ЗагрузкаДанныхИзВнешнегоИсточника.ДобавитьПолеОписанияЗагрузки(ТаблицаПолейЗагрузки, "КатегорияОбмена", "КатегорияОбмена", ОписаниеТиповСтрока25,ОписаниеТиповКолонка,"Номенклатура",2,,Истина);

 ЗагрузкаДанныхИзВнешнегоИсточникаПереопределяемый.СопоставитьНоменклатуруКатегорияОбмена(СтрокаТаблицыФормы.КатегорияОбмена);


Это в общем
Процедура СопоставитьНоменклатуруКатегорияОбмена(КатегорияОбмена) Экспорт
     ЗначениеБылоСопоставлено = Ложь;
    
    Если НЕ ЗначениеБылоСопоставлено И ЗначениеЗаполнено(КатегорияОбмена) Тогда
        
        СправочникСсылка = Справочники.КатегорияОбмена.НайтиПоНаименованию(КатегорияОбмена);
        Если НЕ СправочникСсылка.Пустая() Тогда
            
            
            ЗначениеБылоСопоставлено = Истина;
            Номенклатура = СправочникСсылка.Наименование;
            
        КонецЕсли;
        
    КонецЕсли;
        
КонецПроцедуры


Отладка туда не пускает,ничего не происходит(

Автор: burza 13.03.24, 16:03

burza @ Сегодня, 12:39 * ,
сопоставление не происходит

Автор: takefive 14.03.24, 15:53

попробуйте так...

КатегорияОбмена = СправочникСсылка;

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua