Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



35 страниц V   1 2 3 > » 

>  Сохранить параметры отбора из формы отбора в документе
Constantus
Отправлено: 13.02.20, 17:58


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


fly @ Сегодня, 21:16 * ,

Сделал код

ДокументОбъект.ОтборНастроек = Новый ХранилищеЗначения(КомпоновщикНастроек.Настройки);


Как проверить заполнился ли реквизит? И получить его истинное человеческое значение?

Constantus @ Сегодня, 21:54 * ,

Точнее

ДокументОбъект.ОтборНастроек = Новый ХранилищеЗначения(КомпоновщикНастроек.Настройки.Отбор);

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160374 · Ответов: 8 · Просмотров: 205
 

>  Сохранить параметры отбора из формы отбора в документе
Constantus
Отправлено: 13.02.20, 17:07


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(fly @ 13.02.20, 20:18) *
Отбор = Новый Структура;
СписокНомеклатуры = Новый СписокЗначений;

//----------Заполняем СписокНомеклатуры
Отбор.Вставить("Номенклатура", СписокНоменклатуры);
УстановкаЦенНаИзделияВГородах.ОтборНастроек = Новый ХранилищеЗначения(Отбор);


Стучусь головой об стенку... У меня этот отбор не по номенклатуре, там может быть очень сложный отбор. Как писал ранее типа

( ( Номенклатура Равно "Балка цветника" И Размер В списке "50/8'В'*8; 50/8'В'*7" ) ИЛИ ( Номенклатура Равно "Стела" И Полировка Равно "2х" ) )

Вот этот отбор нужно сохранить в документе, а потом чтобы его вытащить в форму отбора при открытии которого заполняются вот эти отборы
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160368 · Ответов: 8 · Просмотров: 205
 

>  Как правильно расположить картинку на этом сайте?
Constantus
Отправлено: 13.02.20, 16:55


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!!!

Как правильно расположить картинку на этом сайте в топиках?

Я так понимаю, что сначала я должен расположить эту картинку на каком то ссайте, потом разместить ссылку.
На каком сайте можно расположить картинку и дать ссылку на нее?
  Форум: http://pro1c.org.ua/ · Просмотр сообщения: #160366 · Ответов: 1 · Просмотров: 90
 

>  Сохранить параметры отбора из формы отбора в документе
Constantus
Отправлено: 13.02.20, 15:24


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


fly @ Сегодня, 19:06 * ,

Вот код, который массово формирует документы:

    СозданныеДокументы.Очистить();
    ДанныеЗаполнения = ОтобранныеПозиции.Выгрузить();
    Сч = 0;
    Для каждого СтрокаГорода Из ГородаЗаполнения Цикл
        ДокументОбъект = Документы.УстановкаЦенНаИзделияВГородах.СоздатьДокумент();
        //ДокументОбъект.Дата = ТекущаяДата();
        ДокументОбъект.Дата = ДатаДокумента;

        //ДокументОбъект.Организация = ОрганизацияДокумента;
        ДокументОбъект.Автор = Пользователи.ТекущийПользователь();
        ДокументОбъект.АкцияДокумента = АкцияДокумента;
        ДокументОбъект.Комментарий = "#Групповое создание";
        ДокументОбъект.ОсновнойГород = СтрокаГорода.Город;
        СтрокаГородаДокумента = ДокументОбъект.Города.Добавить();
        СтрокаГородаДокумента.Город = СтрокаГорода.Город;
        ДокументОбъект.ЗаполнитьЦены(ДанныеЗаполнения);
        
        ДокументОбъект.Записать(РежимЗаписиДокумента.Запись);
        СтрокаСозданных = СозданныеДокументы.Добавить();
        СтрокаСозданных.Город = СтрокаГорода.Город;
        СтрокаСозданных.Документ = ДокументОбъект.Ссылка;
        Сч = Сч + 1;
    КонецЦикла;



В документе "УстановкаЦенНаИзделияВГородах" есть реквизит "ОтборНастроек" с "ХранилищеЗначения"

Как мне сохранить в этом реквизите настройки отбора? В Вашем примере указывается на диск...

В коде
МакетРезультат = Компоновщик.Выполнить(СхемаЗаполнения, НастройкиКомпоновки,,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));


"НастройкиКомпоновки" при отладке показало в "Отбор" показало значение: Номенклатура Равно "Стела" И Полировка Равно "2х"

Я так понимаю, что мне это значние нужно поместить в реквизит "ОтборНастроек" с "ХранилищеЗначения"?

Если как то как?


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160363 · Ответов: 8 · Просмотров: 205
 

>  Сохранить параметры отбора из формы отбора в документе
Constantus
Отправлено: 13.02.20, 12:25


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, УФ, самопис

Имеется некая свободная форма "Групповое создание документов", которая по неким отборам по номенклатуре отбирает нужную номенклатуру и создает несколько документов

на форме расположен "КомпоновщикНастроек" с типом "КомпоновщикНастроекКомпоновкиДанных" с путем к данным "КомпоновщикНастроек.Настройки.Отбор"

Возможно ли сохранить этот отбор в создаваемых документах?



Чтобы потом при повторном открытии этой формы отбора получить параметры отбора из этого созданного документа?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160356 · Ответов: 8 · Просмотров: 205
 

>  Перезапонение выбранных документов
Constantus
Отправлено: 13.02.20, 10:48


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется некий документ. На форме документа имеется кнопка, которая заполняет табличную часть кодом

  ДокументОбъект = РеквизитФормыВЗначение("Объект");
    ДокументОбъект.ЗаполнитьЦены();
    ЗначениеВРеквизитФормы(ДокументОбъект, "Объект");
    
    Модифицированность = Истина;


ЗаполнитьЦены(); - заполняет ТЧ ценами и т.д.

Теперь в форме списка нужно расположить некую кнопку, которая этим же кодом перезаполняет ТЧ несколько выбранных документов.
Поставил кнопку на список с кодом:

&НаКлиенте
Процедура ПерезаполнитьЦены(Команда)
    
    ВыделенныеСтроки = Элементы.Список.ВыделенныеСтроки;
    ИзменитьЦены(ВыделенныеСтроки);    
    
КонецПроцедуры


&НаСервере //БезКонтекста
Процедура ИзменитьЦены(ВыделенныеСтроки);
    
       Для Каждого Строка Из ВыделенныеСтроки Цикл
                Об = Строка.ПолучитьОбъект();
        Об.ТабличнаяЧасть.Очистить();
    
        Сообщить(Объект.Ссылка);
            
    КонецЦикла;
    
КонецПроцедуры




Никак не могу сообразить как правильно, а главное оптимально в этот код установить срабатывание кода в модуле объекта

Процедура ЗаполнитьЦены() Экспорт


Посоветуйте...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160351 · Ответов: 1 · Просмотров: 119
 

>  Список значение как параметр открываемой формы
Constantus
Отправлено: 03.02.20, 11:20


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, самопис, УФ.

Программно пытаюсь открыть форму с передачей параметров.
На этой открываемой форме есть реквизит "СписокПолей" как список значений.

Для передачи параметра программно формирую список значений:

    СЗ = Новый СписокЗначений;
    СЗ.Добавить("ЦенаДляЗаказчика", "Цену для заказчика");
    СЗ.Добавить("ЦенаДляПодрядчика", "Цену для Подрядчика");
    СЗ.Добавить("Материалы", "Цену для материалы");
    СЗ.Добавить("Прочее", "Цену на работу");
    
    
    
    ПараметрыВызова = Новый Структура;
    ПараметрыВызова.Вставить("АдресДанныхОбработки", АдресТабличнойЧасти_Работы());
    ПараметрыВызова.Вставить("ИмяКолонкиСуммаПроцента", ИКСП);
    ПараметрыВызова.Вставить("ПредставлениеСуммаПроцента", ПСП);
    ПараметрыВызова.Вставить("СписокПолей", СЗ);
    
    ОткрытьФорму("ОбщаяФорма.ФормаИзмененияПроцентаЦены", ПараметрыВызова, ЭтотОбъект);


ошибок нет при открытии, но и реквизить "СписокПолей" пустой ("ЦенаДляЗаказчика" и т.д.), т.е. выбрать какое-либо значение не выбрано.
Что я сделал не так? Подскажите
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159991 · Ответов: 1 · Просмотров: 263
 

>  Откыть форму выбора с отбором: по владельцу составного типа с определенным типом
Constantus
Отправлено: 15.01.20, 16:17


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, господа!
1с8.3.12, самопис, УФ

На данный момент по кнопке открываю форму выбора счетов с параметрами:

ОткрытьФорму("Справочник.БанковскиеСчета.ФормаВыбора", Новый Структура("Отбор", Новый Структура("НеАктуален, ПометкаУдаления", Ложь, Ложь)), ЭтотОбъект);

Теперь требуется отбор провести по "Владельцу"
Владельцем спарвочника явлюятся справочники "Организация", "Контрагенты", "Сотрудники"

Как изменить код, чтобы при открытии формы производился отбор по всем владельцам из справочника "Организация"?

Новый Структура("Владелец", Организация)



Чем в этом когде заменить "Организация"?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159372 · Ответов: 1 · Просмотров: 110
 

>  Очистить значение параметра при изменении другого параметра
Constantus
Отправлено: 11.12.19, 13:29


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!

В шапке отчета имеется Параметр1 и Параметр2

Как сделать так, чтобы при изменении Параметра1, значение Параметра2 очистилось от заполненного ранее значения?
  Форум: Система компоновки данных · Просмотр сообщения: #158378 · Ответов: 2 · Просмотров: 172
 

>  Навигационная ссылка с произвольным комментарием
Constantus
Отправлено: 04.12.19, 15:39


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Есть такая задача для экзаменов:

Необходимо предоставить пользователю
возможность вводить произвольный текстовый комментарий. Текст комментария может
содержать навигационную ссылку (не более одной) на документ оплаты. Переход по
навигационной ссылке должен осуществляться при нажатии кнопки открытия, созданной у
данного элемента управления формы.

Подскажите о чём вообще идет речь? Даже не понимаю с чего начать.... icon_cuss.gif

тескт должен быть типа: вот это самый последный расчет с покупателем: e1cib/data/Справочник.ВнутренниеДокументы?ref=80d394de802257ad11e8155da6a29958

Подскажите где можно посмотреть как всё это делается с нуля, или видео, или дайте списать icon_beer17.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158199 · Ответов: 0 · Просмотров: 161
 

>  ТЧ: настройка формы с отбором нужных строк с сохранением настроект отбора
Constantus
Отправлено: 01.12.19, 11:34


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Попробую по-другому пояснить

Имеется дополнительная форма документа "ФормаИзмененияПроцентаЦены"
На ней установлено софйство: Сохранение данных формы в настройках - использовать список

Тем самым у формы появляются 2- новых кнопки "Сохранить и восстановить ппараметры"

На форме также имеется кнопка "Пометить с отбором", которая открывает общую форму "Заполнение документа", где проводится отбор данных по определенным параметрам, а потом по отборам и происходит установка галок в дополнительной форме для дальнейших махинаций...

Претензий к работе к указанному нет, все работает, но вот никак не запоминаются параметры, т.е. после сохранения параметра отбора и его восстановления, форма "Заполнение документа" открывается свободной от параметровЮ т.е. требуется снова заполнения параметров выбора, а хотелось бы, чтобы отборы взялись из сохраненных параметров формы...

На форме сделал реквизит "НастройкиЗаполнения" с КомпоновщикНастроекКомпоновкиДанных. Отор в этом реквизите поставил как "сохранять"

Как правильно сохранить настройки, а главное как получить эти настройки отборов при открытии формы "Заполнение документов"?


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158129 · Ответов: 2 · Просмотров: 225
 

>  ТЧ: настройка формы с отбором нужных строк с сохранением настроект отбора
Constantus
Отправлено: 27.11.19, 16:34


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, СП, самопис, УФ.

Имеется ТЧ:
Модель (справочник)
Размер (справочник)
Вес (число)
Цена (число)

Необходимо как-то провести визуальный отбор записей по модели, размеру и весу (открывается некая форма, где и производится отбор) и запомнить этот отбор для применения в дальнейшем этого отбора для другого документа.

Далее в этой форме для отбора проставить цену, чтобы эта цена заполнилась в ТЧ...

Основная задача: запомнить фильтр отбора, чтобы каждый раз не заполнять. Т.е. в одном документе нужно настроить 3-и и более отбора, т.к. установка цены различна для разных данных...

Подскажите правильный подход к решению задачи...

Вот в форме списка документа доступна кнопка "Настроить список" и вроде там можно сохранить настройки. А как вставить эту кнопку в список таличной части? Ну если я иду в правильном направлении...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158021 · Ответов: 2 · Просмотров: 225
 

>  Поместить картинку в динамически расширающийся макет печатной формы
Constantus
Отправлено: 27.11.19, 16:01


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Поторопился...

При предварительном просмотре фоновая картинка выходит, но на печать нет... Как фоновую картинку заставить распечатываться?


Если Объект.ВозможностьКредитования Тогда    
        ТабДок.ФоноваяКартинка = БиблиотекаКартинок.Кредит;
        ТабДок.ФиксированныйФон = Ложь;    
    КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158020 · Ответов: 11 · Просмотров: 476
 

>  Параметры отчета: ограничить выбор ПланВидовХарактеристик по папке (родителю)
Constantus
Отправлено: 22.11.19, 9:12


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, самопис, УФ, СП

В отчете в качестве параметра использую "ПланВидовХарактеристик: Производственные статусы".
Эти характеристики разбиты по папкам (группам)

Как можно ограничить список выбора этого параметра по родителю (группе)? Ну чтобы указать в самом отчете ограничения по родителю и при выборе можно использовать только эти значения?

У меня в качестве еще одного параметра используется перечисление, но там в "доступных значениях" можно жестко прописать какие, а с характеристиками как-то не выходит
  Форум: Система компоновки данных · Просмотр сообщения: #157829 · Ответов: 0 · Просмотров: 177
 

>  Поместить картинку в динамически расширающийся макет печатной формы
Constantus
Отправлено: 20.11.19, 17:21


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


fly @ Сегодня, 18:45 * ,


    Если Объект.ВозможностьКредитования Тогда    
        ТабДок.ФоноваяКартинка = Новый Картинка("D:\Кредит01.bmp");// БиблиотекаКартинок.Кредит;
        ТабДок.ФиксированныйФон = Ложь;    
    КонецЕсли;



БиблиотекаКартинок.Кредит - тоже работает
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157746 · Ответов: 11 · Просмотров: 476
 

>  Поместить картинку в динамически расширающийся макет печатной формы
Constantus
Отправлено: 20.11.19, 14:13


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Выкрутился применив фоновый рисунок. Правда фоновый рисунок пришлось расширить границы рисунка до невозможного, иначе изображение клонируется на экране.

Есть возможность фоновый рисунок не клонировать по всему экрану, а только единыжды?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157737 · Ответов: 11 · Просмотров: 476
 

>  Поместить картинку в динамически расширающийся макет печатной формы
Constantus
Отправлено: 20.11.19, 12:42


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Картинку выводит, но после вывода всех:

    ОбластьЦена     = Макет.ПолучитьОбласть("Цена");
    ОбластьЦена.Параметры.ЦенаКомплекта = Формат(Объект.ЦенаКомплекта, "ЧЦ=15; ЧДЦ=2");
    ТабДок.Вывести(ОбластьЦена);
    
    Область = Макет.ПолучитьОбласть(5,1,14,3);

Рисунок = Область.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
// указываете размещение и размеры рисунка
Рисунок.Лево =12;
Рисунок.Верх=0;
Рисунок.Ширина=40;
Рисунок.Высота=30;
// указываете непосредственно картинку из нового элемента картинка или библиотеки
Карт = БиблиотекаКартинок.Ретушь;
Рисунок.Картинка = Карт;
// выводите область на печать
ТабДок.Вывести(Область);
    
Возврат ТабДок;


Можно ли как-то вверх поднять над всем макетом?

fly @ Сегодня, 16:31 * ,

так в том и суть, что нужно разместить не в конкретной области, а над всеми областями..., т.е. над областью "ПерваяОбласть" и "Вторая область"... после их вывода на экран...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157729 · Ответов: 11 · Просмотров: 476
 

>  Поместить картинку в динамически расширающийся макет печатной формы
Constantus
Отправлено: 20.11.19, 12:21


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


fly @ Сегодня, 15:01 * ,

Красиво, но

Область = Макет.ПолучитьОбласть("");


Область не найдена...

У меня 3-и наименованные области... Может есть смысл как-то поиграться с получением области в формате R12C1:R14C3

R12 - начало первой области

R14 - начало второй области

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157727 · Ответов: 11 · Просмотров: 476
 

>  Поместить картинку в динамически расширающийся макет печатной формы
Constantus
Отправлено: 20.11.19, 10:27


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, СП, самопис, УФ.

Пытаюсь сотворить ценник. В макете есть 2-е области, которые динамически расширяются в зависимости от количества данных заполнения (от 1 до много строк).

Имеется картинка "Кредит", которая должна появится на ценнике в зависимости от того, можно или нет оформить кредит (на форме галочка).

Как можно разместить эту картинку поверх макета после того, как ценник будет сформирован? Т.е. сначала получить итоговой ценник, потом разместить картинку и расположить её на макете в зависимости от высоты итогового ценника?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157722 · Ответов: 11 · Просмотров: 476
 

>  Не дотягивает до "ОбработкаВыбора" из ОповеститьОВыборе(АдресРезультата);
Constantus
Отправлено: 15.11.19, 16:53


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


pablo @ Сегодня, 15:47 * ,

Поторопился с вопросом. Надо было просто сначала кофе выпить, а потом понять, что простое копирование кода не означает, что этот код удет прикреплен автоматически к событиям
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157588 · Ответов: 2 · Просмотров: 234
 

>  Не дотягивает до "ОбработкаВыбора" из ОповеститьОВыборе(АдресРезультата);
Constantus
Отправлено: 15.11.19, 10:56


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветсьвую, Форумчане!
1с8.3.12, СП, самопис, СП

Есть некий механизм, который в одной из форм по кнопке открывает дополнительную форму для отора строк ТЧ по галке, Далее создается документ с выранные строками. Это работает...

Теперь по полному образу и подобию создал этот механизм в другом документе, т.е. со всеми кодами и т.д. Визуально всё срабатывает, выбор, создание документа и т.д., за исключением момента.

    АдресРезультата = "";
    СоздатьПеремещениеНаСервере();

    Если ЭтоАдресВременногоХранилища(АдресРезультата) Тогда
        ОповеститьОВыборе(АдресРезультата);    
    КонецЕсли;


Не срабатывает оповестить о выборе, т.е. не доходить до "Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)" и соответственно не сраатывает "ЗаполнитьПеремещения(ВыбранноеЗначение);" в последней процедуре:

&НаКлиенте
Процедура ПередачаВПроизводство(Команда)
    
    Адрес = ПолучитьАдресВоВременномХранилище();
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Адрес", Адрес);
    ПараметрыФормы.Вставить("Основание", Объект.Ссылка);

    
    ОткрытьФорму("Документ.ПроизводственноеЗадание.Форма.ФормаСозданияДокументаПередачи", ПараметрыФормы, ЭтотОбъект,,,,
        Новый ОписаниеОповещения("СоздатьПеремещениеЗавершение", ЭтотОбъект), РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);

КонецПроцедуры

&НаКлиенте
Процедура СоздатьПеремещениеЗавершение(Результат, ДополнительныеПараметры) Экспорт
        
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    //Вставить содержимое обработчика
    
    Если ТипЗнч(ИсточникВыбора) = Тип("УправляемаяФорма")
        И ИсточникВыбора.ИмяФормы = "Документ.ПроизводственноеЗадание.Форма.ФормаСозданияДокументаПередачи" Тогда
        ЗаполнитьПеремещения(ВыбранноеЗначение);
    КонецЕсли;
    
    
КонецПроцедуры


Где и что я недотянул? Из-за того, что не сраатывает обраотка выбора не заполняются данные по ЗаполнитьПеремещения...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157576 · Ответов: 2 · Просмотров: 234
 

>  Отбор в запросе по определенным типам документов из регистра накопления
Constantus
Отправлено: 04.11.19, 9:28


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3, самопис, УФ, БСП

Имеется некий запрос, который по идее должен из регистра накопления вывести только определенные типы документов:

ИЗ
    РегистрНакопления.КосвенныеЗатратыКРаспределению КАК КосвенныеЗатратыКРаспределению
ГДЕ
    КосвенныеЗатратыКРаспределению.Период <= &ДатаОкончания
    И КосвенныеЗатратыКРаспределению.Документ.ЗаМесяц = &МесяцБюджета
    И (КосвенныеЗатратыКРаспределению.Документ ССЫЛКА Документ.СписаниеСРасчетногоСчета
            ИЛИ КосвенныеЗатратыКРаспределению.Документ ССЫЛКА Документ.ЗаявкаНаОплату
            ИЛИ КосвенныеЗатратыКРаспределению.Документ ССЫЛКА Документ.РасходныйКассовыйОрдер
            ИЛИ КосвенныеЗатратыКРаспределению.Документ ССЫЛКА Документ.КорректировкаНеоплаченногоОстаткаПоЗаявкам)




Никак не могу сообразить что не так и результатом запроса выходят все документы? Например выходит документ "РаспределениеЗатрат"...

И КосвенныеЗатратыКРаспределению.Документ ССЫЛКА Документ.СписаниеСРасчетногоСчета


Так срабатывает и отбирает только этот тип документов. Стоит доавить ИЛИ и всё ломается.
Что я упустил?


Constantus @ Сегодня, 12:53 * ,

Вопрос снят... невнимательность моя
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157188 · Ответов: 1 · Просмотров: 877
 

>  Доступ к элементам справочника "Склады", помеченных на удаление
Constantus
Отправлено: 31.10.19, 17:13


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


pablo @ Сегодня, 20:55 * ,
Да, уже обсуждали, но как часто нужно это чистить и на каком событии...

По ольшому счету нужно изавится в истории только от "пробельного" склада? Если чистить кэш каждый раз при входе в систему, то история то удалится и типа опять копи историю с правильными складами :-)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157103 · Ответов: 6 · Просмотров: 375
 

>  Доступ к элементам справочника "Склады", помеченных на удаление
Constantus
Отправлено: 31.10.19, 16:40


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Vofka @ 28.10.19, 13:11 * ,
Если же без доработок программы, можно просто переименовать склады таким образом, чтобы никто случайно не ввел название.

Хороший метод, действительно не ищет по вводу по строке, если несколько пробелов поставить, но вот если этот склад ранее участвовал в заполнении реквизита, то если нажать стрелочку <----- на этом реквизите, то он вспомнит всех, кто когда-то участвовал в выборе, в том числе и склад с пробелами. Как можно поороть эту злопамятную стрелочку?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157101 · Ответов: 6 · Просмотров: 375
 

>  Доступ к элементам справочника "Склады", помеченных на удаление
Constantus
Отправлено: 26.10.19, 16:43


Ветеран
*******

Группа: Пользователи
Сообщений: 867
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, Форумчане!
1с8.3.12, БСП, УФ, самопис

Так уж получилось, что имеется огромное количество складов, которые помечены на удаление.
К сожалению, у пользователей есть возможность выбирать склады вводом по строке, что позволяет по невнимательности, да и не знанию, вводить склады помеченные на удаление.

Есть ли возможность "одним махом" ограничить всех пользователей, кроме какой-нить роли, на возможность видеть, редактировать, выирать и т.д. эти удаленные склады? Краем уха слышал, что можно как-то через РЛС в БСП...

Можете подсказать? Переделывать огромное количество документов, справочников, отчетов СКД это катастрофа...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156930 · Ответов: 6 · Просмотров: 375
 

35 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 29.02.20, 15:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!