Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



11 страниц V   1 2 3 > » 

>  Как создать документ из справочника контрагентов?
Sharzem
Отправлено: 27.03.20, 10:13


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(4andriy @ 25.03.20, 16:24) *
выбрать контрагента из справочника и выписать документ

Цитата(4andriy @ 26.03.20, 19:53) *
задача скопіювати вже створений перед тим заповнений документ і тоді тільки поправити

Це все зовсім різне.
Цитата(4andriy @ 26.03.20, 19:53) *
додав в ПриОткрытии код щоб дані виділеного контера переносились

Реалізовано не вірно, оскільки ТекущийЭлемент() для документу в процедурі ПриОткрытии() не є напередвизначеним параметром, доступ до нього можливий лише через Форма.Параметр.
Цитата(4andriy @ 26.03.20, 19:53) *
ОткрытьФорму("Документ.Накладная.7140",ТекущийЭлемент());

Повна несінитниця...
Цитата(Prospero @ 26.03.20, 21:57) *
в моем примере и подразумевают часть кода, заполняющего документ данными из справочника...

Та Ви що.... 47067070.gif

4andriy @ 25.03.20, 16:24 * ,
Опишіть в чому полягає суть завдання. З того, що Ви нагородили вже нічого не зрозуміло.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161707 · Ответов: 9 · Просмотров: 325
 

>  Как создать документ из справочника контрагентов?
Sharzem
Отправлено: 26.03.20, 10:29


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Prospero @ Вчера, 22:30 * ,
Ні, не вірно. В Вашому прикладі будуть створюватися пусті документи які будуть нікому не потрібні.
По перше, в документі в процедурі ПриОткрытии() необхідно:
Процедура ПриОткрытии()
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
        Если ТипЗначения(Форма.Параметр) = 11 Тогда
            Контрагент = Форма.Параметр;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

По друге, визивати з модуля довідника потрібно наступним чином:
    Если ТекущийЭлемент().ЭтоГруппа() = 0 Тогда
        ОткрытьФорму("Документ.Ваш_документ",ТекущийЭлемент());
    КонецЕсли;

При такому розвитку, введення Нового документу можливо припинити, оскільки відсутній метод Документ.Записать().
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161669 · Ответов: 9 · Просмотров: 325
 

>  Мария 301 МТМ «Невозможно открыть COM порт»
Sharzem
Отправлено: 21.03.20, 9:19


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Номер порта в конфігурації чи в налаштуваннях зазначено вірно?
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #161515 · Ответов: 4 · Просмотров: 203
 

>  Добавить графу в журнале счетов
Sharzem
Отправлено: 12.03.20, 9:51


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(aldem @ 05.03.20, 16:23) *
Как сделать, чтобы только после оплаты в этой графе появлялся номер подчинённой накладной

Якщо кількість підзвітних документів буде більше 1, а кількість стрічок у Вас = 1, як Ви збираєтесь їх туди засунути? Та й для чого ?
Правою кнопкою миші клацаєте на потрібному документі. У випавшому меню вибираєте "Подчиненные документы" і все.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161248 · Ответов: 3 · Просмотров: 1752
 

>  Создать обновление цен в накладной при копировании старой
Sharzem
Отправлено: 11.03.20, 13:30


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


denis84 @ Сегодня, 11:44 * ,
Цитата(denis84 @ 10.03.20, 9:02) *
получать последнюю цену товара на дату документа

Якщо такого в конфігурації немає на те є певна причина.

Цитата(Danaza @ 09.03.20, 14:42) *
поменять можно только вручную

Невідомо який там принцип товарного обліку, якщо є така можливість.

Цитата(denis84 @ 11.03.20, 11:44) *
Автор спросил, можно сделать, я ответил что можно!

Цитата(denis84 @ 10.03.20, 9:02) *
Можно сделать кнопку "пересчет цен"

Якщо вже на те пішло і немає партійного обліку, навіщо кнопка ?

Дивимося процедуру ВводНового() та задаємо умови:
Процедура ВводНового(ПризнакКопирования)
    Если ПризнакКопирования = 1 Тогда
        ПересчитаемТабличнуюЧасть()
    КонецЕсли;
КонецПроцедуры

Також, не забуваємо про зміну дати в документі, туди також слід навішати процедуру. Крім того, необхідно встановити недоступність зміни дати проведених документів.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161195 · Ответов: 5 · Просмотров: 232
 

>  Создать обновление цен в накладной при копировании старой
Sharzem
Отправлено: 11.03.20, 10:16


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(denis84 @ 10.03.20, 9:02) *
Можно сделать кнопку "пересчет цен"

Да ? А якщо облік по партіям ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161191 · Ответов: 5 · Просмотров: 232
 

>  Как создать поиск клиента по номеру телефона
Sharzem
Отправлено: 11.03.20, 9:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Danaza @ 09.03.20, 14:56 * ,
Потрібно в довіднику Ваших "Клієнтів" перевірити усі номери телефонів, щоб вони відповідали одному формату. Тобто, як наприклад, довжина номеру телефону не повинна перевищувати 10 цифр і має починатися з 0. Це необхідно виконати "руцями", оскілльки там можуть бути пробіли або символи (, ), +, починатися з 3 або 8. Можна і автоматом, але це потрібно дивитися.
В процедурі ПриЗаписи(), в модулі довідника необхідна перевірка на коректність (відповідність) номеру потрібному формату.
Приклад:
Функция РазобратьСтрокуНаЧисла(прСтрока)
    лпСтрока = прСтрока;
    лпКолСимв = СтрДлина(лпСтрока);
    лпИвлЧисла = "1234567890";
    лпСтрВозврата = "";
    Для к = 1 По лпКолСимв Цикл
        лпСимв = Сред(лпСтрока,к,1);
        Если Найти(лпИвлЧисла,лпСимв) <> 0 Тогда
            лпСтрВозврата = лпСтрВозврата+Строка(лпСимв);
        КонецЕсли;
    КонецЦикла;
    Если Лев(лпСтрВозврата,1) = "3" Тогда
        лпСтрВозврата = Сред(лпСтрВозврата,2,СтрДлина(лпСтрВозврата));
    КонецЕсли;
    Если Лев(лпСтрВозврата,1) = "8" Тогда
        лпСтрВозврата = Сред(лпСтрВозврата,2,СтрДлина(лпСтрВозврата));
    КонецЕсли;
    Если (Лев(лпСтрВозврата,1) <> "0") или (СтрДлина(лпСтрВозврата) <> 10)  Тогда
        лпСтрВозврата = "";
    ИначеЕсли (Лев(лпСтрВозврата,2) = "02") или (Лев(лпСтрВозврата,2) = "03") Тогда
        лпСтрВозврата = "";
    КонецЕсли;
    Возврат лпСтрВозврата;
КонецФункции // РазобратьСтрокуНаЧисла

Процедура ПриЗаписи()
    Если ПустаяСтрока(РазобратьСтрокуНаЧисла(Телефон)) = 1 Тогда    
        Сообщить("Введен некорректный номер телефона !");
    КонецЕсли;
КонецПроцедуры

Далі в процедурі, що відповідає за пошук дисконтної карти по номеру добавити пошук клієнта по номеру телефона, якщо не знайдена дисконтна карта.
Можна наприклад, побудувати запрос:
    лпТекст = "
    |Телефоны = Справочник.Клиенты.Телефоны;
    |Клиент = Справочник.Клиенты.ТекущийЭлемент;
    |Группировка Клиент без групп;
    |Условие (ПустаяСтрока(Телефоны) = 0);
    |Условие(Лев(Телефоны,лпСтрДлина) = лпКод);";

    Запрос = СоздатьОбъект("Запрос");
    лпТаблЗнач = СоздатьОбъект("ТаблицаЗначений");
    Если Запрос.Выполнить(лпТекст) = 1 Тогда
        Запрос.Выгрузить(лпТаблЗнач,1,0);
        лпТаблЗнач.ВыбратьСтроку();
    КонецЕсли;

В загальному це все, але це тільки приклад.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161189 · Ответов: 2 · Просмотров: 198
 

>  Какую 1с вибрать
Sharzem
Отправлено: 15.01.20, 15:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(Dll @ 07.01.20, 1:19) *
ТиС для України 7.70.026. Но я так понял, что ето очень древняя штука, конторах уже отжила


Ще не вмерла...
І буде жити допоки існуватимуть "древние" контори, бо задовільняє усі потреби. Поки є люди чиї руки виросли звідки потрібно ніхто нічого змінювати не буде.
Я навіть не знаю який має вигляд 8х crazy.gif
  Форум: Помогите подобрать конфигурацию · Просмотр сообщения: #159367 · Ответов: 3 · Просмотров: 299
 

>  не могу обработать значение
Sharzem
Отправлено: 15.01.20, 15:02


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(4andriy @ 13.01.20, 14:45) *
Многострочная часть

Цитата(4andriy @ 13.01.20, 14:45) *
ТекущийЭлемент().Сум


ТекущийЭлемент у Вас довідник, який швидше за все має реквізит Сум. Значення цього реквізиту = ПустоеЗначение() тому і не працює.
Швидше за все має бути Количество * Цена. Я так вважаю.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #159366 · Ответов: 4 · Просмотров: 286
 

>  Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
Sharzem
Отправлено: 25.10.19, 7:17


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 23:04 * ,
Цитата
Як при виборі закладок викликати СПЛАЧЕНО?

Процедура Сплачено()                   
    Если Спл=0 тогда
        Форма.СПЛАЧЕНО.Видимость(0);
    Иначе
        Форма.СПЛАЧЕНО.Видимость(1);
    КонецЕсли;
КонецПроцедуры

Процедура ПриВыбореЗакладки(Номер,Значение)
       .......
       Сплачено();
КонецПроцедуры

Процедура ПриОткрытии()
       ......
       ПриВыбореЗакладки(1,"Основной");
КонецПроцедуры

Все.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156888 · Ответов: 14 · Просмотров: 617
 

>  Как текст на форме сделать невидимым? Проблема 1С 7.70.003 торговля склад для Украины?
Sharzem
Отправлено: 24.10.19, 17:30


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(volodya1122 @ 24.10.19, 10:14) *
В 1с7 повноцінних закладок немає

44000000.gif
Цитата(volodya1122 @ 24.10.19, 10:14) *
Попробую пояснити те що написала nysysimara

Цитата(volodya1122 @ 24.10.19, 10:14) *
Процедура ПриВыбореЗакладки виконується пільки при відкритті форми справочника (в даному випадку) і при виборі закладки.

Цитата(volodya1122 @ 24.10.19, 10:14) *
4. При відкритті форми флажок "Спл" мав би дорівнювати нулю (якшо інше не задано прорамою. Або це не реквізик справочника.

Цитата(volodya1122 @ 24.10.19, 10:14) *
5. Коли на формі ви міняєте значення флажка тоді потрібно на флажок повісити виклик процедури ПриВыбореЗакладки(1,"Основной") або іншої, яка б міняда видимість/доступність іншого реквізиту.

faceoff.gif
12201689.gif
Еххх, Вова, Вова... Нагородив городу... Це Вам не найвища математика. Тут людині потрібно при відкритті викликати ПриВыбореЗакладки() та при виборі закладки викликати Сплачено()... А Ви стільки всього нагородили.....

Nysysimara також... Мабуть, 7.7. вже забули...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156862 · Ответов: 14 · Просмотров: 617
 

>  Можно ли сделать автоматическое обновление отчета? 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 20.10.19, 8:48


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 19:29 * ,
Можна виконувати постійне оновлення звіту через певний проміжок часу... Постійно потрібно опитувати відкриті в даний час вікна і при активації форми сформованого звіту оновити його якщо сплив потрібний час. Без компоненти Formex та його об'єктів "РасширениеФормы" та "Окна" не обійтися. Це буде таке собі збочення. Простіше натискати кнопочку.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156698 · Ответов: 4 · Просмотров: 515
 

>  Как изменить реквизит ВыбратьПериод в 1с 7.7 конф 7.7.003
Sharzem
Отправлено: 23.09.19, 7:18


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


44000000.gif
Виборкою чи запитом при таких умовах... це жах. Якщо воно так Вам конче потрібно - створіть новий документ, назвіть його "Видача видаткових накладних", він підпорядкується Видатковій (вим) накладній (ним) і з ним далі вже працюйте... Тоді Ви зможете отримати необхідний Вам функціонал без спотворювання форми самої Видаткової накладної, а також будувати звіти на тему: хто, коли, з ким, де, кому видав ТМЦ по видатковій накладній.

1. На сьогодні Ви постійно теліпаєте Видаткову накладну, змінюєте реквізити, перепроводжуєте.
2. Той реквізит про який йде мова, краще діставати прямим запитом, але при величезній кількості документів це все одно буде займати час.

Краще, на мою думку, створити новий документ.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155861 · Ответов: 18 · Просмотров: 1227
 

>  Импорт из Аваль Банка
Sharzem
Отправлено: 06.09.19, 16:33


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(bezzil @ 06.09.19, 13:59) *
приходится насиловать этот труп.

faceoff.gif

Він ще живий і може старітися разом з Вами...

Не полінувався, знайшов тут на стор. 46, 47

Там немає нічого особливого.
Відбулося зміщення полів. Їх потрібно "вирівняти" на своє місце. В описі все є. Як не справитесь - гукніть, накинемо двійку стрічок для виправлення.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155402 · Ответов: 16 · Просмотров: 1092
 

>  Импорт из Аваль Банка
Sharzem
Отправлено: 06.09.19, 12:46


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


bezzil @ Сегодня, 12:30 * ,
Можете викласти, що повертає стр = OemToAnsi(ФайлТекст.ПолучитьСтроку(ном)); ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155393 · Ответов: 16 · Просмотров: 1092
 

>  Импорт из Аваль Банка
Sharzem
Отправлено: 06.09.19, 12:19


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


bezzil @ Сегодня, 11:00 * ,
Для ном=1 по ФайлТекст.КоличествоСтрок() Цикл 
    стр = OemToAnsi(ФайлТекст.ПолучитьСтроку(ном));  
    Если Лев(стр,1) = "0" Тогда
        Если (Число(Сред(стр,2,14)) <> Число(ВыбСчет.Номер)) или (Сред(стр,16,8) <> Формат(Дата1,"ДГГГГММДД")) Тогда
//            Сообщить("Ошибка! Проверьте сохранение выписки");
//            Возврат;
              ррр = 0;
              Продолжить;
         КонецЕсли;
        ррр = 1;
        СчетОсн = Число(Сред(стр,2,14));
        ДатаВ = Сред(стр,16,8);
    ИначеЕсли (ррр = 1 ) и (Лев(стр,1) = "1") Тогда    
        Если (Число(Сред(стр,12,14)) <> Число(ВыбСчет.Номер)) и (Число(Сред(стр,89,14)) <> Число(ВыбСчет.Номер)) Тогда  
//            Сообщить("Ошибка! Проверьте сохранение выписки");
//            Возврат;
               Продолжить;
        КонецЕсли;


(Число(Сред(стр,2,14))
(Число(Сред(стр,12,14))
(Число(Сред(стр,89,14))
порівнюється з Число(ВыбСчет.Номер)) Нічого Вас тут не бентежить ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155391 · Ответов: 16 · Просмотров: 1092
 

>  Как зафиксировать шапку таблицы отчета 1с 7.7 конф 7.7.00
Sharzem
Отправлено: 06.09.19, 9:06


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ Вчера, 0:26 * ,
Те саме, лише без попередньго підрахунку стрічок.
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("БАЗА комп");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0)
ТЗ.ВыбратьСтроки();
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155386 · Ответов: 2 · Просмотров: 534
 

>  Не подсвечивается цветом ТЗ в 1С 7.70.003 торговля склад для Украины?
Sharzem
Отправлено: 06.08.19, 14:34


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


ZUBR @ 03.08.19, 17:28 * ,
Уххх, 44000000.gif
1. ТЗ має бути розташована на формі звіту (обробки).
2. Обов'язково в ТЗ має бути така колонка як FormEx_ПланРаскраски.
Від автора:
Цитата
Для ускорения и упрощения работы раскраски таблиц в компоненту с версии 2.0.5.85 введен функционал плана раскраски таблицы. Для его активизации необходимо вызвать метод ИспользоватьПланРаскраски() объекта Сервис с параметром 1 (соответсвенно, для отключения и перехода на старый принцип раскраски надо вызвать тот же метод, но с параметром 0). По умолчанию функционал плана раскраски отключен и работает старая методика раскраски.
Для реализации раскраски по новому функционалу плана раскраски, необходимо добавить в раскрашиваемую таблицу колонку с заголовком ''FormEx_ПланРаскраски'' (без кавычек, регистронезависимо). Колонка может располагаться в любом месте таблицы. Содержимое этой колонки задает план раскраски таблицы, основанный на тех же макросах, которые описаны в части ''Раскраска таблиц''. При этом макросы COUNT и INDENT не обрабатываются. В плане раскраски каждая ячейка текущей строки определяется круглыми скобками. В плане учитываются как видимые, так и невидимые колонки. Макросы раскраски надо помещать в места, соответсвующие смене раскраски. Несколько примеров помогу лучше понять этот принцип.

3. Як приклад можете подивитися тут: Тиць
4. Речі висвітлені Вами:
ТЗ.ВыбратьСтроку(); 
         Таб = СоздатьОбъект("Таблица");

Взагалі не мають до FormEx жодного відношення.

5. Версія 1С 7.70.003 !!!, Вам перейти на 1С 7.70.027 релігія не дозволяє ? Ё-ма-ё.... Не витрачайте свій час...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #154449 · Ответов: 13 · Просмотров: 1974
 

>  комментарий к номенклатуре из формы списка
Sharzem
Отправлено: 29.11.18, 14:43


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Цитата(4andriy @ 28.11.18, 12:01) *
Хочу открыть справочник номенклатуры, есть колонка "Скидка". Добавил кнопку "Скидка". Нужно не открывая саму позицию нажать на кнопку и что-бы в текущей строке был добавлен нужный текст.


1. Довідники на платформі 7.7. ніколи не мали табличних полів, тому колонка "Скидка" в формі довідника може відображуватися у вигляді Таблиці значень яка в свою чергу може заповнюватися як приклад, з підчинених довіднику довідників.
2. Облік товарів (в плані ціноутворення) на різних платформах обліковується по-різному (FIFO, LIFO, середньому)
3. Зважаючи на п. 2 Ви не можете універсально виконувати ті дії які викладені в Вашій процедурі (то зовсім не туди).
4. Цілком підтримую позицію шановного mister-x і рекомендую Вам замість кнопки в формі списку довідника вивести додатково поле з функцією яка поверне Вам 2 ціни: 1 звичайна, вона в Вас вже є (незрозуміло як вона розраховується і від яких чинників залежить, оскільки дуже мало інформації про те з чим Ви працюєте) та 2 - ціна із знижкою.

Якби я був Вашим роботодавцем я б Вам задав одне питання: накой Вам розмір знижки на формі довідника ?

Будь-ласка, почніть з початку питання, що Вам потрібно зробити в цілому, а не лише кусочок якоїсь незрозумілої нам ідеї. Ваші питання розглядають спеціалісти з багаторічним досвідом і те що Ви намагаєтеся реалізовувати це дрібниці... Головне правильно описати завдання.

volodya1122 @ Сегодня, 10:51 * ,

volodya1122, Ви що просто познущалися ?
А він візьме і вставить Ваш кусок кода...
Добре якщо в довідник "Номенклатура" friends.gif
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #147634 · Ответов: 19 · Просмотров: 977
 

>  Варианты настройки 1С 7.7 win2008 + удаленный SQL 2000
Sharzem
Отправлено: 16.11.18, 14:20


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Talkman @ Сегодня, 14:11 * ,
Заметил что Вы из Черкасс... Я там обучение проходил на Кварце, ул. 30-Летия Победы, 30.
Когда-то были там сильные системщики... Программистов тогда они обижали когда-то... Было это перед первым Майданом....
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #147221 · Ответов: 13 · Просмотров: 746
 

>  Варианты настройки 1С 7.7 win2008 + удаленный SQL 2000
Sharzem
Отправлено: 16.11.18, 14:07


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Ай-яй-яй:
Идем в скуль, разворачиваем "базы данных" - "системные базы данных" - "master", тыкаем на "представления"(на ангельском языке - views), выбираем "создать представление". Если выскочило "добавление таблицы", жмакаем закрыть, в поле кода (там по дефолту стоят select и from) копируем следующий текст: select * from sysprocesses where cmd <> 'checkpoint' и нажимаем кнопку "выполнить код sql" (находится выше слева, красный восклицательный знак), если код поменялся и не выскочило ошибок - это хорошо, жмем сверху кнопку "сохранить" и называем это представление вот так: sksprocesses

Может не одобрить Администрация...

Че Вам мешает поднять SQL до 2008 ?
Проще обслуживать.
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #147219 · Ответов: 13 · Просмотров: 746
 

>  ошибка с импортом из Excel
Sharzem
Отправлено: 15.11.18, 16:38


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


4andriy @ Сегодня, 17:19 * ,
Ще раз. Що вертає:
Сообщить(Реквизит(СпсРек.ПолучитьЗначение(Ном)));


???

Ругається на те що не може створити ТабЗн Нову колонку з ідетифікатором який вертає Функція Реквизит(Стр,Режим=3)
Перевірте будь-ласка.

В стрічці 133:
СпсРек.ДобавитьЗначение(ТипРек+";"+СокрЛП(Строка(Ном))+";"+Метаданные.Справочник(НомСпр).Реквизит(КолРек).Идентификатор);


Заменіть на
СпсРек.ДобавитьЗначение(Лев(ТипРек,1)+";"+СокрЛП(Строка(Ном))+";"+Метаданные.Справочник(НомСпр).Реквизит(КолРек).Идентификатор);


Має бути все гуд.

PS: Не тестував.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #147192 · Ответов: 7 · Просмотров: 704
 

>  Варианты настройки 1С 7.7 win2008 + удаленный SQL 2000
Sharzem
Отправлено: 15.11.18, 16:22


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Без різниці, буде працювати нормально. З підводних каменів, як зазвичай "Язык и региональные стандарты = Русский"
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #147191 · Ответов: 13 · Просмотров: 746
 

>  ошибка с импортом из Excel
Sharzem
Отправлено: 15.11.18, 16:06


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


4andriy @ Сегодня, 16:57 * ,
126 строка в обробці:
ТипРек=Лев(Метаданные.Справочник(НомСпр).Реквизит(КолРек).Тип,4);

але то не критично....

Отут щось не те:
Функция Реквизит(Стр,Режим=3)
//Режим 1-Тип, 2 - Номер, 3 - Наименование
Перем МСтр;
    Если Режим=1 Тогда
        Возврат Лев(Стр,1);
    ИначеЕсли Режим=2 Тогда
        МСтр=Прав(Стр,СтрДлина(Стр)-2);
        Возврат Лев(МСтр,Найти(МСтр,";")-1);
    Иначе
        МСтр=Прав(Стр,СтрДлина(Стр)-2);
        МСтр=ВРег(Прав(МСтр,СтрДлина(МСтр)-Найти(МСтр,";")));
        Возврат МСтр;
    КонецЕсли;
КонецФункции


А якщо перед
ТабЗн.НоваяКолонка(Реквизит(СпсРек.ПолучитьЗначение(Ном)));

добавити:
Сообщить(Реквизит(СпсРек.ПолучитьЗначение(Ном)));

???
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #147186 · Ответов: 7 · Просмотров: 704
 

>  Варианты настройки 1С 7.7 win2008 + удаленный SQL 2000
Sharzem
Отправлено: 15.11.18, 15:06


Оратор
Иконка группы

Группа: Местный
Сообщений: 261
Регистрация: 09.02.12
Пользователь №: 14875


Ви думаєте що таким чином зможете вирішити проблеми з прінтерами ?
Проадмініструйте їх і не шукайте собі додаткової роботи.
З приводу запитання: нічого не зміниться (моя особиста думка).
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #147170 · Ответов: 13 · Просмотров: 746
 

11 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 04.04.20, 8:07
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!