Версия для печати темы (https://pro1c.org.ua/index.php?s=b5bf511ad8e076f28ad3801bf29dbb4c&showtopic=66726)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Не получается получить доступ к реквизиту формы

Автор: Eskin 11.09.21, 22:39

Доброго времени суток.

1С:Предприятие 8.3 (8.3.16.1224)
Управление небольшой фирмой для Украины, редакция 1.6 (1.6.11.1)

Слабо знаком с управляемыми формами, поэтому прошу помощи.
Если коротко, то задача состоит вот в чем: необходимо из формы внешней обработки редактировать некоторые реквизиты документа ЗаказПокупателя с дальнейшей записью документа. Создал две формы во внешней обработки (для списка и документа), в форме "документа" создал реквизит Заказ типа ДокументСсылка.ЗаказПокупателя и Комментарий типа Строка.

Вот так я получаю данные конкретного документа:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("ЗаказДанные") Тогда

         Заказ = Документы.ЗаказПокупателя.НайтиПоНомеру(Параметры.ЗаказДанные.Номер, Параметры.ЗаказДанные.Дата);
        
    КонецЕсли;
КонецПроцедуры


А вот в процедуре
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();

    Комментарий = Заказ.Комментарий;
    
КонецПроцедуры


выдает ошибку "Поле объекта не обнаружено (Комментарий)".

В процедуре На сервере в отладчике я полностью вижу объект Заказ - могу отрыть плюсик и увидеть все данные, но после выхода из процедуры плюсик пропадает. Видимо я чего-то не знаю при работе с УФ. Подскажите, где я туплю. Заранее спасибо.

Автор: assist2erp 12.09.21, 6:53

В процедуре ПриСозданииНаСервере на входе у вас есть ссылка. По ссылке с помощью ОбщегоНазначения.ЗначенияРеквизитовОбъекта получаете все реквизиты документа которые вам необходимы на форме. Производите ваши действия на форме, в обработчике команды записи проверяете введенные значения, собираете все нужные вам данные в структуру и передаете в процедуру модуля обработки и там записываете измененные данные документа.

Тяжело переходить с 77 на 8, и тем более на УФ.wink.gif
Это нужно понять один раз разделение на клиент/сервер, и дальше будет все ОК

Автор: Vofka 12.09.21, 14:25

Eskin, а почему вы не заполняете комментарий в ПриСозданииНаСервере?
На клиенте нельзя обратиться через точку к реквизитам ссылки.

Автор: Eskin 13.09.21, 8:14

assist2erp @ Вчера, 7:53 * ,

Благодарю! Это ценная инфа.

Vofka @ Вчера, 15:25 * ,

Это решение было настолько простым, что я до него не додумался. Спасибо!

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua