Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику vadim007 ::: Спасибо сказали: 205 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
20.08.15, 9:54 Как найти ошибку? 7.7 - 8.2 УТП
http://files.d-lan.dp.ua/download.php?file...aae6aacecb11e43
В общем, пытался разобраться, поудалял "лишние" правила - все равно была ошибка.
Не стал дальше копать, создал новую конвертацию с единственным правилом Касса - заработало.
Единственный минус - даже если денежный счет безнальный, его папка все равно выгружается. Как это убрать - пока не знаю.
yurvic,
18.08.15, 11:48 Рейтинг и ТОП 100
Цитата(mister-x @ 18.08.15, 12:03) *
хм, можна на майбутнє, заборонити користувачам, в яких репутація нижче n, жалітися, а також писати в ПП: буває, що просять щось скинути в ПП (а ще щойно зареєструвались), а на форумі нульова активність - дописів немає взагалі; а буває взагалі користувач на форумі читач і щось просить...
ще можна подумати про обмеження завантаження з "Хранилища" по рівню репутації і кількістю дописів

Я против - не нужно повторения пути infostart.ru. Так скоро и до монетизации дойдем.
Kutuzov,
07.08.15, 7:27 Предприятие 7.7 Установка Списка значений в Таблицу Значений
Цитата(Sharzem @ 06.08.15, 23:25) *
зірка в шоці

Как только это просмотрели?!:
Цитата(Sharzem @ 06.08.15, 23:25) *
лпЗначение = лпТЗ.ПолучитьЗначение(лпСч,"Параметры");
лпЗначение.Установить("Значение",лпНовоеЗначение);

Ведь в ячейках таблицы хранятся ссылки на список значений. Получили ссылку - и работаем с ней как со списком. И не нужно снова сохранять ее в лпТЗ.
Дальше только рассуждения:
лпЗначение - локальная переменная, имеющая свой адрес. Операция лпЗначение = лпТЗ.ПолучитьЗначение(лпСч,"Параметры") присваивает ей адрес списка значений. А вот операция лпТЗ.УстановитьЗначение(лпСч,"Параметры",лпЗначение) сохраняет в ячейке таблицы адрес не списка значений, а адрес переменной лпЗначение. Вот и получается, что все ячейки Параметры в лпТЗ забиты адресом переменной лпЗначение. В конце цикла лпЗначение ссылается на последний полученный список значений. Откуда и выходит, что всей ячейки Параметры в лпТЗ "забиты" одним списком значений.
Sharzem,
06.08.15, 9:07 Анекдот
К пастуху, пасущему стадо овец, подъезжает на машине какой-то тип, высовывается из окна и говорит:
- Если я тебе скажу, сколько у тебя овец в стаде, ты мне подаришь одну?
Немного удивленный пастух отвечает:
- Конечно, почему бы и нет.
Тогда этот мужик достает ноутбук, подсоединяет его к мобильному
телефону, устанавливает связь с Интернетом, заходит на сайт НАСА,
выбирает спутниковую связь GPS, выясняет точные координаты места, где он находится, и отправляет их на другой спутник НАСА, который сканирует эту местность и выдает фото со сверхвысоким разрешением. Затем этот тип передает снимок в одну из лабораторий Гамбурга, которая через несколько секунд отправляет ему E-mail с подтверждением того, что снимок был обработан и полученные данные сохранены в базе данных. Через ODBC он подключается к базе данных MS-SQL, копирует данные в таблицу EXCEL и начинает производить расчет. Через несколько минут он получает результат и распечатывает в цвете 150 страниц на своем миниатюрном принтере.
Наконец он говорит пастуху:
- У тебя в стаде 1586 овец.
- Точно! Именно столько овец у меня в стаде. Что ж, выбирай.
Мужик выбирает одну и грузит ее в багажник. И тут пастух ему говорит:
- Послушай, а если я угадаю, кем ты работаешь, ты мне ее вернешь?
Немного подумав, мужик говорит:
- Ну давай.
- Ты работаешь консультантом, - неожиданно выдает пастух.
- Это правда, черт возьми! И как же ты догадался?
- Это было легко сделать, - говорит пастух, - ты появился, когда никто тебя не звал, хочешь получить плату за ответ, который я уже знаю, на вопрос, который тебе никто не задавал, и к тому же ты ни хрена не смыслишь в моей работе. ТАК ЧТО ОТДАВАЙ ОБРАТНО МОЮ СОБАКУ.
Acid, mister-x, Pavlik1c,
04.08.15, 4:22 Перенести 7.7 бухгалтерия на 8.2
Цитата(kot488 @ 03.08.15, 17:59) *
Сижу колупаюсь над ней, не хочет выгружать, файл выгрузки не создает. Пробовал создать пустой хмл тоже не вносит в него нечего(((

Посмотрите вот эти уроки:

PS: ключевое слово, почему не получается - "колупаюсь". Измените подход на более системный.
mister-x,
26.07.15, 21:32 Филиппов Е. В., Настольная книга 1С:Эксперта по технологическим вопросам
Еще одна "Настольная книга Эксперта по техническим вопросам.pdf"
В цвете.
Нашел на просторах Интернета.

Настольная книга Эксперта по техническим вопросам
alex-pro, andr_andrey, mister-x, Petre, Pingu, stark, TipsyKID, Vofka,
22.07.15, 11:55 Анекдоты
Собеседование:
— Работодатель (Р) и Соискатель (С):
Р — В своем резюме вы написали, что знаете следующие языки и технологии программирования: Basic (TB, QB, VB, VBA, VB.NET ) C (C and C++ for Unix, FreeBSD, QNX), C++, VC++, C++.NET, C#, в идеале знаете ассемблеры следующих процессоров I-4004 — IP4, Amiga: (ну и тут список на 2 страницы, мелко и подробно). Ну что же, зарплата у нас по договоренности, но гор золота мы вам не обещаем. Максимум на что вы можете расчитывать это 300 тыс Евро.
С — !?!?!?
Р — И только не надо весь рабочий день мечтать о коттедже на Канарах, максимум, что мы можем предложить нашим сотрудникам — это 5-комнатную квартиру в центре Москвы.
С — пытается усидеть на месте, и вести себя пристойно.
Р — и не надо думать, что если у шефа красавец порше, то вы его тоже получите. Ваш максимум — это BMW Z8.
С — (не выдержав) Врете!
Р — (Чинно) Ты первый начал.
python, Егор Динин,
21.07.15, 9:32 Показать таблицу в форму отрытой модально
Sede, а зачем еще слой добавлять, когда можно в одном слое расположить и элементы формы, и таблицу значений.
Так менеджеру понятней будет.
И правильно Vofka сказал - обмен с формой вести через список значений. Это универсальный механизм.
Sede,
20.07.15, 13:31 Перенос регистра сведений ФИОФизЛиц
Вот нашел на просторах инета:
В обработчике ПослеВыгрузки справочника ФизическиеЛица добавил код:
НаборЗаписей = РегистрыСведений.ФИОФизЛиц.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.ФизЛицо.Установить(Источник,Истина);
НаборЗаписей.Прочитать();
Для Каждого Запись из НаборЗаписей Цикл
    ВыгрузитьПоПравилу(Запись, , , , "ФИОФизЛиц");
КонецЦикла;

Получилось.
PS: сам до такого не додумался-бы, опыта и знаний по КД маловато.
avel1976,
20.07.15, 12:55 БУУ - CRM 2.0
Тогда нужно смотреть ПКО и все правила, с ними связанные, для документа Счета (СчетаФактуры?)
Если сможете, покажите скрины ПКО для документа Счет (СчетФактура?).
Вкладки ОбработчикСобытий, Настройки, Дополнительно.
papasha95,
20.07.15, 11:42 БУУ - CRM 2.0
Папаша, не знаю, что такое CRM, хотелось-бы взглянуть на скрин-шот с окном этой обработки. Может галочка какая-то есть?
И, что означают слова "старые платежки нормально не подставляются"?
Старые по дате, или старые - они уже есть в CRM, и не обновляются документами из БУУ?
Это разные вещи.
papasha95,
01.07.15, 11:07 Повторять при печати строки
Разобрался. Здесь нет возможности присоединить архив, поэтому привожу пример полностью:

Перем КакоеТоЧисло; 
Перем Предел;
Перем тз1, тз2;
Перем Таб, Таб1, КолСтрПред;

Функция ДатьСлучайноеЧисло()
    m35=34359738368;
    m36=68719476736;
    m37=137438953472;
    КакоеТоЧисло=5*КакоеТоЧисло;
    Если КакоеТоЧисло>=m37 Тогда КакоеТоЧисло=КакоеТоЧисло-m37 КонецЕсли;
    Если КакоеТоЧисло>=m36 Тогда КакоеТоЧисло=КакоеТоЧисло-m36 КонецЕсли;
    Если КакоеТоЧисло>=m35 Тогда КакоеТоЧисло=КакоеТоЧисло-m35 КонецЕсли;
    Возврат Цел(КакоеТоЧисло/m35*101);
КонецФункции

Процедура ПриОткрытии(Настр)
    КолСтрок = 300; // Количество строк в таблицах
    КакоеТоЧисло=_GetPerformanceCounter()*_GetPerformanceCounter();
КонецПроцедуры

Функция СлучайноеЧисло(Предел)
    СлучайноеЧисло=ДатьСлучайноеЧисло();
    СлучайноеЧисло=СлучайноеЧисло%(Предел-1)+1;
    Возврат СлучайноеЧисло;
КонецФункции

Процедура ВывестиТаблицу(тз, Н)
    Перем ст[10]; // Строка таблицы
    Если ПустоеЗначение(тз) = 1 Тогда
        Возврат;
    КонецЕсли;
    Если (Н=1) Или (Н=2) Тогда
    Иначе
        Возврат;
    КонецЕсли;
    тз.ВыбратьСтроки();
    Состояние(Шаблон("Вывод таблицы [Н]"));
    Для Ном = 1 По тз.КоличествоСтрок() Цикл
        Для Инд = 1 По тз.КоличествоКолонок() Цикл // Сформируем строку вывода
            ст[Инд] = тз.ПолучитьЗначение(Ном,Инд);
        КонецЦикла;
        Таб1.ВывестиСекцию("Строка"+Н); // Вывели строку в вспомогательную таблицу
        Если Таб1.КоличествоСтраниц() > КолСтрПред Тогда
            // В вспомогательной таблице перешли на новую страницу
            // В основной таблице отстаем на одну строку
            Если фКолонтитулы = 1 Тогда
                Таб.ВывестиСекцию("Колонтитул"+Н); // Вывели колонтитул в основную таблицу
                Таб1.ВывестиСекцию("Колонтитул"+Н);// Вывели колонтитул в вспомогательную таблицу для общего счета
            КонецЕсли;
            Таб.ВывестиСекцию("Шапка"+Н);   // Вывели шапку в основную таблицу на новой странице
            Таб1.ВывестиСекцию("Шапка"+Н);  // Вывели шапку в вспомогательную таблицу для общего счета
            КолСтрПред = КолСтрПред+1;
        КонецЕсли;
        Таб.ВывестиСекцию("Строка"+Н); // Вывели строку в основную таблицу
    КонецЦикла;
    Если фКолонтитулы = 1 Тогда
        Таб.ВывестиСекцию("Колонтитул"+Н);
        Таб1.ВывестиСекцию("Колонтитул"+Н); // В вспомогательную таблицу для общего счета
    КонецЕсли;
КонецПРоцедуры

//*******************************************
Процедура Сформировать()
    Перем ст[10]; // Строка таблицы
    тз1.УдалитьСтроки();
    тз2.УдалитьСтроки();
    // тз1
    Состояние("Заполнение таблицы 1 случайными числами");
    Для Ном = 1 По КолСтрок Цикл
        тз1.НоваяСтрока();
        Для Инд = 1 По 7 Цикл
            тз1.УстановитьЗначение(Ном, Инд, СлучайноеЧисло(Предел));
        КонецЦикла;
    КонецЦикла;
    
    // тз2
    Состояние("Заполнение таблицы 2 случайными числами");
    Для Ном = 1 По КолСтрок Цикл
        тз2.НоваяСтрока();
        Для Инд = 1 По 10 Цикл
            тз2.УстановитьЗначение(Ном, Инд, СлучайноеЧисло(Предел));
        КонецЦикла;
    КонецЦикла;
    
    КолСтрПред = 1;
    
    Таб = СоздатьОбъект("Таблица"); // Для вывода данных
    Таб.ИсходнаяТаблица("Таблица");
    
    Таб1=СоздатьОбъект("Таблица");  // Для подсчета страниц
    Таб1.ИсходнаяТаблица("Таблица");
    
    // Выводим тз1
    Таб1.ВывестиСекцию("Заголовок1");
    Таб1.ВывестиСекцию("Шапка1");
    Если фКолонтитулы = 1 Тогда
        Таб1.ВывестиСекцию("Шапка1");   // "Лишняя" строка для контроля перехода на новую страницу
    КонецЕсли;
    Таб.ВывестиСекцию("Заголовок1");
    Таб.ВывестиСекцию("Шапка1");
    ВывестиТаблицу(тз1, 1);
    
    Если фНоваяСтраница = 1 Тогда
        Таб.НоваяСтраница();
        Таб1.НоваяСтраница();
        КолСтрПред = КолСтрПред+1;
    КонецЕсли;
    
    // Выводим тз2
    Таб1.ВывестиСекцию("Заголовок2");
    Таб1.ВывестиСекцию("Шапка2");
    Если (фКолонтитулы = 1) И (фНоваяСтраница = 1) Тогда
        Таб1.ВывестиСекцию("Шапка2");   // "Лишняя" строка для контроля перехода на новую страницу
    КонецЕсли;
    Таб.ВывестиСекцию("Заголовок2");
    Таб.ВывестиСекцию("Шапка2");
    ВывестиТаблицу(тз2, 2);
    
    Таб1.ТолькоПросмотр(1);
    Таб1.Опции(0,0,0,0,"Вспомогательная","Вспомогательная");
    Таб1.Показать("Вспомогательная");
    
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,0,0,"Основная","Основная");
    Таб.Показать("Основная");
КонецПроцедуры

Предел = 1000; // Верхний предел случайного числа

тз1 = СоздатьОбъект("ТаблицаЗначений");
Для Инд=1 По 7 Цикл
    тз1.НоваяКолонка("ст"+Строка(Инд));
КонецЦикла;

тз2 = СоздатьОбъект("ТаблицаЗначений");
Для Инд=1 По 10 Цикл
    тз2.НоваяКолонка("ст"+Строка(Инд));
КонецЦикла;


Vofka,
28.05.15, 11:56 Обработка Подбор номенклатуры
Разобраться, как эти данные выводятся в итоговой строке, и по аналогии вывести их в табличной части подбора.
candrey,
21.07.14, 9:18 Агент+ Мобильная торговля. Количество знаков после комы
После комы число знаков уже не имеет значения 12201689.gif
Ardi,
20.05.14, 7:28 О музыке
alex040269, Ardi, Vofka,
15.05.14, 14:06 Прикольные картинки
Когда папа - сантехник:
Ardi,
12.05.14, 15:07 Тролли
Цитата(Ardi @ 12.05.14, 16:05) *
Я предполагаю что в каждом райцентре Донецкой и Луканской области в пределах видимости райадминистраций Путин поселил по снайперу.

ХА-ХА-ХА
Домовик,
12.05.14, 10:31 аналіз рахунка посубконто, 1С Бухгалтерия 7.7 для Украины
Да, и еще. Вид деятельности и Вид затрат - периодические. Посмотрите историю. М.б. они заданы на май, а документ - за апрель.
djdf_crash,
12.05.14, 10:13 аналіз рахунка посубконто, 1С Бухгалтерия 7.7 для Украины
Цитата(djdf_crash @ 12.05.14, 10:54) *
Вказаний рахунок 471

Т.е. сотрудник в отпуске? А какой у сотрудника указан Вид деятельности, Вид затрат?
Приведенный мною фрагмент (стандартный) срабатывает только тогда, когда константа "Использовать обеспечение отпусков" установлена в Да.
Если-же вы отправляете сотрудника в отпуск через задание счета затрат в карточке сотрудника в 471, то вроде должно получиться. Нужно трассировать в отладчике, и смотреть, где создается проводка со сч.471, и все параметры этой проводки.
djdf_crash,
08.05.14, 12:10 Восстановление последовательность
1. Да
2. Можно.
masejka,
18.04.14, 10:49 ТиС+АСП
Тогда попробуйте Univero 2.7. С "Конвертацией данных 1.0" сложнее - ее изучить и понять нужно.
djdf_crash,
18.04.14, 10:25 Улыбнуло
А еще они маскируются:
Virgo,
18.04.14, 9:06 ТиС+АСП
Лучше доверить это дело профессионалам. Самому вам это не сделать - много нюансов.
Например, что делать с одинаковыми ТМЦ из разных баз? Объединить их вместе, или разделить?
Мой вам совет - не заморачивайтесь. Лучшее - враг хорошего.
Или вы начинаете с нуля? Тогда без проблем. Нужно только для того, чтобы в справочнике Фирмы была возможность добавлять фирмы (филиалы), в конфигураторе, в ПланеСчетов, назначить разделитель учета.
djdf_crash,
14.04.14, 11:01 С днем Космонавтики
Поздравляю всех с прошедшим днем космонавтики.

Желаю заоблачных зарплат, космических скоростей в реализации нужд заказчиков.
Alen55, alex040269, Virgo,
14.04.14, 9:35 Ошибки релиза 302
Цитата(mister-x @ 14.04.14, 10:22) *
в послугах добавлена одиниця виміру "послуга", Перечисления.ЕдиницыИзмерения

Прочитайте уважно аргументацію.
mister-x,

5 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 26.05.20, 8:16
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!