Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



5 страниц V   1 2 3 > » 

>  не могу передать значение с таблицы
AnryMc
Отправлено: Вчера, 8:44


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Было бы неплохо узнать что такое rsMain?
Так как могут быть варианты...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176362 · Ответов: 2 · Просмотров: 132
 

>  Заміна 1С
AnryMc
Отправлено: 05.09.22, 16:58


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(Vadim67567567 @ 05.09.22, 17:36) *
Тобто у малому та середньому б-зі не має конкурентів?


Это по поводу облачного хранения данных?

З.Ы. Наверно подразумевается что купить дороже, чем оно того стоит...
  Форум: Офф-топик · Просмотр сообщения: #176291 · Ответов: 22 · Просмотров: 702
 

>  Заміна 1С
AnryMc
Отправлено: 05.09.22, 16:20


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Демка бухии которую продвигают bookkeeper
Первое - она облачная, т.е. все ваши данные у дяди (вместе с "управленческим" учетом 32541850.gif )
Второе - она облачная, т.е. никаких: "А я хочу так..."
Третье - она облачная, т.е. ...

Цитата:
Цитата
BOOKKEEPER успешно решает задачи ведения бухгалтерии онлайн для предпринимателей и предприятий всех систем налогообложения.
ФОП
Предприятия малого и среднего бизнеса
Дирктор (владелец) компании, инвестор
Бухгалтер аутсорсер


Т.е.: Ларек, оптовый склад: купил-продал,...
Если бизнес процесс не постоянный, а каждый раз с "нюансами" то точно не подходит
Про производство - ни слова...
ЗП - очень простая, опять таки - без "нюансов"
  Форум: Офф-топик · Просмотр сообщения: #176289 · Ответов: 22 · Просмотров: 702
 

>  позиционирование после стандартного поиска
AnryMc
Отправлено: 31.08.22, 14:38


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(iksteram @ 30.08.22, 19:25) *
можно элементу формы назначить обработчик (программно)


а строка поиска - ДополнениеЭлементаФормы Вид: "Отображение строки поиска", где Родитель: Список (таблица формы) - а не элемент...

Можно еще НАВЕРНО через "ж...у":
Повесить ПодключитьОбработчикОжидания с периодом например 1 секунда и анализировать наверно Элементы.ДокументСписок.ПолучитьИсполняемыеНастройкиКомпоновкиДанных() есть ли там отбор...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176244 · Ответов: 7 · Просмотров: 270
 

>  позиционирование после стандартного поиска
AnryMc
Отправлено: 30.08.22, 16:28


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(iksteram @ 30.08.22, 17:23) *
вопрос в какой обработчик это запихнуть?


Лично я в своё время не нашёл 8,3,15,1700 на более свежих не знаю...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176239 · Ответов: 7 · Просмотров: 270
 

>  позиционирование после стандартного поиска
AnryMc
Отправлено: 30.08.22, 16:20


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Я делал свою строку поиска...
Реквизит формы "СтрокаДляПоиска" - тип строка,
&НаКлиенте
Процедура СтрокаДляПоискаПриИзменении(Элемент)
    
    Если ЗначениеЗаполнено(СтрокаДляПоиска) Тогда
        
        УстановитьМойОтбор(СтрокаДляПоиска);
        
    Иначе
        
        УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОчистка(Элемент, СтандартнаяОбработка)
    
    УдалитьМойОтбор();
        
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОткрытие(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ЛОЖЬ;
    
    Если ЗначениеЗаполнено(Элемент.ТекстРедактирования) Тогда
        
        УстановитьМойОтбор(Элемент.ТекстРедактирования);
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьМойОтбор(СДП)
    
    ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(Список, "Наименование", СДП, ВидСравненияКомпоновкиДанных.Содержит,,Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура УдалитьМойОтбор()
    
    ОбщегоНазначенияКлиентСервер.УдалитьЭлементыГруппыОтбораДинамическогоСписка(Список, "Наименование");
    
КонецПроцедуры


Цитата(iksteram @ 30.08.22, 17:16) *
Проблема впередаче фокуса после поиска


   //устанавливаем фокус на таблицу списка
    ЭтаФорма.ТекущийЭлемент = Элементы.ДокументСписок;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176237 · Ответов: 7 · Просмотров: 270
 

>  позиционирование после стандартного поиска
AnryMc
Отправлено: 30.08.22, 15:13


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(iksteram @ 30.08.22, 15:40) *
что бы после стандартного поиска происходило позиционирование на список (первую строку списка)?


Я "подозреваю" что это события "ПриОчистке" и "ПриИзменении" когда "пусто"...

А позиционирование

&НаКлиенте
Процедура КомандаПерваяСтрока(Команда)
    
    Элементы.ДокументСписок.ТекущаяСтрока = ПолучитьСсылкуПервогоЭлемента();
    
КонецПроцедуры

&НаСервере
Функция ПолучитьСсылкуПервогоЭлемента()
    
    лкСхема     = Элементы.ДокументСписок.ПолучитьИсполняемуюСхемуКомпоновкиДанных();  
    лкНастройки     = Элементы.ДокументСписок.ПолучитьИсполняемыеНастройкиКомпоновкиДанных();
    
    //почему-то по умолчанию, в динамических списках нет поля Ссылка, добавляем
    лкПоля = лкНастройки.Структура[0].Выбор.Элементы;
    лкПоле = лкПоля.Добавить(Тип("ВыбранноеПолеКомпоновкиДанных"));
    лкПоле.Поле = Новый ПолеКомпоновкиДанных("Ссылка");
    
    лкКомпоновщик     = Новый КомпоновщикМакетаКомпоновкиДанных();
    лкМакетКомпоновки = лкКомпоновщик.Выполнить(лкСхема, лкНастройки,,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
    
    лкПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    лкПроцессорКомпоновки.Инициализировать(лкМакетКомпоновки);
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
    лкРезультат = Новый ТаблицаЗначений;
    ПроцессорВывода.УстановитьОбъект(лкРезультат);
    ПроцессорВывода.Вывести(лкПроцессорКомпоновки);
    
    
    Если лкРезультат.Количество() > 0  Тогда
        лкСсылка = лкРезультат[0].Ссылка;
    Иначе    
        лкСсылка = Неопределено;
    КонецЕсли;    
    
    Возврат лкСсылка;
    
КонецФункции




Хотя если документов очень много, будет не реально тормозить.
можно по кнопке Home - должно быстрее
&НаКлиенте
Процедура КомандаПерваяСтрока(Команда)
    
    //устанавливаем фокус на таблицу списка
    ЭтаФорма.ТекущийЭлемент = Элементы.ДокументСписок;
    мГенераторКлавиш = Новый COMОбъект("Wscript.shell");
    мГенераторКлавиш.SendKeys("{Home}");
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176235 · Ответов: 7 · Просмотров: 270
 

>  Затраивание в СКД
AnryMc
Отправлено: 25.08.22, 13:55


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Отчет СКД - схема прилагается...
Схема СКД (хранение до 30/08/2022)

Конфигурация: Business automation software for accounting CORP, edition 2.1
Платформа: 8.3.15.1700

Суть отчета: За преиод (с / по) выбираются сумма и кол-во по счету 281 (сальдо начальное, оборот Дт, оборот Кт, сальдоконечное) в разрезе
Номенклатура, Партия, Склад
по каждой позиции Номенклатура, Партия, Склад добавляется регистратор, счет Кт с Субконто1, 2 и 3, валюта Кт, Сумма, Валютная сумма Кт, Кол-во Кт.

Как только добавляю "расшифровку" по обороту с Кт... Затраиваются Суммы и кол-во по (сальдо начальное, оборот Дт, оборот Кт, сальдоконечное)

Пробовал в ресурсах "расчитать по" - не получается

Как это побороть?
Какому "полю" назначить какую "роль"?

З.Ы. За оперативную и существенную помощь - например скачивание с Инфостарта...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176222 · Ответов: 0 · Просмотров: 188
 

>  Не везде считать итоги в СКД
AnryMc
Отправлено: 19.08.22, 14:53


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


СКД выводит "Таблицу":
Строки - некие статьи (например затрат)
Колонки - План, Факт товара, Факт деньги
на их пересечение Ресурсы - полученные в запросе

Вопрос: Можно ли сделать расчет вертикальных итогов так чтобы по некоторым строкам (статьям затрат) они вычислялись для Факта (товар/деньги) и не рассчитывались по Плану?

З.Ы, В данном случае расчет итогов по группировкам не подходит, т.к. группировка одна (в ней 3 значения: план, товар, деньги) и нужно рассчитывать только по 2 значениям (товар и деньги)

З.Ы.Ы. Возможно частичным решением будет возможность исключить Ресурсы по некоторые строкам (статьям) из участия в общих вертикальных итогах, Вопрос как?
  Форум: Система компоновки данных · Просмотр сообщения: #176198 · Ответов: 2 · Просмотров: 222
 

>  Получить синоним метаданных на определенном языке
AnryMc
Отправлено: 19.08.22, 11:11


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718





Цитата(29a @ 19.08.22, 11:44) *
и получить синоним на этом языке

+
Цитата(denis84 @ 18.08.22, 10:18) *
Создайте регистр сведений, и там укажите соответствие элементов и синонимов на другом языке


64000000.gif Склоняюсь к идее сделать регистр сведений и спец. обработкой заполнить его синонимами из под интерфейсов с разными языками...
Но это... 32542620.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176197 · Ответов: 4 · Просмотров: 578
 

>  Получить синоним метаданных на определенном языке
AnryMc
Отправлено: 18.08.22, 8:17


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Доброго времени суток!

Пока не особенно проснулся а есть задача:

В конфигурации есть несколько языков.
ВОПРОС: Можно ли получить синоним объекта метаданных на нужном языке отличном от языка интерфейса?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176190 · Ответов: 4 · Просмотров: 578
 

>  Помилка: Номер року в літералі типу 'Дата' перевищує 3999
AnryMc
Отправлено: 16.08.22, 8:25


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718



Цитата(Gorus @ 15.08.22, 18:30) *
Пуста дата - це 01.01.0001, тобто '00010101'


У Вас из МИНИМАЛЬНОГО значения '00010101' вычитается месяц месяц - результат выходит за разрешенный диапазон и выдается сообщение о его превышении, все нормально...
Это как деление на 0 (ноль) - результат = бесконечность...

Единственный выход я вижу в проверке на "0" (т.е. '00010101') перед выполнением кода...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176174 · Ответов: 11 · Просмотров: 399
 

>  Сканирование документов ( договора ) в формате PDF
AnryMc
Отправлено: 12.08.22, 9:40


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(Profi_1C77 @ 11.08.22, 17:20) *
но доступа туда у меня нет

доступа или $m?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #176159 · Ответов: 4 · Просмотров: 406
 

>  Відбір на списку форми документа по додаткових реквізитах
AnryMc
Отправлено: 12.08.22, 9:38


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


bandrah @ 10.08.22, 21:59 * ,

Практически все списки документов формируются запросом, добавьте в него выборку доп. реквизитов и сделайте по ним условие...
При СозданииНаСервере устанавливайте нужное значение параметра для условия...

AnryMc @ Сегодня, 10:17 * ,


Туплю я с утра однако...

ПриСозданииНаСервере программно напишите нужный отбор по "ДополнительныеРеквизиты"

Туплю я с утра однако...

ПриСозданииНаСервере программно напишите нужный отбор по "ДополнительныеРеквизиты"

А ещё проще: общий модуль "ОбщегоНазначенияКлиентСервер"
- Процедура УстановитьЭлементОтбора
- Процедура УстановитьЭлементОтбораДинамическогоСписка
- Процедура УстановитьПараметрДинамическогоСписка
- Процедура УдалитьЭлементыГруппыОтбораДинамическогоСписка

Пример кода "альтернативного" поиска по наименованию
&НаКлиенте
Процедура СтрокаДляПоискаПриИзменении(Элемент)
    
    Если ЗначениеЗаполнено(СтрокаДляПоиска) Тогда
        
        УстановитьМойОтбор(СтрокаДляПоиска);
        
    Иначе
        
        УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОчистка(Элемент, СтандартнаяОбработка)
    
    УдалитьМойОтбор();
        
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОткрытие(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ЛОЖЬ;
    
    Если ЗначениеЗаполнено(Элемент.ТекстРедактирования) Тогда
        
        УстановитьМойОтбор(Элемент.ТекстРедактирования);
        
    //Иначе
    //    
    //    УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьМойОтбор(СДП)
    
    ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(Список, "Наименование", СДП, ВидСравненияКомпоновкиДанных.Содержит,,Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура УдалитьМойОтбор()
    
    ОбщегоНазначенияКлиентСервер.УдалитьЭлементыГруппыОтбораДинамическогоСписка(Список, "Наименование");
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176158 · Ответов: 1 · Просмотров: 211
 

>  BAF small bussines завантаження данних номенклатури, редагування форм, предоплата
AnryMc
Отправлено: 12.08.22, 9:08


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


toralgr @ Вчера, 10:05 * ,

Лично я не работал с данной конфигурацией и хотел бы узнать как вы загружаете номенклатуру... Какой обработкой?
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #176157 · Ответов: 5 · Просмотров: 574
 

>  Помилка: Номер року в літералі типу 'Дата' перевищує 3999
AnryMc
Отправлено: 12.08.22, 9:04


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Gorus @ Вчера, 17:36 * ,
Из справки:
Цитата
Литерал типа ДАТА
Литерал типа ДАТА записывается в виде:
ДАТАВРЕМЯ ( <Целое число>, <Целое число>,
<Целое число>[, <Целое число>,
<Целое число>, <Целое число>] )
Значения типа дата задаются с помощью ключевого слова ДАТАВРЕМЯ, после которого в скобках последовательно указываются год, месяц, день, час, минута, секунда. Последние три указывать необязательно.
Максимальная дата которую возможно задать при помощи литерала ДАТАВРЕМЯ – 31.12.3999 23:59:59.


Вы пишите
Цитата
При цьому, якщо Начисления.ДатаНачалаБазовогоПериода - пуста дата

Пустая дата - это 01.01.0001 или Null или Неопределено?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176156 · Ответов: 11 · Просмотров: 399
 

>  Язык отчета на СКД
AnryMc
Отправлено: 08.08.22, 13:54


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Кстати, если"прикрутить" справочник или регистр сведений можно сделать "универсальный" механизм перевода...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176135 · Ответов: 9 · Просмотров: 450
 

>  При відкритті конструктора рухів немає жодних рухів по регістру
AnryMc
Отправлено: 05.08.22, 14:56


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Ну я например не знаю альтернативы данному программному продукту с таким же функционалом и ценовым диапазоном...

Или очень специализированные (практически без возможности подстройки / доработки / изменения) или + 00 (два нуля) как минимум к цене и год-три внедрения и постоянные платежи для возможности поддержки изменений (законодательных), да и стоимость доработки как минимум * 2-3 (умножить на 2 - 3) , и вместо 1-2 часов - неделя - две...


Цитата(Vadim67567567 @ 26.07.22, 11:18) *
BAF, цим вам не подобається, чудовий замінник - 1С


Как и 1С -BAF в санкционном списке...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176119 · Ответов: 7 · Просмотров: 512
 

>  Язык отчета на СКД
AnryMc
Отправлено: 05.08.22, 13:51


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(sava1 @ 05.08.22, 10:36) *
ТекОбласть = Результат.НайтиТекст("Итого", ТекОбласть, Результат.Область(), Истина, Истина, Истина, Ложь);

Если ТекОбласть <> Неопределено Тогда
ТекОбласть.Текст = "Загалом";
КонецЕсли;


Поиск области не в цикле - заменит 1-е значение а не все...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176117 · Ответов: 9 · Просмотров: 450
 

>  УФ - управление кнопкой Печать
AnryMc
Отправлено: 05.08.22, 13:20


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(kserg2012 @ 04.08.22, 8:56) *
Business automation software for accounting


В данной конфигурации для справочника Договора контрагентов - нет пачатных форм...
Я бы для начала выяснил как подключены эти печатные формы...
Если это ВПНы (внешнии печатные формы) - то в расширение можно "добавить" из общего модуля "ПодключаемыеКомандыКлиентСервер" процедуру "ОбновитьКоманды" и её "перекурочить" как душе угодно...

Можно создать для объекта Справочник.ДоговораКонтрагентов какое угодно подменю для кнопки "Печать"...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176116 · Ответов: 7 · Просмотров: 292
 

>  событие активации строки в списке значений на форме
AnryMc
Отправлено: 05.08.22, 13:00


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


AnryMc @ Сегодня, 12:49 * ,

Пардон, не обратил внимание что 7.7...

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176115 · Ответов: 3 · Просмотров: 287
 

>  событие активации строки в списке значений на форме
AnryMc
Отправлено: 05.08.22, 11:49


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


kostya77 @ Вчера, 11:37 * ,

Для списка значений (реквизит формы - тип "Список значений") на форме (вставленном как таблица) есть событие: "ПриАктивизацииСтроки"
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176114 · Ответов: 3 · Просмотров: 287
 

>  Язык отчета на СКД
AnryMc
Отправлено: 05.08.22, 10:55


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


РЕШЕНО!!!

Рабочий код:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    
    Настройки = ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки();
    
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
    
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки, Истина);  
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    
    ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
    
    Ячейка = 1;
    
    Пока Ячейка <> Неопределено Цикл
        
        Ячейка = ДокументРезультат.НайтиТекст("Итого");
        
        Если Ячейка <> Неопределено Тогда
            
            Ячейка.Текст = "Разом";
            
        КонецЕсли;
        
    КонецЦикла;
    
    //***Запишем в журнал событий
    ЗаписьЖурналаРегистрации("МоеСобытие.Отчет."+СокрЛП(ЭтотОбъект.Метаданные().Имя),
    УровеньЖурналаРегистрации.Информация,
    ,
    СокрЛП(ЭтотОбъект.Метаданные().Имя),
    "Открыт "+СокрЛП(ПараметрыСеанса.ТекущийПользователь)+" "+СокрЛП(ТекущаяДата()));
    
КонецПроцедуры


Работает со всеми настройками (настойками, пользовательскими настройками, фиксированными настройками) - отборы, оформления, ....
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176112 · Ответов: 9 · Просмотров: 450
 

>  Язык отчета на СКД
AnryMc
Отправлено: 04.08.22, 10:43


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Доброго времени суток!

Внешний отчет на СКД без макета оформления, т.е. выводится системой.
Для Конфигурации Бухгалтерия BAS в ней есть два языка: русский и украинский.
Платформа инсталлирована русская (интерфейс программы) - переинсталяция не подходит
Интерфейс пользователя - украинский
Язык печатных форм - украинский (хотя в данном случае он не причём)
Всё работает нормально но в ИТОГАХ СКД пишется "Итого"

Вопрос: Как заменить "Итого" на "Разом"?

З.Ы. Кстати и во всех стандартных отчетах тоже "Итого"...

Уточню вопрос
Запуск через ключ /Luk - не подходит
Интересует изменение в самой СКД через модуль объекта процедура "ПриКомпоновкеРезультата"

З.Ы. Рассматривается вариант платного выполнения с подробными объяснениями
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176105 · Ответов: 9 · Просмотров: 450
 

>  ВПФ Счет покупателю с QR-кодом - реквизиты платежа (Сумма, iBAN, получатель, назначение платежа
AnryMc
Отправлено: 06.01.22, 15:52


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 102
Регистрация: 11.12.10
Пользователь №: 5718


Внешняя печатная форма (ВПФ) - регистрируется в программе и добавляет ещё одну печатную форму для документа "Счет для оплаты Покупателю"
В отличии от стандартной - формирует дополнительно QR-код для формирования оплаты по стандарту НБУ:
"П О С Т А Н О В А
01 лютого 2021 року м. Київ № 11
Про внесення змін до Правил формування та використання QR-коду
для здійснення кредитових переказів"

Проверял на: Monobank и Приват24

P.S. Приват24 на момент проверки не "подхватывал" наименование Получателя. Monobank - всё нормально.
P.P.S. В качестве "назначения платежа" в QR-код берется "Комментарий"

Файл создавался для BAS бух корп., но должен работать и в других конфигурациях этой "линейки".
Для конфигураций: "... для Украины" - нужна небольшая переработка...
  Форум: Отчеты / Обработки · Просмотр сообщения: #175050 · Ответов: 1 · Просмотров: 717
 

5 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 27.09.22, 0:22
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!