Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Управление ролями пользователей.
george_smith
Отправлено: 12.02.20, 14:36


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Здравстуйте!
В документе "Реализация товаров и услуг" на вкладке "Доверенность"есть реквизиты "Отпуск разрешил" и "Отпуск произвел". Для зав скадом редактирование данного документа запрещено. Как можно ему дать возможность вносить данные только в эти два реквизита. Спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160320 · Ответов: 2 · Просмотров: 204
 

>  Где описывается код "меню действия", вывести список (обычный клиент)
george_smith
Отправлено: 26.10.19, 12:01


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Спасибо Всем, кто помагал!
Методом проб и ошибок создадал вот такой рабочий код.
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Масс = Новый Массив;
    Для Сч=0 По ОформленияСтрок.Количество() -1  Цикл
        Если  НЕ ОформленияСтрок[Сч].ДанныеСтроки.ЭтоГруппа  Тогда
            Масс.Добавить(ОформленияСтрок[Сч].ДанныеСтроки.Ссылка);            
        КонецЕсли;
    КонецЦикла;
        
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |    Штрихкоды.Владелец.Ссылка КАК НоменклатураРегистраШтрихКод,
    |    Штрихкоды.Штрихкод КАК Штрихкод
    |ИЗ
    |    РегистрСведений.Штрихкоды КАК Штрихкоды
    |ГДЕ
    |    ТИПЗНАЧЕНИЯ(Штрихкоды.Владелец) = ТИП(Справочник.Номенклатура)
    |    И Штрихкоды.Качество.Ссылка = ЗНАЧЕНИЕ(Справочник.Качество.Новый)
    |    И Штрихкоды.Владелец.Ссылка В (&Масс)
    |
    |СГРУППИРОВАТЬ ПО
    |    Штрихкоды.Владелец.Ссылка,
    |    Штрихкоды.Штрихкод";
    
    Запрос.УстановитьПараметр("Масс",Масс );
    РЗ = Запрос.Выполнить();
    ТЗ = РЗ.Выгрузить();
        
    Для Каждого ОС ИЗ ОформленияСтрок Цикл
        СтрокаТЗ = ТЗ.Найти(ОС.ДанныеСтроки.Ссылка);
        Если СтрокаТЗ <> Неопределено Тогда
            ОС.Ячейки.ШтрихКодМой.Значение = СтрокаТЗ.Штрихкод;
            ОС.Ячейки.ШтрихКодМой.Текст = СтрокаТЗ.Штрихкод;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Станно, что
ОС.Ячейки.ШтрихКодМой.Значение = СтрокаТЗ.Штрихкод;
            ОС.Ячейки.ШтрихКодМой.Текст = СтрокаТЗ.Штрихкод;
работает только когда две строки записаны имеено в таком порядке. По одной и в другм порядке не рабатает, или показывает не адекватные значения или пустые ячейки.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156928 · Ответов: 9 · Просмотров: 565
 

>  Где описывается код "меню действия", вывести список (обычный клиент)
george_smith
Отправлено: 25.10.19, 15:07


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Vofka @ Вчера, 14:03 * ,

Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Масс = Новый Массив;
    Соо = Новый Соответствие;
    Для Сч=0 По ОформленияСтрок.Количество() -1  Цикл
        Если  НЕ ОформленияСтрок[Сч].ДанныеСтроки.ЭтоГруппа  Тогда
            Масс.Добавить(ОформленияСтрок[Сч].ДанныеСтроки.Ссылка);
            Соо.Вставить(ОформленияСтрок[Сч].ДанныеСтроки.Ссылка, ОформленияСтрок[Сч].Ячейки.ШтрихКодМой.Значение );               
        КонецЕсли;
    КонецЦикла;
    
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |    Штрихкоды.Владелец.Ссылка КАК НоменклатураРегистраШтрихКод,
    |    Штрихкоды.Штрихкод КАК Штрихкод
    |ИЗ
    |    РегистрСведений.Штрихкоды КАК Штрихкоды
    |ГДЕ
    |    ТИПЗНАЧЕНИЯ(Штрихкоды.Владелец) = ТИП(Справочник.Номенклатура)
    |    И Штрихкоды.Качество.Ссылка = ЗНАЧЕНИЕ(Справочник.Качество.Новый)
    |    И Штрихкоды.Владелец.Ссылка В (&Масс)
    |
    |СГРУППИРОВАТЬ ПО
    |    Штрихкоды.Владелец.Ссылка,
    |    Штрихкоды.Штрихкод";
    Запрос.УстановитьПараметр("Масс",Масс );
    РЗ = Запрос.Выполнить();
    ТЗ = РЗ.Выгрузить();
    Выборка = РЗ.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        Для Каждого Эл  Из Соо Цикл
            Если  Выборка.НоменклатураРегистраШтрихКод = Эл.Ключ  Тогда
                
                Эл.Значение =  Выборка.Штрихкод;
                
            КонецЕсли;
        КонецЦикла;             

                
    КонецЦикла;
    
        
    
КонецПроцедуры


Не работат! :-)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156907 · Ответов: 9 · Просмотров: 565
 

>  Где описывается код "меню действия", вывести список (обычный клиент)
george_smith
Отправлено: 24.10.19, 12:54


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


pablo @ Сегодня, 13:31 * ,
Конфигурация изменена, проблем нет. Хотелось бы услышать совет, каким способом это правильно сделать. ;-)

Vofka @ Сегодня, 13:15 * ,
Да, как раз это хочу.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156857 · Ответов: 9 · Просмотров: 565
 

>  Где описывается код "меню действия", вывести список (обычный клиент)
george_smith
Отправлено: 24.10.19, 12:01


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Vofka @ Сегодня, 12:51 * ,
У нас в конфе на форму элемента "Номенклатура" вынесен регистр сведений ШрихКоды и установлен отбор по текущему элементу. То есть видно "штрихкод" для каждого элемента номенклатуры в справочнике. Но так как это только отображение регистра, в форму списка нельзя добавить колонку ШтрихКод, как хотят бухи, что было удобно смотреть, стандартными средствами. Подскажите способ как схитрить или вообще не стоит это решать. Для каждого элемента номенклатуры только один штрихкод. Спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156853 · Ответов: 9 · Просмотров: 565
 

>  Где описывается код "меню действия", вывести список (обычный клиент)
george_smith
Отправлено: 24.10.19, 11:36


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Здравствуйте!
1С:Предприятие 8.3 (8.3.10.2299) "Управление торговым предприятием для Украины", редакция 1.2. (1.2.53.1)
Хотел бы получить помощь, что бы узнать где в данной конфигурации (обычный клиент) описывается код "меню действия", вывести список?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156849 · Ответов: 9 · Просмотров: 565
 

>  Автоматизация перепроведения документов
george_smith
Отправлено: 06.06.19, 13:59


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


"Управление торговым предприятием для Украины", редакция 1.2. (1.2.51.2)

Здравствуйте!
Что бы получать актуальные данные каждую неделю, руководство предприятия постановило делать перепроведение документов каждую неделю, с первого дня после закрытого периода.
В связи с этим хотел бы узнать:
1. Можно ли автоматизировать эту процедуру и есть ли для этого готовые решения или обязательно это выполнять существующей обработкой?
2. Не вредит ли постоянные перепроведения базе самой? Есть ли рекомендации на счет частоты использования данной обработки?
Спасибо


 ! 

Правила: 5
 
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #152878 · Ответов: 1 · Просмотров: 559
 

>  Будет ли отличаться работа 1С на Exppress от работы на полной SQL?
george_smith
Отправлено: 15.05.19, 13:47


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


NAGor4ik @ Сегодня, 9:58 * ,
За бесплатно лучше, конечно, DB2 Express-C под Ubuntu.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #152224 · Ответов: 12 · Просмотров: 677
 

>  Загрузка данных из Excel начала тормозить и иногда вообще обрывается
george_smith
Отправлено: 15.05.19, 9:06


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Здравствуйте!
Пользователь работает в терминальной сессии, в документе "Реализация товаров и услуг", загружает номенклатурные позиции из файла Excel. Раньше быстро работало, а сейчас начало тормозить, иногда загрузка обрывается. Особенное если номенклатурных позиций больше 100. Даже при 50 отрабатывает не совсем хорошо. Подскажите как решить данную проблему или хотя бы в какую сторону копать.


 ! 

Правила: 4
 
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #152218 · Ответов: 0 · Просмотров: 453
 

>  Индесация базы 1Сv8 под MS SQL - server 2014
george_smith
Отправлено: 16.04.19, 16:45


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Vladal @ Сегодня, 12:02 * ,
Спасибо за ответы! Размер базы 18637,69 MB MS SQL server 2014 management studio.
Средствами 1С, а именно ТиИс.. еще не делал, в конце недели попробую. Думал, что через sql-сервер это более эффективно.
Заметил что, физически, работать начало, все таки быстрее.
В свой новосозданный maintenance plan включил, так же update statistics task и DBCC FREEPROCCACHE.
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #151561 · Ответов: 4 · Просмотров: 711
 

>  Индесация базы 1Сv8 под MS SQL - server 2014
george_smith
Отправлено: 16.04.19, 11:13


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 16.04.19
Пользователь №: 65103


Здравствуйте!
Хочу увеличить производительность системы "Управление торговым предприятием для Украины", редакция 1.2. (1.2.48.1)
База 1Сv8.3 под MS SQL (mdf - файл весить около 15 gb., log урезанный до 1 gb.).
До перестройки индексов запрос sys.dm_db_index_physical_stats показал для многих объектов id avg_fragmentation_in_percent больше 30%.
После Rebuild Indexes ситуация не изменилась. Запрос sys.dm_db_index_physical_stats показал тоже самое.
Подскажите как победить высокий процент не фрагментированых индексов? Может через Reorganize Indexes? Чем эти два способа отличаются.


  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #151550 · Ответов: 4 · Просмотров: 711
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 09.04.20, 12:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!