Версия для печати темы (https://pro1c.org.ua/index.php?s=9fc12498d1f2a889064c710b040adf73&showtopic=65627)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Тематическое общение _ Вопрос по структуре данные МеДок Firebird

Автор: Squall84 02.04.21, 12:43

Доброго времени суток. Нужно подключиться к базе Медка и получить только зарегистрированные налоговые накладные.

Я подключился к базе FireBird. Получаю список НН. Тут все работает без проблем.

Но не могу понять откуда получить признак - зарегистрирован или нет. Если подключаться по API методом OpenDocumentByExDocID(), то можно указать статус документа. Т.е. принят, не принят, зарегистрирован и т.п. Но в основной таблице в базе я не вижу этого признака.

Есть подозрение, что этот статус хранится в другой таблице. Половину таблиц перебрал, не вижу, где может храниться этот статус.

Возможно кто-то делал подобное и может подсказать?

Автор: 29a 12.04.21, 14:06

Squall84 @ 02.04.21, 13:43 * ,

            СтрокаПодключения = "Driver={"+СокрЛП(ПараметрыПодключенияSQL.Драйвер)+"};Server="+СокрЛП(ПараметрыПодключенияSQL.Сервер)+";Database="+СокрЛП(ПараметрыПодключенияSQL.База)+";User ID="+СокрЛП(ПараметрыПодключенияSQL.Пользователь)+";Password="+СокрЛП(ПараметрыПодключенияSQL.Пароль)+";";
            
            ADODBConnection = Новый COMОбъект("ADODB.Connection");
            ADODBConnection.ConnectionString = СтрокаПодключения;
            ADODBConnection.CursorLocation= 3;
            ADODBConnection.Open();
            
            ADODBCommand = Новый COMObject("ADODB.Command");
            ADODBCommand.ActiveConnection = ADODBConnection;
            ADODBCommand.CommandTimeOut = 10000;
            
            ADODBCommand.CommandText = ТекстЗапроса;                    
            
            RS = Новый COMОбъект ("ADODB.RecordSet");
            
            Попытка
                RS = ADODBCommand.Execute();
            Исключение
                Сообщить(ОписаниеОшибки(), СтатусСообщения.Важное);
                Продолжить;
            КонецПопытки;
            
            ВсегоЗаписей = RS.RecordCount;
            
            Пока RS.EOF() = 0 Цикл
                //запись
                Инд = 0;
                Структура = Новый Структура;
                //все ее поля
                Для Каждого П Из RS.Fields Цикл
                    Если RS.fields(Инд).Value = Null Тогда
                        Структура.Вставить(П.Name, "");
                    Иначе    
                        Структура.Вставить(П.Name, RS.fields(Инд).Value);
                    КонецЕсли;    
                    Инд = Инд + 1;
                КонецЦикла;
                //REGDATE - дата регистрации документа в налоговой, если не пустая значит зарегистрирован
            КонецЦикла;

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua