Версия для печати темы (https://pro1c.org.ua/index.php?s=970930185f09fbb1974adf041da8ddca&showtopic=67336)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ управление текстом програмно

Автор: 4andriy 16.09.23, 13:26

в конфигураторе можно изменять размер и цвет шрифта
нужно менять без конфигуратора сразу на форме, например кнопкой

Автор: AnryMc 18.09.23, 10:00

4andriy @ 16.09.23, 14:26 * ,

https://pro1c.org.ua/index.php?showtopic=5960


FormEx версия 2.0.5.91

...
Средства доступа и изменения свойств для любых реквизитов формы
...

Автор: 4andriy 18.09.23, 10:24

AnryMc @ Сегодня, 11:00 * ,
форму умею, я хочу что-бы текст типа "Акт" или "Счет" вверху формы документа можно было раскрашивать вручную без перехода в конфигуратор

4andriy @ Сегодня, 11:11 * ,
на форме элемента

Автор: volodya1122 18.09.23, 13:43

Цитата(4andriy @ 18.09.23, 10:24) *
на форме элемента

1. Поясните что имеется в виду. Форма документа в 1С, где заполняются данные. Или печатная форма - которая выводится на печать?
2. И каков сакральный смысл в этом?

Автор: 4andriy 18.09.23, 14:56

volodya1122 @ Сегодня, 14:43 * ,
журнал документов - новая строка - выбор документа - например СЧЕТ - дальше открывается сам счет. нужно что-бы если в документе есть ошибка слово "СЧЕТ" был написан красным до распечатывания. в идеале хочу запрограмировать что-бы он светился) хочу добавить в 1с немного визуального оформления. ничего по функционалу - только красота.

Автор: volodya1122 19.09.23, 15:54

4andriy @ Вчера, 14:56 * ,
Можно раскрасить табличную часть журнала документов. Например так. Формексом

Функция КолонкаТекстВТабличнойЧастиЖурнала()       
    ЦветПроба=Число(НомерДок);
    Возврат "BRUSH["+(ЦветПроба*1450)+"] "+"COUNT["+2+"]";;

    // FONT[<Цвет>] - задает цвет шрифта строки;
    // BRUSH[<Цвет>] - задает цвет фона строки;
    // FONT_S[<Цвет>] - задает цвет шрифта строки, если она является текущей (не влияет на текущую ячейку);
    // BRUSH_S[<Цвет>] - задает цвет фона строки, если она является текущей (не влияет на текущую ячейку);
    // COUNT[<КоличествоКолонок>] - задает количество колонок, на которые распространяется раскраска;
    // INDENT[<Отступ>] - задает количество колонок, которое необходимо пропустить перед началом раскраски;
    // FONTSET[<КодШрифта>] - задает шрифт строки;
    // FONTSET_S[<КодШрифта>] - задает шрифт строки, если она является текущей;

КонецФункции


Процедура ПослеОткрытия()  
    ФормаРасш = СоздатьОбъект("РасширениеФормы");
    ФормаРасш.УстановитьФорму(Форма);  
    ФормаРасш.Максимизирована = 1;    
    Сервис = СоздатьОбъект("Сервис");
    Сервис.ВключитьРаскраскуТаблиц();
КонецПроцедуры


Насчет слова "Счет" на самой форме документа. Можно сделать несколько вариантов надписи в разных цветах, и по условию показывать нужное.

Автор: 4andriy 22.09.23, 17:36

volodya1122 @ 19.09.23, 16:54 * ,
Насчет слова "Счет" на самой форме документа. Можно сделать несколько вариантов надписи в разных цветах, и по условию показывать нужное.

а как показывать на форме и скрывать по условию?

Автор: volodya1122 24.09.23, 14:24

4andriy @ 22.09.23, 17:36 * ,

Очень просто:

Если Условие1 тогда
Форма.Дата1.видимость(0);
Форма.ТекстНаФорме.видимость(0);
Форма.ТекстНаФорме1.видимость(1);
ИначеЕсли Условие2 тогда
Форма.Дата1.видимость(1);
Форма.ТекстНаФорме.видимость(0);
Форма.ТекстНаФорме1.видимость(1);
ИначеЕсли Условие3 тогда
Форма.Дата1.видимость(1);
Форма.ТекстНаФорме.видимость(1);
Форма.ТекстНаФорме1.видимость(0);
Иначе
Форма.Дата1.видимость(0);
Форма.ТекстНаФорме.видимость(1);
Форма.ТекстНаФорме1.видимость(0);
КонецЕсли

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua