Версия для печати темы (https://pro1c.org.ua/index.php?s=bc329f7fc4c24f49896a0b031d086bef&showtopic=67326)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ Ошибка отбора: УстановитьОтбор - Неверное имя реквизита

Автор: 4andriy 09.09.23, 20:25

//******************************************************************************
//
Процедура ПриВыбореЗнач()
    ТекущийВидОтбора = СписокВидовОтбора.ПолучитьЗначение(СписокВидовОтбора.ТекущаяСтрока());
    Если ТекущийВидОтбора = "ПоФирме" Тогда
        Форма.СписокВидовДокументов.Видимость(0);
        УстановитьОтбор("Фирма", СписокЗнач);
        ВидыОтбора("");
    ИначеЕсли ТекущийВидОтбора = "ПоКонтрагенту" Тогда
        Форма.СписокВидовДокументов.Видимость(0);
        УстановитьОтбор("Контрагент", СписокЗнач);
        ВидыОтбора("");
    ИначеЕсли ТекущийВидОтбора = "ПоАвтору" Тогда
        Форма.СписокВидовДокументов.Видимость(0);
        УстановитьОтбор("Автор", СписокЗнач);
        ВидыОтбора("");
    ИначеЕсли ТекущийВидОтбора = "ПоВидуДокумента" Тогда
        Форма.СписокЗнач.Видимость(0);
        ПриВыбореВидаДокумента();
    КонецЕсли;
КонецПроцедуры // ПриВыбореКонтрагента


Из списка выбираю контрагента, и тогда ошибка отбора:

УстановитьОтбор("Фирма", СписокЗнач);
{Журнал.Общий.Форма.ФормаСписка.Модуль(16)}: Неверное имя реквизита!

Автор: 4andriy 10.09.23, 13:04

4andriy @ Вчера, 21:25 * ,
ошибки уже нет, работает выборка по фирме, автору, а по контрагенту нет

Автор: 4andriy 10.09.23, 15:09

//******************************************************************************
Процедура ПриВыбореВидаОтбора()
    ТекущийВидОтбора = СписокВидовОтбора.ПолучитьЗначение(СписокВидовОтбора.ТекущаяСтрока());
...
    ИначеЕсли ТекущийВидОтбора = "ПоКонтрагенту" Тогда
        Форма.СписокЗнач.Видимость(1);
        Форма.СписокВидовДокументов.Видимость(0);
        Форма.СписокЗнач.НазначитьТип("Справочник.Контрагенты");
...
    КонецЕсли;
    ПриВыбореЗнач();
КонецПроцедуры // ПриВыбореВидаОтбора
//******************************************************************************


При выборе по контрагенту пусто.

Автор: 4andriy 11.09.23, 8:56

4andriy @ Вчера, 16:09 * ,
Работает. Надо было добавить Группу отбора "Контрагент".

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua