Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Обучение по программированию 1С 8.3. Создание внешнего отчета "Отчет по продажам". [раздел Обучающее видео]
Автор macho210386 — 13.10.19, 18:15 — 0 комментариев


Описание:
Как создать внешний отчет. - создание внешнего отчета "Отчет по продажам". Описание механизма СКД. Встраивание внешнего отчетам в конфигурацию "Бухгалтерия для Украины ред. 2.0".
Просмотров: 9, оставить комментарий   
Помогите создать внешнею печатную форму [раздел Программирование в 1С Предприятие 8.3]
Автор Laky2006 — 12.10.19, 23:17 — 2 комментариев
Здравствуйте я только начинаю знакомиться с 1с8,3 есть такая конфигурация

Платформа: 1С:Предприятие 8.3 (8.3.15.1656)
Конфигурация: Управление небольшой фирмой для Украины (базовая), редакция 1.6 (1.6.10.1) (http://1c.ua/v8/RegionalSolutions_UA_UNF.php)

Хочу вставить внешнею печатную форму но остановился на ошибке вывода наименования товара который сдается в ремонт в друменте ПриемПередача в ремонт.
В "Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати)" хочу вывести на печать и указываю
ОбластьШапка.Параметры.Товар = СсылкаНаДокумент.Номенклатура;

при попытке печати выдает ошибку "В обработчике печати не был сформирован табличный документ для : заказвнешний"

подскажите как правильно прописать Номенклатуру?

Код прописал ниже



Функция СведенияОВнешнейОбработке() Экспорт
ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;
МассивНазначений.Добавить("Документ.ПриемИПередачаВРемонт"); //Указываем документ к которому делаем внешнюю печ. форму
ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "Заказ реализации товаров внешний"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Версия", "1.0");
ПараметрыРегистрации.Вставить("Информация", "Эту ВПФ мы сделали для того что бы посмотреть возможности БСП ");
ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, "Заказ внешний", "заказвнешний", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции


Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление;
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры



Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "заказвнешний", "Заказ внешний", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));

КонецПроцедуры // Печать()



Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати)

ТабличныйДокумент = Новый ТабличныйДокумент;
МакетОбработки = ПолучитьМакет("МакетЗаказ");

//заполняем шапку
ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.НомерРеализации = СсылкаНаДокумент.Номер;
ОбластьШапка.Параметры.ДатаРеализации = Формат(СсылкаНаДокумент.Дата, "Л=uk_UA; ДЛФ=D");
ОбластьШапка.Параметры.Товар = СсылкаНаДокумент.Номенклатура;

//выводим шапку в табличный документ
ТабличныйДокумент.Вывести(ОбластьШапка);











КонецФункции
Просмотров: 34, последний комментарий от Laky2006   
Вітаємо з Днем Захисника України! [раздел http://pro1c.org.ua/]
Автор Лёша Гончарук — 11.10.19, 12:50 — 0 комментариев
Щиро вітаємо з Днем Захисника України!

Це справжнє свято мужності й сили духу, свято захисту і гідності – усіх тих якостей, що властиві лише справжнім боронителям і захисникам України, в тилу і на передовій.

Тож нехай у вас завжди вистачає наснаги, міцності духу та віри у наше спільне світле майбутнє.

Бажаємо вам здоров’я, успіхів, добробуту та завжди мирного неба!

Просмотров: 39, оставить комментарий   
Выбрать новый товар, который только добавили в базу [раздел Программирование в 1С Предприятие 8.3]
Автор Tseka — 10.10.19, 15:22 — 11 комментариев
1С:Предприятие 8.3 (8.3.8.2027)

"Управление торговлей для Украины", редакция 2.3.


Запросом пытаюсь выбрать только новый товар , который только добавили в базу , делаю это через "установку цен номенклатуры" .

Как в выборки оставить только товар с Регистратором "Поступление товаров и услуг" ?

ВЫБРАТЬ
    ЦеныНоменклатуры.Период,
    ЦеныНоменклатуры.Номенклатура.Наименование КАК НоменклатураНаименование,
    ЦеныНоменклатуры.Регистратор
ИЗ
    РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры


СГРУППИРОВАТЬ ПО
    ЦеныНоменклатуры.Период,
    ЦеныНоменклатуры.Номенклатура.Наименование,
    ЦеныНоменклатуры.Регистратор

ИМЕЮЩИЕ
    МИНИМУМ(ЦеныНоменклатуры.Период) > &ДатаМесяцНазад

УПОРЯДОЧИТЬ ПО
    НоменклатураНаименование



 ! 

Правила: 4, 5
 
Просмотров: 164, последний комментарий от fly   
Выгрузка Акта сверки в Медок, ошибка при вызове метода контекста (Edit) [раздел Программирование в 1С Предприятие 8.3]
Автор Мичман Харитонов — 10.10.19, 11:30 — 1 комментариев
Платформа 8.3.7,
Конфигурация самописная.
Переделываю на основе выгрузки для налоговых документов...

Код
Процедура ВыполнитьПередачуНакладных(Результат, ЭлементыФормы) Экспорт
    Попытка
        App = Новый COMОбъект("MEDOC.ZApplication");
    Исключение
        Сообщить("Приложение M.E.DOC не запущено!");
        Возврат;
    КонецПопытки;
    СведенияОПоставщике  =  УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Организация,  ТекущаяДата());
    КодПоЕДРПОУ  =  СокрЛП(СведенияОПоставщике.КодПоЕДРПОУ);
    ЭлементыФормы.Состояние.Заголовок = "Осуществляется передача Актов Сверки...";
    Передано = 0;
    Для каждого Стр Из Результат Цикл
        Если Стр.Передавать = Ложь Тогда
            Продолжить;
        КонецЕсли;
        
        PDate = Дата(Год(Стр.Ссылка.Дата), Месяц(Стр.Ссылка.Дата), День(Стр.Ссылка.Дата));
        
        
        ИД = Строка(Стр.Ссылка.УникальныйИдентификатор());
                
         Бланк = "1C82A3";  
         Формирование_АктаСверки(App,  Стр.Ссылка,  Бланк,  PDate,  ИД)
        
    КонецЦикла;
    App.RefreshRstDoc();
    ЭлементыФормы.Состояние.Заголовок = "Передача Актов сверки завершена успешно.";
    Сообщить("Передано " + Передано + " документ(ов) ");
    
КонецПроцедуры

Функция Формирование_АктаСверки(App,  Документ,  Бланк,  PDate,  ИД)
Doc  =  App.OpenOrCreateByExDocID(Бланк, 0, PDate,  , ИД, 0);
rsMain = Doc.DataSets("MAIN");
            //rsMain = Doc.DataSets();
            rsMain.Edit();
....


На rsMain.Edit(); спотыкается, выдает ошибку
Просмотров: 70, последний комментарий от Petre   
Проблемы при заполнении накладной на основании реализации [раздел Управление торговлей для Украины редакция 2 (Управление торговлей для России редакция 10)]
Автор Козлова Татьяна — 10.10.19, 10:46 — 1 комментариев
Добрый день.Работаю в программе 1С Предприятие 8.3 (8.3.10.2580) конфигурация "Управление торговлей для Украины"редакция 2.3 (2.3.29.1) Периодически возникает проблема при заполнении налоговой накладной.Накладную формирую на основании реализации.Реализация ,в свою очередь, на основании счета.Не всегда.но бывает часто,что при формировании налоговой мне программа выдает следующее:На текущий момент сумма неподтвержденных налоговых обязательств по одной или нескольким ставкам НДС меньше соответствующей суммы документа.Заполнить налоговую накладную номенклатурным составом невозможно.Открыть форму обработки заполнения налоговой накладной номенклатурным составом?Может кто сталкивался с таким,подскажите,где искать ошибку.Наш программист не в курсе.


 ! 

Правила:3, 4, 5
 
Просмотров: 64, последний комментарий от Макс1С   
Как прописать процедуру для элементов формы в глобальном контексте [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 10.10.19, 10:29 — 5 комментариев
Всем опять привет!
Проблема такая ....
Вот код:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Объект.Ссылка.Пустая()=Истина Тогда
    Элементы.ФормаКоманднаяПанель.ПодчиненныеЭлементы.ФормаОбщаяКомандаДанныеАвтозаполнения_Назначить.Видимость=Ложь;
    Элементы.ФормаКоманднаяПанель.ПодчиненныеЭлементы.ФормаОбщаяКомандаДанныеАвтозаполнения_Очистить.Видимость=Ложь;
    КонецЕсли;
КонецПроцедуры

Думаю любому на этом сайте ясно, какую цель ставит код данной процедуры. И где он обычно пишется. Да, конечно ... в самой форме.
Что нужно... Одной единственное ...
Прописать тоже самое в глобальном контексте. Т.е. на пример для всех форм объекта по всем документам.
Никто не подскажет как это реализовать?
Как это сделать в 1С? ... ВЕЛИКОМ и МОГУЧЕМ! smile.gif
Буду признателен!
Просмотров: 165, последний комментарий от Gigi   
Заполнение счетов учета при импорте контрагентов [раздел 1С Управление небольшой фирмой для Украины]
Автор n25 — 10.10.19, 9:32 — 5 комментариев
Столкнулся с тем, что при импорте заказов из Prom (через их обработку) создаются контрагенты с незаполненными счетами учета:



Из-за этого нельзя создать расходные накладные и поступления денег. Каждый раз открывать какждого контрагента и устанавливать ему счета несколько муторно.
Возможно ли чтобы счета при импорте устанавливались автоматически "по умолчанию"?

УНФ 1.6.9.1 1С 8.3.15
Просмотров: 81, последний комментарий от n25   
Объеденение полей запроса [раздел Программирование в 1С Предприятие 8.3]
Автор TailorMade — 10.10.19, 6:59 — 7 комментариев
Здравствуйте. Я бы хотел в этом запросе объеденить поля, у которых есть IDРодителя и равно ID другого задания. Это вообще возможно сделать? А то я пробовал и не получалось

ВЫБРАТЬ
    МИНИМУМ(ЗаказПокупателяРасшифровка.НомерСтроки) КАК НомерСтрокиТЧ,
    ЗаказПокупателяРасшифровка.Задание,
    СУММА(ЗаказПокупателяРасшифровка.ID) КАК ID,
    СУММА(ЗаказПокупателяРасшифровка.IDРодителя) КАК IDРодителя,
    СУММА(ЗаказПокупателяРасшифровка.Цена) КАК Цена,
    ЗаказПокупателяРасшифровка.Исполнитель,
    СУММА(ЗаказПокупателяРасшифровка.КоличествоЧасов) КАК КоличествоЧасов
ИЗ
    Документ.ЗаказПокупателя.Расшифровка КАК ЗаказПокупателяРасшифровка
ГДЕ
    ЗаказПокупателяРасшифровка.Ссылка = &ТекущийДокумент

СГРУППИРОВАТЬ ПО
    ЗаказПокупателяРасшифровка.Исполнитель,
    ЗаказПокупателяРасшифровка.Задание

УПОРЯДОЧИТЬ ПО
    НомерСтрокиТЧ
Просмотров: 129, последний комментарий от Vladal   
1С 8.3. Переход с базовой на Проф. [раздел Обучающее видео]
Автор macho210386 — 09.10.19, 17:14 — 0 комментариев
Как перевести базу с базовой версии в ПРОФ. Рассматривается конфигурация "Бухгалтерия для Украины ред. 2.0".

Просмотров: 46, оставить комментарий   
Группировка подзадач при выгрузке с Битрикс24 [раздел Программирование в 1С Предприятие 8.3]
Автор TailorMade — 09.10.19, 17:15 — 1 комментариев
Здравствуйте. Выгружаю задачи с Битрикс24 в 1С 8.3. При помощи "tasks.task.list"
Как можно сделать так, чтобы в ТЧ задача попадала и указывалась её подзадача? А то на данный момент подзадача выглядит так же, как и задача
И чтобы в Печатную форму попадали уже объедененные задачи с подзадачами

У подзадачи есть <parentId>, который равен <id> родителя. Но я не знаю как при формировании макета печати "объеденить" родительскую задачу с её подзадачами
Просмотров: 67, последний комментарий от Vofka   
Как программно получить цену по договору [раздел Программирование в 1С Предприятие 8.3]
Автор TailorMade — 09.10.19, 11:58 — 11 комментариев
Здравствуйте. Есть документ Заказ Покупателя. В нем есть Договор, у которого установлен тип цен. И по этому типу цен документов "Установка цен номенклатуры" установлена цена. Как программно с модуля документа Заказ Покупателя получить эту цену?
УТП 8.3
Просмотров: 139, последний комментарий от TailorMade   
Универсальный отчет 1С - как им пользоваться? [раздел Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11)]
Автор glavkomnn — 09.10.19, 0:51 — 0 комментариев
Коллеги приветствую!

Как мог, попытался описать по своим наблюдениям и практике, разобрать основные возможности инструмента "Универсальный отчёт", присутствующего в большинстве основных типовых конфигураций 1С 8.3 на управляемых формах ("УТ 11, БП 3.0, ЗУП 3.1, КА 2, ERP 2 и др.)

Конкретно использовал универсальный отчёт конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

Кто хорошо разбирается в этой теме, с какой основной целью его добавили в типовые конфигурации и как им правильно пользоваться?

Можно ли с его помощью делать соединения, запросы, строить произвольные алгоритмы, то что позволяла консоль отчетов 8.2? Где в типовых конфигурациях 8.3 на управляемых формах, то что на конфах 8.2 называлось консоль отчетов?
Просмотров: 62, оставить комментарий   
Редактирование печатной формы счета в1с7.7 [раздел Программирование в 1С Предприятие 7.7]
Автор jojojoba2 — 08.10.19, 10:56 — 4 комментариев
Добрый день!

Помогите начинающему программисту и просьба не судить строго))). Я изучаю программирование в 1С 8 . Поставили задачу по 1с 7.7 Предприятие (Бухгалтерский учет по Украине) - доработать печатную форму документа счет-фактура. Начал разбиратся и увидел что 7 очень сильно отличается от 8. Есть внешний макет каторый лежит в \1cv77_db\Management\ExtForms\PrnForms SF3_ukr.mxl. В печатной форме нужно вывести р/р и банк контрагента. В документе счет-фактура нашел процедуру ПЕЧАТЬ

Код
Процедура Печать()
    //----
    Ф=_глПолучитьИмяФайлаПечатнойФормы("SF3",Метаданные.Документ(Вид()).Представление());
    
    ЕстьСкидка = 1;
    фУкр = ?(Константа.ФормыНаУкраинском = Да, 1, 0);
    Если (Константа.ИспользоватьСкидку<>Да) Или (ЧтоПродаем<>Перечисление.ЧтоПродаем.ТМЦ) Тогда
        ЕстьСкидка = 0;
    КонецЕсли;
    
    Таб = СоздатьОбъект("Таблица");
    Если ПустоеЗначение(Ф)=0 Тогда
        Таб.ИсходнаяТаблица(КаталогИБ()+"ExtForms\PrnForms\"+Ф);
    Иначе
        Таб.ИсходнаяТаблица("Таблица"+?(Константа.ФормыНаУкраинском = Да,"_Укр",""));
    КонецЕсли;
    
    Если Заказ.Выбран() = 1 Тогда
        Номер = Заказ.НомерДок;
        Если Заказ.Вид() = "Договор" Тогда
            Если ПустоеЗначение(Заказ.НомерДоговора) = 0 Тогда
                Номер = Заказ.НомерДоговора;
            КонецЕсли;
        КонецЕсли;
        тЗаказ = глУкр(Заказ.ПредставлениеВида()) + " № " +СокрЛП(Номер) + ?(фУкр = 1, " від "," от ") + Заказ.ДатаДок;;
    Иначе
        тЗаказ = ?(фУкр = 1,"Без замовлення","Без заказа");
    КонецЕсли;

    глУстПропись(Валюта);
    Таб.ВывестиСекцию("Шапка");
    Ном = 1;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
        ЕдИзм = ?(ТМЦ.Вид()="ТМЦ",Ед,ТМЦ.БазЕдиница);
        Таб.ВывестиСекцию("Строка");
        Если ФКомп = 1 Тогда
            СпрКомп = СоздатьОбъект("Справочник.СоставКомплекта");
            СпрКомп.ИспользоватьВладельца(ТМЦ);
            СпрКомп.ВыбратьЭлементы();
            Пока СпрКомп.ПолучитьЭлемент() = 1 Цикл
                Таб.ВывестиСекцию("Составляющая");        
            КонецЦикла;
        КонецЕсли;
        Ном = Ном+1;
    КонецЦикла;
    Если ЕстьСкидка=1 Тогда
        Таб.ВывестиСекцию("Скидка");
    КонецЕсли;
    Если (ВидНДС.Код = "БезНДС") Тогда      
        Таб.ВывестиСекцию("БезНДС");        
    Иначе
        Таб.ВывестиСекцию("ДноНДС");        
    КонецЕсли;
    Таб.ВывестиСекцию("Дно");
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,,);
    Таб.Показать("ПЕЧАТЬ: Счет-фактура","");
КонецПроцедуры


Я не могу понять где в коде и в каких модулях выводятся параметры и шаблоны печатной формы каторые есть на форме . Где код с запросами по выводу данных. Искал во всех модулял в конфигурации,не нашел. Может есть какой-то внешний модуль?Где он может находиться? Как правильно в 1с7.7 прописать новый параметр в коде?

Помогите разобраться.Если можно скиньте примеры или какую-то инструкцию. Смотрел видео - там редактируют печатную форму вместе с макетом и с модулем *.ert . У меня внешний только макет *.xml.

Заранее спасибо.


 ! 

Правила: 9
 
Просмотров: 134, последний комментарий от jojojoba2   
отличие базовой УНФ от микро [раздел 1С Управление небольшой фирмой для Украины]
Автор aik2001 — 08.10.19, 9:40 — 0 комментариев
А в чем отличие базовой УНФ от микро. А то в описании их сравнивают с проф версией , и отличия те же самые.
Просмотров: 48, оставить комментарий   
Есть ли какие нибудь обновления по поводу изъятия из обихода 5, 2 и 1 коп? [раздел Вся 1С]
Автор twilight_dream — 07.10.19, 23:36 — 1 комментариев
Типа в документах уменьшить количество знаков за запятой, например в расходном, приходном кассовых ордерах, в кассе ККМ (весовой товар может давать копейки в конце)?
Просмотров: 76, последний комментарий от Vladal   
Программное создание кнопки для всех документов в формах объекта [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 07.10.19, 13:34 — 23 комментариев
Всем опять привет!
Вообще на данном сайте как то кем то было сказано про мысли в слух ))
Но чем пожалуй решил поделиться, это уже не "мысли в слух, а мысли в крик smile.gif
Хотите знать, чем вообще занимаюсь, и на что трачу кучу времени...
ДОДЕЛЫВАЮ ТО ЧТО ПРОИЗВОДИТЕЛИ СИСТЕМЫ 1С НЕ ДОРАБОТАЛИ. Вот чем.
Просто создал пустую голую тестовую базу и пишу кучу функций к ней, которые максимально универсальны, и поэтому гораздо удобнее чем встроенные функции.
И кроме того, вообще улучшаю возможности конфигурации в целом. Добавляя туда кучу тех возможностей которых не хватает.
Тех возможностей, которые уже должны были быть в системе 1С во встроенном готовом виде. Что бы программисту меньше было работы.
И все это элементарно для того что бы подготовить почву для возможных заказов. Что бы делать их быстро и эффективно. А не заниматься разной ерундой, и тратить на это время. Той ерундой, которой вынуждает заниматься платформа своими многочисленными недоработками.
Вот чем я занимаюсь!
Ну согласитесь... занимаюсь тем чем НЕ ДОЛЖЕН ЗАНИМАТЬСЯ!
Так что, без всего этого караул.
Ладно ... перейду к вопросу:
Вот код:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
НоваяКоманда = ЭтаФорма.Команды.Добавить("ДанныеАвтозаполнения_Сохранить");
НоваяКоманда.Действие = "ДанныеАвтозаполнения_Сохранить";
НоваяКоманда.Заголовок = "Назначить реквизиты автозаполнения";
НоваяКоманда.Подсказка = "Назначить реквизиты автозаполнения по указанным значениям формы";
НоваяКоманда.Картинка = БиблиотекаКартинок.СоздатьНачальныйОбраз;
//НоваяКоманда.Отображение = КартинкаИТекст; // Тут пожалуйста ... не получается  с отображением ... если не трудно сменить строчку
КнопкаФормы  = Элементы.Добавить("КомандаДанныеАвтозаполнения_Сохранить", Тип("КнопкаФормы"),КоманднаяПанель);
КнопкаФормы .ИмяКоманды = "ДанныеАвтозаполнения_Сохранить";    
//КнопкаФормы .Вид = ВидКнопкиФормы.КнопкаКоманднойПанели;
КонецПроцедуры

Думаю тут все понимают назначение примера данного кода. Но вопрос в чем:
Как сделать то что делает код, для любой ФормаОбъекта... ЛЮБОЙ! На пример по любому объекту документа.
Как известно есть подпись на событие: "ОбработкаПолученияФормы".
И поэтому вот процедура по стандарту:
Процедура ДокументПолученияФормыОбработкаПолученияФормы(Источник, ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка) Экспорт
Если ВидФормы="ФормаОбъекта" Тогда
// И как тут ... или это не подходит и так не получиться для указанной цели..
//НоваяКоманда = Источник.Команды.Добавить("ДанныеАвтозаполнения_Сохранить");        
КонецЕсли;

Короче хотел по быстрому получить ответ возможно ли это. Или великий и могучий 1С опять не позволяет сделать разумнее.
Если да то как?
Буду признателен!
Просмотров: 477, последний комментарий от Gigi   
Как создать отчет для текущего пользователя 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 06.10.19, 20:40 — 2 комментариев
Здравствуйте. Еще один интересный вопрос. У меня есть доработанная сетевая версия 1С7.7 Торговля + Склад. Есть сотрудники. Я их прописываю, как пользователей с правами созданного интерфейса Инженер. Есть отчет по сдельной части зарплаты. Мне нужно, чтобы программа автоматически подставляла в этот отчет сотрудника, который в данный момент под своим именем пользователя зашел в программу. К примеру, что нужно написать ТЗ.Сотрудник = ????. Или по-другому сделать? Чтобы в дальнейшем сотрудник мог посмотреть показатели. Только свои. В справочниках Сотрудники и Пользователи ФИО идентичны.
Спасибо!
Просмотров: 143, последний комментарий от andrew76   
Резервное копирование 1с: быстрый и удобный способ восстановления данных без выхода пользователей [раздел Обучающее видео]
Автор glavkomnn — 06.10.19, 15:58 — 1 комментариев
Как сделать резервную копию отдельно взятых справочников или документов программы 1С Бухгалтерия для Украины, не останавливая работу, не выгоняя пользователей и не теряя время на выгрузку и загрузку копии базы.

Автор предлагает оригинальный способ.

Очень быстрая выгрузка копии нужного участка данных и их восстановление в базе 1С после неудачных экспериментов с базой.

Просмотров: 103, последний комментарий от awp   
Как в отчет 1С добавить колонки, которые в нём не предусмотрены [раздел Обучающее видео]
Автор glavkomnn — 06.10.19, 15:56 — 0 комментариев
Возможности и правила использования пользовательских полей в схеме компоновки данных отчета.

На примере типового отчета "Валовая прибыль предприятия" конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

Просмотров: 187, оставить комментарий   
RSS Текстовая версия Сейчас: 14.10.19, 3:56
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!