Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Можно ли сделать автоматическое обновление отчета? 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 19.10.19, 18:29 — 2 комментариев
Здравствуйте! И еще один вопрос. Если у меня открытый отчет на экране и какой-то документ добавился или изменился, есть ли какие-то способы сделать автоматическое обновление отчета, чтобы эти изменения сразу в нем отразились? Спасибо.
Просмотров: 58, последний комментарий от volodya1122   
Сообщение "Недостаточно прав в новом интерфейсе 1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 18.10.19, 19:43 — 3 комментариев
Здравствуйте! Я на финальной стадии доработки. Такой вопрос. Я создал новый интерфейс инженера и отметил ему в конфигураторе права доступа до различных документов, отчетов, справочников и т.д., как считаю нужным. Но если заходить от его имени в программу, выскакивает сообщение "Недостаточно прав". Правда, программа работает. При выходе из программы такое же сообщение. Что это значит, и каких прав недоситаточно? Спасибо.
Просмотров: 56, последний комментарий от ZUBR   
Почему программно не заполняется поле с типом Справочник.Сотрудники 1с 7.7 конф 7.7.003 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 18.10.19, 16:56 — 4 комментариев
Здравствуйте!
Мне нужно, чтобы поле Инженер в моей расходной накладной, имеющий тип Справочник.Сотрудники, заполнялось автоматически. Для этого я написал процедуру "Виконав". Привожу часть кода.

Спр = СоздатьОбъект("Справочник.Сотрудники");               //Автозаполнение поля Инженер
     Спр.ВыбратьЭлементы();
      Пока Спр.ПолучитьЭлемент()=1 Цикл  
          Если Спр.Наименование = СокрЛП(ПолноеИмяПользователя()) Тогда
    Инженер = Спр.Наименование;
    Сообщить(Спр.Наименование);
    КонецЕсли;
    КонецЦикла;


Для выяснения проблемы в тело оператора Если я ввел оператор Сообщить. При выполнении процедуры в поле сообщений появляется наименование сотрудника. Значит, условие выполняется. Но при этом поле Инженер с типом Справочник.Сотрудники остается пустым, хотя оно должно быть заполненным. Я понимаю, что здесь могут быть проблемы потому, что это справочник. Подскажите, что я делаю неправильно. Спасибо!
Просмотров: 66, последний комментарий от ZUBR   
Не инициализируется текст модуля менеджера в конфигураторе [раздел Программирование в 1С Предприятие 8.3]
Автор onsamuy — 18.10.19, 14:33 — 1 комментариев
Собственно в чем дело.

Есть перепуганый заказчик. Все что я кодирую - сначала кодирую в базе тест. Далее заказчик проверяет работу, и самостоятельно выгружает конфу в файлик cf из базы тест, и загружает файлик в базу рабочая. Проблема в том, что я в базе тест, в обработке добавил процедуру ВыгрузкаДБФНовая(). После проверки и манипуляций заказчика с файликами, когда открываю конфигуратор базы рабочая - не вижу этой процедуры, то есть код модуля вижу какбы старый. Хотя алгоритм работает по новому, даже в отладчике курсор бегает по несуществующим строкам модуля smile.gif))))
Проблема известная, лечится или удалением из списка базы добавлением заново, или удалением файлов кеша на локальной машине. НО.. не помогает!!! Как можно все таки вылечить это?
Просмотров: 57, последний комментарий от getnight   
Системная функция "ТипЗнч()" - не вопрос, а просто мнение [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 18.10.19, 12:07 — 9 комментариев
Всем опять привет!
В данном случае вышел на форум не по поводу вопроса, а по поводу просто мнения.
Не знаю, уместно ли это и есть ли польза какая то от этого.
Хотя думаю все таки есть. По крайней мере думаю гостям данного сайта пригодится.
В особенности новичкам в системе 1С. Тем которые так же как я столкнулись с кое какими вопросами. И пока так и не нашли ответ почему разработчики великого и могучего языка 1С сделали именно так как сделали. А не чуть иначе.
Не буду объяснять детально в чем именно возникает вопрос, а вместо этого скину одну функцию, которую пришлось самому написать в общем модуле.
Думаю понимающему и без слов будет ясно почему и зачем пришлось писать такую функцию, и в чем именно сама функция: "ТипЗнч()" вынудила опять заниматься изобретательством и прочей ерундой.
В особенности если сравнивать две функции. Одна из которой это функция самой системы 1С, т.е. та самая: "ТипЗнч()" и другую, которая, слава богу вообще оказалась, но которая уже не из 1С, а из ХML. Т.е. если сравнить эти две функции и задать вопрос какая лучше. От 1С или от ХML. И лучше в смысле больших возможностей.
Вот код функции:
Функция ПоЗначению(Значение,ЗначВозврата) Экспорт
XMLТип=XMLТипЗнч(Значение).ИмяТипа;
Если Найти(XMLТип,".")=0 Тогда
    ТипГруппа=Строка(ТипЗнч(Значение)); //ТипГруппа=ТипЗнч(Значение);        
    Тип=ТипГруппа;
    МетаданныеГруппа=ТипГруппа;
    МетаданныеИмя=ТипГруппа;
    МетаДанныеПолноеИмя=ТипГруппа;
Иначе
    МетаДанныеПолноеИмя=Значение.Метаданные().ПолноеИмя();
    МетаданныеГруппа=Config_String_серв.Парсер(МетаДанныеПолноеИмя,".",1);
    МетаданныеИмя=Config_String_серв.Парсер(МетаДанныеПолноеИмя,".",2);
    Если Найти(XMLТип,"RecordSet")>0 Тогда
    ТипГруппа="НаборЗаписей";    
    ИначеЕсли Найти(XMLТип,"Ref")>0 Тогда
    ТипГруппа="Ссылка";    
    Иначе
    ТипГруппа="Объект";    
    КонецЕсли;
    Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
КонецЕсли;    
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если ЗначВозврата="Структура" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[ЗначВозврата];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
         //------- Ref --------- Object
            //"Catalog","Справочник"
            //"Document","Документ"
            //"Enum","Перечисление"
            //"ChartOfCharacteristicTypes","ПланВидовХарактеристик"
            //"ChartOfAccounts","ПланСчетов"
            //"Task","Задача"
         //---- RecordSet ------
            //"InformationRegister","РегистрСведений"
            //"CalculationRegister","РегистрРасчета"
КонецФункции

К этому мне ничего еще добавить. Поэтому воздержусь ... Ибо на счет "возможностей" функции "ТипЗнч()", об этом, думаю сами эти строки кода скажут лучше всяких слов.
Так что, на этот раз решил не задавать вопросы, а просто высказать мнение ...
Ладно ... вот собственно и все.
Просмотров: 236, последний комментарий от Gigi   
Как изменить список печатных форм в документах [раздел 1С Управление небольшой фирмой для Украины]
Автор Laky2006 — 17.10.19, 17:03 — 7 комментариев
Здравствуйте возможно ли в документе скрыть или поместить в низ печатные формы которыми не планируется пользоваться?
Просмотров: 92, последний комментарий от Toka   
Вакансия программист 1С BAS ERP [раздел Предложения работы]
Автор EurocaseHR2019 — 17.10.19, 15:55 — 0 комментариев
В связи с развитием собственной системы управления предприятием на базе 1С:ERP, компания «EUROCASE» приглашает талантливых программистов, имеющих опыт работы с продуктами 1С:ERP/ 1С:Предприятие.

Производственная компания «EUROCASE» — высоко технологическое предприятие по производству упаковочных материалов, пакетов, пленок.
Компании производители пищевой промышленности Украины являются потребителями нашей продукции!

Наш будущий коллега:
-Имеет опыт программирования на платформе 1С:Предприятие 8.3 более 2-х лет;
-Имеет опыт коллективной разработки;
-Умеет вести разработку под управляемое приложение, тонкий клиент;
-Знает типовые конфигурации на управляемых формах;
-Знает (понимает) принципы бухгалтерского, налогового, управленческого учета;
-Умеет работать на результат, обладает системным мышлением, аналитическим складом ума.

Будет плюсом:
-Наличие сертификатов 1С:Специалист;
-Опыт участия в проектах автоматизации на базе 1С:ERP;
-Дополнительное образование — экономика предприятия, бухгалтерия;
-Уверенные знания в одной или нескольких предметных областях: бухгалтерский учет, управление производством.

Основные задачи:
-Модернизация существующих, разработка новых функциональных модулей 1С:ERP под задачи предприятия;
-Обучение и поддержка ключевых пользователей, написание инструкций.

Мы предлагаем:
-достойная заработная плата;
-работа во внутреннем проекте на базе 1С:ERP;
-интересные задачи, активное участие в развитии проекта;
-регулярные тренинги и обучение, профессиональный рост;
-оплачиваемое компанией внешнее обучение;
-возможность работать удаленно или в комфортном офисе (м. Печерская).

С удовольствием уделю внимание каждому, кого заинтересовала вакансия, в личных сообщениях отвечу на дополнительные вопросы, а так же присылайте резюме на почту hr@eurocase-pack.com
Просмотров: 43, оставить комментарий   
Вывод данных из поля табличной части в дополнительное поле формы списка документа [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 17.10.19, 12:16 — 6 комментариев
Добрый день!

Есть задача в 1С8.3 в форму списка документа Платежное поручение входящее добавить новое поле ЗаказПокупателя и в него вывести данные с табличной части РасшифровкаПлатежа из поля сделка(в котором отображается заказ покупателя). Помогите пожалуйста разобратся начинающему програмисту :

Код
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
     ЭтотОбъект = Документы.ПлатежноеПоручениеИсходящее;
    Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
                  |    ЗаказПокупателя.Ссылка
                  |ИЗ
                  |    Документ.ЗаказПокупателя КАК ЗаказПокупателя
                  |ГДЕ
                  |    ЗаказПокупателя.Ссылка = &ТекущийДокумент";
    
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
    Результат = Запрос.ВыполнитьПакет();
    ВыборкаЗП = Результат.Выбрать();
    
    ОтборВыборки = Новый Структура("Заказ");
    Для Каждого ТекОформление Из ОформленияСтрок Цикл
        ОтборВыборки.ЗаказПокупателя = ТекОформление.ДанныеСтроки.Ссылка;
        
         ТекОформление.Ячейки.ЗП.Значение(ВыборкаЗП.НайтиСледующий(ОтборВыборки));
        
    КонецЦикла;
КонецПроцедуры


ЗП ---это колонка в форме списка в которую нужно вывести данные


При запуске выдает ошибку:


Документ.Справки_расчеты_роялти.Форма.ФормаСписка.Форма(132)}: Поле объекта не обнаружено (СсылкаНаОбъект)
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);

----- Как правильно задать параметры колонки ЗП (поле ввода или указать данные реквизита )
----- Правильный запрос вывода значения с табличной части этого документа(я попытался через ссылку на заказ покупателя)
----- Правильный метод вывода значения в колонку формы списка.


Если можно , сбросьте пример.

Заранее всем спасибо.


 ! 

Правила: 9
 
Просмотров: 83, последний комментарий от fly   
Как программно установить значение DPI при сканировании через WIA ? [раздел Тематическое общение]
Автор andrew76 — 17.10.19, 8:22 — 15 комментариев
Добрый день !

Появилась необходимость сканирования фотографий из 1с 8.2 через сервис VIA.
Все работает в принципе,но хотелось бы устанавливать значение DPI программно.
Не могу разобраться с тех.документацией на WIA.
в принципе после вызова следующей строчки кода появляется диалоговое окно WIA.В этом окне и устанавливается значение DPI.
По умолчанию оно 150.А мне нужно 300.Можно ли задать его программно ?

DevManager = Новый COMОбъект("WIA.CommonDialog");
Просмотров: 169, последний комментарий от Vofka   
Декларация по Акцизному налогу [раздел Отчеты / Обработки]
Автор Gorus — 16.10.19, 9:31 — 0 комментариев
В новой декларации по акцизному налогу (действует с сентября 2019г.) появляется ошибка при заполнении: "Поле об`єкту не виявлено D8H01G1S_1" Ошибка проявляется когда по одной налоговой инспекции проходять несколько кодов КОАТУУ.

Исправленная версия обработки: Прикрепленный файл  Reglamentirovannyj_otchet_deklaratsiya_aktsiznogo_naloga.zip ( 655.36 килобайт ) Кол-во скачиваний: 12
Просмотров: 73, оставить комментарий   
Как в доработанную конфигурацию перенести данные?1с 7.7 конф 7.7.00 [раздел Программирование в 1С Предприятие 7.7]
Автор ZUBR — 16.10.19, 1:00 — 1 комментариев
Здравствуйте! Я практически закончил доработку стандартной конфигурации под себя. Дальше стоит вопрос, как данные со стандартной конфигурации перенести в новую. Журналы, склад, документы и т.д. Возможно ли это и каким путем. Спасибо.
Просмотров: 79, последний комментарий от volodya1122   
Как получить список всех форм в 1С [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 15.10.19, 11:17 — 12 комментариев
Всем опять привет!
Вообще есть формы системные. Это формы для метаданных. Которые разделены по категориям: ФормаОбъекта, формаСписка и ФормаВыбора.
А есть созданные в конфигурации формы.
Так вот, нужна функция возвращающая значения списка созданных форм. В формате на пример структуры или списка значений ... Не важно.
Для лучшего понимания вопроса вот на пример следующая функция. Написать которую, в чем плюс было не сложно:
//СписокЭлементовМетаданных = ОбщийМодуль_МетаДанные.СписокЭлементовМетаданных(МетаданныеГруппа,"СписокЗначений");
Функция СписокЭлементовМетаданных(МетаданныеГруппа,ФорматВозрата) Экспорт
Перем СписокЭлементовМетаданных, ЭлементМетаданных;
Если ФорматВозрата="СписокЗначений" Тогда
    СписокЭлементовМетаданных = Новый СписокЗначений();
    Для Каждого ЭлементМетаданных Из Метаданные[МетаданныеГруппа] Цикл
    СписокЭлементовМетаданных.Добавить(ЭлементМетаданных.Имя,ЭлементМетаданных.Синоним);
    КонецЦикла;
    Возврат СписокЭлементовМетаданных;
ИначеЕсли ФорматВозрата="Структура" Тогда
    СписокЭлементовМетаданных = Новый Структура();
    Для Каждого ЭлементМетаданных Из Метаданные[МетаданныеГруппа] Цикл
    СписокЭлементовМетаданных.Вставить(ЭлементМетаданных.Имя,ЭлементМетаданных.Синоним);
    КонецЦикла;
    Возврат СписокЭлементовМетаданных;    
Иначе
    Возврат Неопределено;    
КонецЕсли;
КонецФункции

Данная функция выводит список элементов метаданных по указанной в функции группе.
И как понимается тут все легко и просто.
Нужно то же самое, только для форм.
Т.е. таким же маккаром получить его в виде структуры или списка значений.
Если 1С позволяет это то просьба скинуть готовую функцию в примерно подобном стиле. Если конечно не трудно.
Буду признателен!
Просмотров: 441, последний комментарий от Gigi   
Серии в НЗП - при переработке (ошибка расчета себестоимости) [раздел 1С Управление производственным предприятием 8]
Автор VXIIIZ — 15.10.19, 10:51 — 9 комментариев
Подскажите, господа, вдруг кто-то сталкивался.
Платформа: 8.3.13.1809
Конфа: 1.3.64.1

Детализация затрат - детально
Расчет себестоимости - по переделам.

Передел 1:
Из сырья1 делаем полуфабрикат1 (ПФ1)

Передел 2.
Передачей товаров передаем в переработку
поступлением из переработки - распределение материалов фиксируем затраты на выпуск этого ПФ. и собственно регистрируем выпуск ГП1
получением услуг по переработке добавляем услугу и собственно списываем в НЗП с партий переданных в переработку ПФ1

Все просто, себестоимость расчитывается, 231-й закрывается. Ровно до тех пор пока мы не устанавливаем учет по сериям.




При передаче товаров серию можно указать с партий она списывается корректно


Но в партиях переданных серии нет.

Затратах на выпуск продукции серия есть и она заполняется
Но в получении услуг по переработке серии нет


Соответственно в незавершенку это ПФ попадает без серии

И как результат:
Просмотров: 145, последний комментарий от VXIIIZ   
Позволяет ли 1С программно вставить кнопку в панель инструментов [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 15.10.19, 10:10 — 6 комментариев
Всем опять привет!
Искал инфу по указанному вопросу в сети, но че-те не нашел ответ на данный вопрос.
Поэтому никто не может дать точный ответ на вопрос.
Можно ли в 1С программно добавить кнопку не просто в командную панель любой формы, а в саму панель инструментов 1С предприятия.
И по первому вопросу, т.е. по вопросу добавления кнопки в командную панель знаю что можно. Равно как и знаю не только то что в глобальном смысле добавить то можно, а еще и то что, скрыть в том же самом глобальном смысле , что самое смешное, никак нельзя smile.gif. Хоть лопни smile.gif
Поэтому хотел уточнить так ли дело обстоит по вопросу уже панели инструментов или еще хуже?
Ибо судя по тому, что в сети по вопросу не нахожу инфу, догадываюсь что и тут нельзя это сделать. Но хотел уточнить и получить точный ответ на данный вопрос.
Буду признателен!

Gigi @ Сегодня, 9:55 * ,
Вот инфа близкая к заданному вопросу. Но это где то рядом, но все равно не то что надо.
Просмотров: 154, последний комментарий от Gigi   
Как вернуть выбранное значение из формы списка Справочника в вызвавшую форму элемента другого справочника ? [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор andrew76 — 14.10.19, 16:51 — 3 комментариев
Добрый вечер !

Имеется форма элемента справочника.На нажатию кнопки,расположенной на этой форме,запускается форма
списка другого справочника.На это форме по двойному клику или нажатию клавиши Enter обрабатываю событие
Выбор.Мне нужно передать значение реквизита Наименование (выбранный элемент по клику или Enter'у)
в реквизит Наименование вызвавшей формы первого справочника.Как это реализовать ?
Т.е. я должен заменить значение реквизита Наименование выбранным значением из другого справочника.
Просмотров: 137, последний комментарий от getnight   
Обучение по программированию 1С 8.3. Создание внешнего отчета "Отчет по продажам". [раздел Обучающее видео]
Автор macho210386 — 13.10.19, 18:15 — 0 комментариев


Описание:
Как создать внешний отчет. - создание внешнего отчета "Отчет по продажам". Описание механизма СКД. Встраивание внешнего отчетам в конфигурацию "Бухгалтерия для Украины ред. 2.0".
Просмотров: 60, оставить комментарий   
Помогите создать внешнею печатную форму [раздел Программирование в 1С Предприятие 8.3]
Автор Laky2006 — 12.10.19, 23:17 — 3 комментариев
Здравствуйте я только начинаю знакомиться с 1с8,3 есть такая конфигурация

Платформа: 1С:Предприятие 8.3 (8.3.15.1656)
Конфигурация: Управление небольшой фирмой для Украины (базовая), редакция 1.6 (1.6.10.1) (http://1c.ua/v8/RegionalSolutions_UA_UNF.php)

Хочу вставить внешнею печатную форму но остановился на ошибке вывода наименования товара который сдается в ремонт в друменте ПриемПередача в ремонт.
В "Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати)" хочу вывести на печать и указываю
ОбластьШапка.Параметры.Товар = СсылкаНаДокумент.Номенклатура;

при попытке печати выдает ошибку "В обработчике печати не был сформирован табличный документ для : заказвнешний"

подскажите как правильно прописать Номенклатуру?

Мой код
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;
МассивНазначений.Добавить("Документ.ПриемИПередачаВРемонт"); //Указываем документ к которому делаем внешнюю печ. форму
ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "Заказ реализации товаров внешний"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Версия", "1.0");
ПараметрыРегистрации.Вставить("Информация", "Эту ВПФ мы сделали для того что бы посмотреть возможности БСП ");
ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, "Заказ внешний", "заказвнешний", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции


Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление;
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры



Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "заказвнешний", "Заказ внешний", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));

КонецПроцедуры // Печать()

  
  
Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати)

ТабличныйДокумент = Новый ТабличныйДокумент;
МакетОбработки = ПолучитьМакет("МакетЗаказ");

//заполняем шапку
ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.НомерРеализации = СсылкаНаДокумент.Номер;
ОбластьШапка.Параметры.ДатаРеализации = Формат(СсылкаНаДокумент.Дата, "Л=uk_UA; ДЛФ=D");
ОбластьШапка.Параметры.Товар = СсылкаНаДокумент.Номенклатура;

//выводим шапку в табличный документ
ТабличныйДокумент.Вывести(ОбластьШапка);


КонецФункции
Просмотров: 126, последний комментарий от Vofka   
Вітаємо з Днем Захисника України! [раздел http://pro1c.org.ua/]
Автор Лёша Гончарук — 11.10.19, 12:50 — 0 комментариев
Щиро вітаємо з Днем Захисника України!

Це справжнє свято мужності й сили духу, свято захисту і гідності – усіх тих якостей, що властиві лише справжнім боронителям і захисникам України, в тилу і на передовій.

Тож нехай у вас завжди вистачає наснаги, міцності духу та віри у наше спільне світле майбутнє.

Бажаємо вам здоров’я, успіхів, добробуту та завжди мирного неба!

Просмотров: 71, оставить комментарий   
Выбрать новый товар, который только добавили в базу [раздел Программирование в 1С Предприятие 8.3]
Автор Tseka — 10.10.19, 15:22 — 13 комментариев
1С:Предприятие 8.3 (8.3.8.2027)

"Управление торговлей для Украины", редакция 2.3.


Запросом пытаюсь выбрать только новый товар , который только добавили в базу , делаю это через "установку цен номенклатуры" .

Как в выборки оставить только товар с Регистратором "Поступление товаров и услуг" ?

ВЫБРАТЬ
    ЦеныНоменклатуры.Период,
    ЦеныНоменклатуры.Номенклатура.Наименование КАК НоменклатураНаименование,
    ЦеныНоменклатуры.Регистратор
ИЗ
    РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры


СГРУППИРОВАТЬ ПО
    ЦеныНоменклатуры.Период,
    ЦеныНоменклатуры.Номенклатура.Наименование,
    ЦеныНоменклатуры.Регистратор

ИМЕЮЩИЕ
    МИНИМУМ(ЦеныНоменклатуры.Период) > &ДатаМесяцНазад

УПОРЯДОЧИТЬ ПО
    НоменклатураНаименование



 ! 

Правила: 4, 5
 
Просмотров: 247, последний комментарий от Tseka   
Выгрузка Акта сверки в Медок, ошибка при вызове метода контекста (Edit) [раздел Программирование в 1С Предприятие 8.3]
Автор Мичман Харитонов — 10.10.19, 11:30 — 1 комментариев
Платформа 8.3.7,
Конфигурация самописная.
Переделываю на основе выгрузки для налоговых документов...

Код
Процедура ВыполнитьПередачуНакладных(Результат, ЭлементыФормы) Экспорт
    Попытка
        App = Новый COMОбъект("MEDOC.ZApplication");
    Исключение
        Сообщить("Приложение M.E.DOC не запущено!");
        Возврат;
    КонецПопытки;
    СведенияОПоставщике  =  УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Организация,  ТекущаяДата());
    КодПоЕДРПОУ  =  СокрЛП(СведенияОПоставщике.КодПоЕДРПОУ);
    ЭлементыФормы.Состояние.Заголовок = "Осуществляется передача Актов Сверки...";
    Передано = 0;
    Для каждого Стр Из Результат Цикл
        Если Стр.Передавать = Ложь Тогда
            Продолжить;
        КонецЕсли;
        
        PDate = Дата(Год(Стр.Ссылка.Дата), Месяц(Стр.Ссылка.Дата), День(Стр.Ссылка.Дата));
        
        
        ИД = Строка(Стр.Ссылка.УникальныйИдентификатор());
                
         Бланк = "1C82A3";  
         Формирование_АктаСверки(App,  Стр.Ссылка,  Бланк,  PDate,  ИД)
        
    КонецЦикла;
    App.RefreshRstDoc();
    ЭлементыФормы.Состояние.Заголовок = "Передача Актов сверки завершена успешно.";
    Сообщить("Передано " + Передано + " документ(ов) ");
    
КонецПроцедуры

Функция Формирование_АктаСверки(App,  Документ,  Бланк,  PDate,  ИД)
Doc  =  App.OpenOrCreateByExDocID(Бланк, 0, PDate,  , ИД, 0);
rsMain = Doc.DataSets("MAIN");
            //rsMain = Doc.DataSets();
            rsMain.Edit();
....


На rsMain.Edit(); спотыкается, выдает ошибку
Просмотров: 102, последний комментарий от Petre   
RSS Текстовая версия Сейчас: 21.10.19, 12:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!