Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Звернення з форми до довідника , Потрібна допомога в синтаксисі.          
l2d808 Подменю пользователя
сообщение 23.05.18, 15:32
Сообщение #1

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 241
Из: Советский Союз
Спасибо сказали: 59 раз
Рейтинг: 70.4

Доброго дня, шановні добродії.
Я використовую 1с8,3 конфа самописна.
Розпочинаю вивчення 1с,8,3 й одразу стикнувся з ситуацією.
Є довідник "МодельТранспортногоЗасобу" в нього є реквізит "ТипТранспортногоЗасобу" також є довідник "ТранспортнийЗасіб" у якому є реквізит "ТипТранспортногоЗасобу" та "МодельТранспортногоЗасобу" . На формі довідника "ТранспортнийЗасіб" при виборі елементу "МодельТранспортногоЗасобу" реквізиту "ТипТранспортногоЗасобу" необхідно присвоїти значення реквізиту "ТранспортнийЗасіб" довідника "МодельТранспортногоЗасобу".
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
    ТранспортнийЗасіб.ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

Щось на кшталт цього.
Допоможіть порадою або кодом.


Signature
Короеды это не жуки. Это пользователи. Они едят кору головного мозга ...

Vidocq05 Подменю пользователя
сообщение 23.05.18, 15:57
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 169
Из: Сумы
Спасибо сказали: 25 раз
Рейтинг: 25

l2d808 @ Сегодня, 16:32 * ,
Для обычных форм так:
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
    ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

l2d808 Подменю пользователя
сообщение 23.05.18, 16:04
Сообщение #3

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 241
Из: Советский Союз
Спасибо сказали: 59 раз
Рейтинг: 70.4

Vidocq05 @ Сегодня, 16:57 * ,
Видеє помилку:
{Справочник.ТранспортнийЗасіб.Форма.ФормаЭлемента.Форма(7,25)}: Переменная не определена (МодельТранспортногоЗасобу)
ТипТранспортногоЗасобу=<<?>>МодельТранспортногоЗасобу.ТипТранспортногоЗасобу; (Проверка: Тонкий клиент)


Signature
Короеды это не жуки. Это пользователи. Они едят кору головного мозга ...

Vidocq05 Подменю пользователя
сообщение 23.05.18, 16:18
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 169
Из: Сумы
Спасибо сказали: 25 раз
Рейтинг: 25

l2d808 @ Сегодня, 17:04 * ,
Похоже у Вас управляемые формы. Я в них не очень силен. Попробуйте так:
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
    Объект.ТипТранспортногоЗасобу=Объект.МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

Flexy Подменю пользователя
сообщение 23.05.18, 16:20
Сообщение #5

Танцор с Бубном
Иконка группы
Группа: Местный
Сообщений: 1121
Из: Днепра
Спасибо сказали: 219 раз
Рейтинг: 158

&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
ТранспортнийЗасіб.ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

&НаКлиенте
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
МодельТранспортногоЗасобуПриИзмененииСервер();
КонецПроцедуры


Для получения ".ТипТранспортногоЗасобу" нужно сервер вызывать. На клиенте нет этих данных.

Сообщение отредактировал Flexy - 23.05.18, 16:22

Спасибо сказали: l2d808,

Vidocq05 Подменю пользователя
сообщение 23.05.18, 16:33
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 169
Из: Сумы
Спасибо сказали: 25 раз
Рейтинг: 25

Цитата(Flexy @ 23.05.18, 17:20) *
&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
ТранспортнийЗасіб.ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

Тогда наверное так:
&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
    ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

l2d808 Подменю пользователя
сообщение 23.05.18, 16:33
Сообщение #7

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 241
Из: Советский Союз
Спасибо сказали: 59 раз
Рейтинг: 70.4

Flexy @ Сегодня, 17:20 * ,
Знову помилка...
{Справочник.ТранспортнийЗасіб.Форма.ФормаЭлемента.Форма(11,2)}: Переменная не определена (ТранспортнийЗасіб)
<<?>>ТранспортнийЗасіб.ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу; (Проверка: Сервер)
{Справочник.ТранспортнийЗасіб.Форма.ФормаЭлемента.Форма(11,43)}: Переменная не определена (МодельТранспортногоЗасобу)
ТранспортнийЗасіб.ТипТранспортногоЗасобу=<<?>>МодельТранспортногоЗасобу.ТипТранспортногоЗасобу; (Проверка: Сервер)


Signature
Короеды это не жуки. Это пользователи. Они едят кору головного мозга ...

Vofka Подменю пользователя
сообщение 23.05.18, 16:37
Сообщение #8

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12750
Из: Киев
Спасибо сказали: 3840 раз
Рейтинг: 2962.7

l2d808, при создании темы вам высвечивалось окошко, в котором вы нажали кнопку "Мною прочитано и осознано". Врать не хорошо.

&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
   Объект.ТранспортнийЗасіб.ТипТранспортногоЗасобу = Объект.МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры


Signature
Услуги 1С программиста

l2d808 Подменю пользователя
сообщение 23.05.18, 16:39
Сообщение #9

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 241
Из: Советский Союз
Спасибо сказали: 59 раз
Рейтинг: 70.4

У мене вийшло таким чином:
&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
объект.ТипТранспортногоЗасобу=объект.МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

&НаКлиенте
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
МодельТранспортногоЗасобуПриИзмененииСервер();
КонецПроцедуры

Все запрацювало...
Вельми дякую за допомогу!


Signature
Короеды это не жуки. Это пользователи. Они едят кору головного мозга ...

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 17.11.18, 17:40
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне