Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Заполнение поля из свойства другого объекта , 1С 8.3 УПП          
jojojoba2 Подменю пользователя
сообщение 16.05.19, 12:44
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 16
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день!

Помогите начинающему разработчику 1С. Есть документ Перемещение ОС. В нем нужно добавить поле с вожможностью вода данных ,на ком или какому складе(МОЛ) принадлежит ОС(Тоесть чтобы было поле "Тот кто здал" и "Тот кто принял". При создании нового документа Перемещение ОС, при добавлении Основного средства необходимо чтобы данные на ком(на каком складе) оно числится добавлялись в созданное поле автоматически.

Подскажите метод или пример кода автоматического заполнения. Я Пытаюсь через обработку формы при изменении документа "Перемещение ОС"
подставить в новое поле (созданное мною "на ком числиться") данные из документа "Основные Средства" вкладка "бух учет" из поля "МОЛБУ",но это не реквизит , а переменная в Процедура ЗаполнитьОписания() формы элемента. Как сделать ссылку на конкретный элемент формы другого документа.

Процедура ОСОсновноеСредствоПриИзменении(Элемент)
    
СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.м =Справочники.ОсновныеСредства.ФормаЭлемента. ???????????

КонецПроцедуры


Направте на путь истинный.

Спасибо.


 ! 

Правила: 4, 9
 


Сообщение отредактировал Vofka - 16.05.19, 15:01

Acid Подменю пользователя
сообщение 16.05.19, 13:11
Сообщение #2

Про1С-ник
Иконка группы
За заслуги на форуме в 2010 году
Группа: Местный
Сообщений: 2081
Из: Занзибар
Спасибо сказали: 357 раз
Рейтинг: 236.7

Цитата(jojojoba2 @ 16.05.19, 13:44) *
Направте на путь истинный.

Почитайте для начала методику как выполняются подобные операции в УПП.


Signature

Документируйте Код! мать вашу...

* Хочу работать не далеко от моря http://www.severniykipr.ru/

jojojoba2 Подменю пользователя
сообщение 16.05.19, 14:32
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 16
Спасибо сказали: 0 раз
Рейтинг: 0

Acid @ Сегодня, 14:11 * ,

Подскажите пожалуйста книгу

Vofka Подменю пользователя
сообщение 16.05.19, 15:03
Сообщение #4

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12984
Из: Киев
Спасибо сказали: 3942 раз
Рейтинг: 3073.3

jojojoba2, у вас есть табличная часть, в которой вы выбираете основное средство и в этой строке вам надо заполнить колонку значением из выбранного основного средства?


Signature
Услуги 1С программиста

Acid Подменю пользователя
сообщение 16.05.19, 15:05
Сообщение #5

Про1С-ник
Иконка группы
За заслуги на форуме в 2010 году
Группа: Местный
Сообщений: 2081
Из: Занзибар
Спасибо сказали: 357 раз
Рейтинг: 236.7

jojojoba2 @ Сегодня, 15:32 * ,
[необходимо зарегистрироваться для просмотра ссылки]

[необходимо зарегистрироваться для просмотра ссылки]

Vofka Подменю пользователя
сообщение 16.05.19, 15:16
Сообщение #6

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12984
Из: Киев
Спасибо сказали: 3942 раз
Рейтинг: 3073.3

Acid, если вопрос по программированию, причем тут литература по УПП?


Signature
Услуги 1С программиста

jojojoba2 Подменю пользователя
сообщение 16.05.19, 15:50
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 16
Спасибо сказали: 0 раз
Рейтинг: 0

Vofka @ Сегодня, 16:03 * ,

Да, нужно подставить в созданное поле на ком числится основное средство. Как подтянуть данные из регистра.Я пробую запросом но данные не вставляются:

Функция ПолучитьДанныеИзРС(ОС)

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ОС",ОС);
Запрос.Текст =  "ВЫБРАТЬ
              
               |    МестонахождениеОС.МОЛ
               |ИЗ
               |    РегистрСведений.МестонахождениеОС КАК МестонахождениеОС ";
              
              
               // получение данных по конкретному ОС

Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();



КонецФункции



Процедура ОСОсновноеСредствоПриИзменении(Элемент)
    
СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.М = ПолучитьДанныеИзРС(СтрокаТабличнойЧасти.ОС);


КонецПроцедуры


jojojoba2 @ Сегодня, 16:36 * ,
Написал код, вставляет значение в мое созданное поле но значение одно и тоже для всех основных средств


 ! 

Правила: 9
 


Сообщение отредактировал Vofka - 17.05.19, 11:48

Acid Подменю пользователя
сообщение 16.05.19, 16:04
Сообщение #8

Про1С-ник
Иконка группы
За заслуги на форуме в 2010 году
Группа: Местный
Сообщений: 2081
Из: Занзибар
Спасибо сказали: 357 раз
Рейтинг: 236.7

Цитата(Vofka @ 16.05.19, 16:16) *
если вопрос по программированию, причем тут литература по УПП?


Потому что я вижу, что хотят выполнить хотелку бухгалтера. В итоге сломают стандартный документ. Просто предупреждаю назревающий конфликт.
В УПП вся необходимая информация присутствует - у склада есть и ответсвенное лицо и местонахождение. И в ведомости ОС можно вывести всю необходимую информацию.

fly Подменю пользователя
сообщение 17.05.19, 8:55
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 11
Спасибо сказали: 2 раз
Рейтинг: 1

jojojoba2 @ Вчера, 16:50 * ,

Функция ПолучитьДанныеИзРС(ОС)
.....
.....
КонецФункции


Потеряли:
Возврат <Возвращаемое значение>
Ключевое слово, которое завершает выполнение функции и возвращает указанное значение в выражение, в котором используется функция.
В качестве возвращаемого значения может выступать выражение или переменная, значение которого содержит результат обращения к функции.

Возврат <Возвращаемое значение> = 1но значение

Запрос ваш может выдавать множественное значение (может быть > 1).
переделайте запрос на "срез последних".
Запрос условие = ОС???? - "....ГДЕ......" -

Но это плохое решение, так как при изменении ОС, постоянно будет меняться МОЛ. Ответственный - последнее значение по строкам документа может быть различным.
Рискуете получить 2а ответственных "Сдал" - фактически, а подписывает документ один Сдающий.

Vofka Подменю пользователя
сообщение 17.05.19, 11:50
Сообщение #10

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12984
Из: Киев
Спасибо сказали: 3942 раз
Рейтинг: 3073.3

Цитата(Acid @ 16.05.19, 17:04) *
Потому что я вижу, что хотят выполнить хотелку бухгалтера. В итоге сломают стандартный документ. Просто предупреждаю назревающий конфликт.
В УПП вся необходимая информация присутствует - у склада есть и ответсвенное лицо и местонахождение. И в ведомости ОС можно вывести всю необходимую информацию.

В таком случае дайте конкретный ответ почему так делать не надо, вместо абстрактного "читайте книги".


Signature
Услуги 1С программиста

jojojoba2 Подменю пользователя
сообщение 17.05.19, 13:28
Сообщение #11

Общительный
**
Группа: Пользователи
Сообщений: 16
Спасибо сказали: 0 раз
Рейтинг: 0

Всем спасибо!
Вставляю рабочий код, может кому то пригодиться

Функция ПолучитьДанныеИзРС(ОС) 

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ОС",ОС);
Запрос.УстановитьПараметр("Дата",Дата);
Запрос.Текст = "ВЫБРАТЬ
|    МестонахождениеОСБухгалтерскийУчет.МОЛ
|ИЗ
| РегистрСведений.МестонахождениеОСБухгалтерскийУчет.СрезПоследних(&Дата,ОсновноеСредство = &ОС) КАК МестонахождениеОСБухгалтерскийУчет";

// получение данных по конкретному ОС

Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();

Возврат Выборка.МОЛ;

КонецФункции

Процедура ОСОсновноеСредствоПриИзменении(Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.М = ПолучитьДанныеИзРС(СтрокаТабличнойЧасти.ОсновноеСредство);

КонецПроцедуры


Сообщение отредактировал Vofka - 17.05.19, 14:24

Vofka Подменю пользователя
сообщение 17.05.19, 14:25
Сообщение #12

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12984
Из: Киев
Спасибо сказали: 3942 раз
Рейтинг: 3073.3

jojojoba2, обратите внимание все таки на 9 пункт правил. И для спасибо у нас специальная кнопочка есть wink.gif.


Signature
Услуги 1С программиста

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 24.06.19, 19:57
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне