Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Залипла дата в документах          
kot488 Подменю пользователя
сообщение 25.04.17, 12:54
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Спасибо сказали: 0 раз
Рейтинг: 0

Есть в самописной базе документ. В нем есть кнопка заполнить с помощью которой в него заполняются все определенные документы указанного типа. На скрине документ правильный, с правильными датами. Но дата в заголовке почему то 03.04.2017


Это под моей учетной записью.
А у некоторых пользователей, в этом документе отображается дата что документы созданы 03.04


Хотя если зайти в сам документ то в нем правильная дата, 23.04. И даже документы от 31.03 пользователю показывает как 03.04

Что за глюк? Кеш почистил


и все новые документы тоже создаются с датой 03.04

sava1 Подменю пользователя
сообщение 25.04.17, 13:07
Сообщение #2

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1440
Из: Проскуров
Спасибо сказали: 340 раз
Рейтинг: 337.3

В Параметрах как Дата используется ?

kot488 Подменю пользователя
сообщение 25.04.17, 13:10
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:07 * ,
В параметрах текущая дата компьютера. Если заходить через конфигуратор то все ок

sava1 Подменю пользователя
сообщение 25.04.17, 13:13
Сообщение #4

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1440
Из: Проскуров
Спасибо сказали: 340 раз
Рейтинг: 337.3

В табло ТекущаяДата, РабочаяДата что выводит ?

kot488 Подменю пользователя
сообщение 25.04.17, 13:27
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:13 * ,


Где это можно посмотреть? не могу найти(

sava1 Подменю пользователя
сообщение 25.04.17, 13:30
Сообщение #6

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1440
Из: Проскуров
Спасибо сказали: 340 раз
Рейтинг: 337.3

сервис- Табло
В Выражение пишем - ТекущаяДата() и аналогично РабочаяДата

kot488 Подменю пользователя
сообщение 25.04.17, 13:35
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:30 * ,

Я правильно смотрю?


sava1 Подменю пользователя
сообщение 25.04.17, 13:40
Сообщение #8

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1440
Из: Проскуров
Спасибо сказали: 340 раз
Рейтинг: 337.3

Я не вижу картинок

kot488 Подменю пользователя
сообщение 25.04.17, 13:45
Сообщение #9

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:40 * ,
savepic глючит(

ТекущаяДата() 25.04.2017 14:43:35
РабочаяДата() {(1,1)}: Процедура или функция с указанным именем не определена (РабочаяДата)
РабочаяДата 25.04.2017 0:00:00

Если зайти в конфигуратор и запустить отладку, и открыть документ то даты правильные.
Если зайти в базу не через отладку то дата 03.04

sava1 Подменю пользователя
сообщение 25.04.17, 13:54
Сообщение #10

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1440
Из: Проскуров
Спасибо сказали: 340 раз
Рейтинг: 337.3

Тады надо отладчиком смотреть, где меняется.

kot488 Подменю пользователя
сообщение 25.04.17, 14:39
Сообщение #11

Завсегдатай
****
Группа: Пользователи
Сообщений: 152
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:54 * ,

Там и кода особо нет при открытии

&НаКлиенте
Процедура УстановитьПараметрыОтбораПользователя()        
    
    ЭлементыОтбора = Список.Отбор.Элементы;        
    ЭлементыОтбора.Очистить();                            
    
    Если Не ОтборОрганизация.Пустая() Тогда        
                
        ЭлементОтбораОрганизация = ЭлементыОтбора.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        
        ЭлементОтбораОрганизация.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Организация");
        ЭлементОтбораОрганизация.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
        ЭлементОтбораОрганизация.Использование = Истина;
        ЭлементОтбораОрганизация.ПравоеЗначение = ОтборОрганизация;
    
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ОрганизацияФильтрПриИзменении(Элемент)
    
    УстановитьПараметрыОтбораПользователя();
    
КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ОтборОрганизация = Пользователи.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "ОсновнаяОрганизация");    
    
КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    УстановитьПараметрыОтбораПользователя();    
    
КонецПроцедуры


Помог ребут службы sql

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 28.06.17, 7:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне