Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 11, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Як правильно завантажити номенклатуру з табл.документа?          
zhezabel Подменю пользователя
сообщение 16.08.18, 15:35
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

1с8 УТ ред.2.3
Виникає проблема при завантаженні номенклатури через файл ЗагрузкаДаныхИзТабличногоДокумента в частині одиниць вимірювання. "Базова" завантажується, "для отчетов" і "хранения остатков" не виходить. Підкажіть, будь ласка, як правильно це зробити?

Zaval Подменю пользователя
сообщение 16.08.18, 20:15
Сообщение #2

Крутой
Иконка группы
Группа: Местный
Сообщений: 1993
Из: Киева и окрестностей
Спасибо сказали: 403 раз
Рейтинг: 256.9

Цитата(zhezabel @ 16.08.18, 16:35) *
"для отчетов" і "хранения остатков" не виходить.

Що саме?

zhezabel Подменю пользователя
сообщение 17.08.18, 8:43
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Коли відкриваю Елемент номенклатури, то базова одиниця є, а "для отчетов" і "хранения остатков" червоне підкреслення і немає можливості вибрати(список пустий).

nik389 Подменю пользователя
сообщение 17.08.18, 9:14
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 48
Из: Украина
Спасибо сказали: 14 раз
Рейтинг: 11

так а вы обработку подправьте. там пару строк дописать..

zhezabel Подменю пользователя
сообщение 17.08.18, 9:50
Сообщение #5

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

З 1с8 тільки починаю співпрацю) Підкажіть, будь ласка, що і куди дописати?

nik389 Подменю пользователя
сообщение 17.08.18, 10:37
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 48
Из: Украина
Спасибо сказали: 14 раз
Рейтинг: 11

вот готовый кусок кода:
Процедура СоздатьЕдиницуХраненияОстатков(Номенклатура)

    Если ЗначениеЗаполнено(Номенклатура.ЕдиницаХраненияОстатков) Тогда
        Возврат;
    КонецЕсли;

    ВыборкаЕдиниц = Справочники.ЕдиницыИзмерения.Выбрать(, Номенклатура.Ссылка);
    Если ВыборкаЕдиниц.Следующий() Тогда
        НайденнаяЕдиница = ВыборкаЕдиниц.Ссылка;
    Иначе
        НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
        НайденнаяЕдиницаОбъект.Наименование            = СокрЛП(Номенклатура.БазоваяЕдиницаИзмерения);
        НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = Номенклатура.БазоваяЕдиницаИзмерения;
        НайденнаяЕдиницаОбъект.Коэффициент             = 1;
        НайденнаяЕдиницаОбъект.Владелец                = Номенклатура.Ссылка;

        Попытка
            НайденнаяЕдиницаОбъект.Записать();
        Исключение
            Сообщить("Не удалось записать единицу хранения остатков: " + ОписаниеОшибки(), СтатусСообщения.Важное);            
            Возврат;
        КонецПопытки;

        НайденнаяЕдиница = НайденнаяЕдиницаОбъект.Ссылка;
    КонецЕсли;

    Номенклатура.ЕдиницаХраненияОстатков = НайденнаяЕдиница;
    Номенклатура.ЕдиницаДляОтчетов = НайденнаяЕдиница;

КонецПроцедуры // ПроверитьЕдиницуХраненияОстатков()


куда дописать, думаю сами разберетесь..

zhezabel Подменю пользователя
сообщение 17.08.18, 16:20
Сообщение #7

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

не розібралась(

zhezabel Подменю пользователя
сообщение 21.08.18, 13:23
Сообщение #8

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Професіонали 1с, скажіть, будь ласка, куди вставити цей код, щоб все нормально завантажувалось?

sanek6662009@gma... Подменю пользователя
сообщение 27.08.18, 18:41
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 46
Из: Днепр
Спасибо сказали: 3 раз
Рейтинг: 3

zhezabel @ 21.08.18, 14:23 * ,
в обработку)

Егор Динин Подменю пользователя
сообщение 27.08.18, 19:33
Сообщение #10

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1408
Из: Киев
Спасибо сказали: 517 раз
Рейтинг: 355.7

http://pro1c.org.ua/topic/zagruzka-dannyh-...ost&p=54899

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.10.18, 14:55
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне