Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 9
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Вывод на макет картинки , 1С:Предприятие 8.3 (8.3.11.3034) , УНФ 1.6 (1.6.6.1)          
And1001 Подменю пользователя
сообщение 05.10.18, 9:40
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте уважаемые программисты. Просьба помочь с выводом на макет картинки. Пример кода :
&НаСервере
Функция СформироватьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    НоменклатураПрисоединенныеФайлы.ВладелецФайла.Ссылка КАК ВладелецФайлаСсылка,
    |    Номенклатура.ФайлКартинки КАК ФайлКартинки,
    |    Номенклатура.Ссылка КАК Ссылка
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
    |        ПО Номенклатура.ФайлКартинки = НоменклатураПрисоединенныеФайлы.Ссылка";    
    ТабИтог = Запрос.Выполнить().Выбрать();
    ТабДок = Новый ТабличныйДокумент;
    Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет");  
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Шапка);
    Рез=Макет.ПолучитьОбласть("Результат");
    Пока ТабИтог.Следующий() Цикл
        Рез.Параметры.НаимНоменклатуры = ТабИтог.ВладелецФайлаСсылка.Наименование;
        ДанныеКартинки = УправлениеНебольшойФирмойСервер.ПолучитьДвоичныеДанныеФайла(ТабИтог.ФайлКартинки);
        Если ЗначениеЗаполнено(ДанныеКартинки) Тогда
            Рез.Параметры.Картинка = Новый Картинка(ДанныеКартинки);
        КонецЕсли;            
        ТабДок.Вывести(Рез);
    КонецЦикла;
    возврат  ТабДок;
КонецФункции

В итоге выводится слово "картинка". Другие методы, описанные в интернете мне не помогли.

sanek6662009@gma... Подменю пользователя
сообщение 05.10.18, 20:29
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 45
Из: Днепр
Спасибо сказали: 3 раз
Рейтинг: 3

And1001 @ Сегодня, 10:40 * ,
[необходимо зарегистрироваться для просмотра ссылки]

And1001 Подменю пользователя
сообщение 08.10.18, 12:55
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Разобрался. В параметр нельзя передавать изображение. Изображение передается в объект рисунок ( на макете Таблица => Рисунки => Картинка). Затем передавать в этот объект полученные из двоичных данных нашу картинку.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 16.10.18, 8:37
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне