Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> ВыбранныйЭлемент = ФормаВыбора.Открыть() - почему не работает?          
Gigi Подменю пользователя
сообщение 01.03.18, 14:17
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 267
Спасибо сказали: 3 раз
Рейтинг: 0

Всем привет!
Хочу задать вопрос по быстрому и получить тоже так же ...
Никто не подскажет почему указанный ниже фрагмент не работает.
Дело в том, нужно выбрать значение в форме выбора программно. Но при этом что бы открытие формы выбора было не модально. Потому что раздражает то что в таком режиме у окна нет режима свернуть и развернуть окно, а есть только крестик - выйти.
Вот фрагмент
ФормаВыбора=ПолучитьФорму("Справочник.Справочник1.ФормаВыбора",,ЭтаФорма);
ОбъектСсылка = ФормаВыбора.ОткрытьМодально(); // Так проходить без проблем
//ОбъектСсылка = ФормаВыбора.Открыть();  // А так выпердриваеться ... НИКАК НЕ ХОЧЕТ ....
Если ОбъектСсылка <> Неопределено Тогда
ФормаОбъектаСсылки = ПолучитьФорму("Справочник.Справочник1.ФормаОбъекта", новый Структура("Ключ", ОбъектСсылка));
Предупреждение(ФормаОбъектаСсылки.Объект.Наименование);
КонецЕсли;

Короче нужно то что указано в коде, только что бы форма выбора открывалась Не модально, а как обычно.
Если можно просто подкорректируйте под эту цель.
Буду признателен!

podcast Подменю пользователя
сообщение 01.03.18, 14:46
Сообщение #2

Оратор
*****
Группа: Пользователи
Сообщений: 272
Спасибо сказали: 64 раз
Рейтинг: 61.3

Gigi @ Сегодня, 14:17 * ,
Попробуйте указывать владельца правильно.
ОткрытьФорму("Справочник.Справочник1.ФормаВыбора",,ОбъектСсылка);
Если ОбъектСсылка <> Неопределено Тогда
ФормаОбъектаСсылки = ПолучитьФорму("Справочник.Справочник1.ФормаОбъекта", новый Структура("Ключ", ОбъектСсылка));
Предупреждение(ФормаОбъектаСсылки.Объект.Наименование);
КонецЕсли;

Fynjy Подменю пользователя
сообщение 01.03.18, 15:50
Сообщение #3

Сенсей Чака Норриса
**********
За вредность
Группа: Пользователи
Сообщений: 1982
Из: Ахметов сити
Спасибо сказали: 330 раз
Рейтинг: 161.3

Зачем такие извраты?
ОткрытьЗначение(ОбъектСсылка)


Signature

Gigi Подменю пользователя
сообщение 01.03.18, 16:07
Сообщение #4

Оратор
*****
Группа: Пользователи
Сообщений: 267
Спасибо сказали: 3 раз
Рейтинг: 0

Цитата(podcast @ 01.03.18, 14:46) *
Попробуйте указывать владельца правильно.

Цитата(Fynjy @ 01.03.18, 15:50) *
Зачем такие извраты?

Ну ладно ... но в таком случае как определить выбранное из списка формы выбора значение?
Ведь по такой схеме:
ОбъектСсылка = ФормаВыбора.ОткрытьМодально();

"ОбъектСсылка" это выбранное из списка значение. Что и устраивает... просто нужно не модальное открытие.
А таким образом:
ОткрытьФорму("Справочник.Справочник1.ФормаВыбора",,ОбъектСсылка);
Если ОбъектСсылка <> Неопределено Тогда .....

или таким
ОткрытьЗначение(ОбъектСсылка)

Как получить то самое значение переменной "ОбъектСсылка"?
Форму то открыть можно, а выбранное значение как получить?
как в таком сказанном уже стиле:
ОбъектСсылка = ФормаВыбора.ОткрытьМодально();

Просто без модального режима открытия

Petre Подменю пользователя
сообщение 01.03.18, 16:56
Сообщение #5

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2371
Из: Київ, Україна
Спасибо сказали: 582 раз
Рейтинг: 541.8

Gigi @ Today, 16:07 * ,
Из кода вообще не понятно, что вы хотите сделать (после того, как выбрали значение).
Разница между методами ОткрытьМодально и Открыть в том, что последний ничего не возвращает.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Gigi Подменю пользователя
сообщение 01.03.18, 17:07
Сообщение #6

Оратор
*****
Группа: Пользователи
Сообщений: 267
Спасибо сказали: 3 раз
Рейтинг: 0

Цитата(Petre @ 01.03.18, 16:56) *
Из кода вообще не понятно, что вы хотите сделать (после того, как выбрали значение).
Разница между методами ОткрытьМодально и Открыть в том, что последний ничего не возвращает.

Не важно что хочу... главное ОТКРЫТЬ ФОРМУ ВЫБОРА НЕ МОДАЛЬНО и ПОЛУЧИТЬ ССЫЛКУ ВЫБРАННОГО ОБЪЕКТА.
Вот и все что нужно!
Но в том то и все дело, что команда ОткрытьМодально() это функция. Очень удобная.
С ее помощью можно одним махом открыть форму выбора и запеременить ссылку выбранного объекта.
Просто САМОЕ ОТКРЫТИЕ НУЖНО НЕ МОДАЛЬНОЕ! Вот и все.
А команда Открыть() позволяет открыть не модально, но за то это процедура. И в таком случае как получить выбранную ссылку?
Короче .. Капец smile.gifsmile.gif
Главное даже по этой ерунде

Petre Подменю пользователя
сообщение 01.03.18, 17:28
Сообщение #7

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2371
Из: Київ, Україна
Спасибо сказали: 582 раз
Рейтинг: 541.8

Gigi @ Today, 17:07 * ,
Все зависит от конкретики.
Если полученную ссылку необходимо поместить в элемент формы, достаточно указать данный элемент как владельца в ПолучитьФорму и больше ничего не делать.
Если полученная ссылка не помещается в элемент формы, а лишь используется программно для х.з. каких целей, то, как вариант, в ПолучитьФорму как владелец указывается ЭтаФорма (как у вас в первом сообщении), и этой же форме-владельце в процедуре события ОбработкаВыбора получаем выбранное значение из параметра ЗначениеВыбора и делаем с ним что необходимо.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: Gigi,

logist Подменю пользователя
сообщение 01.03.18, 21:23
Сообщение #8

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2449 раз
Рейтинг: 1519.4

Цитата(Gigi @ 01.03.18, 17:07) *
Не важно что хочу...

Я бы на этом закрыл тему, реально надоело уже такое обращение.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Gigi Подменю пользователя
сообщение 02.03.18, 14:02
Сообщение #9

Оратор
*****
Группа: Пользователи
Сообщений: 267
Спасибо сказали: 3 раз
Рейтинг: 0

Petre @ Вчера, 17:28 * ,
Короче объясняю вкрадце
Есть кнопка на форме.
При нажатии на эту кнопку нужно:
Первое - Нужно что бы происходило то что обычно происходит при выборе реквизита Ссылка... ничего кроме .... т.е. появилась форма выбора БЕЗ МОДАЛЬНОГО РЕЖИМА.
Второе - Получить ссылку выбранного в переменную.
Третье - по этой ссылке сделать кое какие записи на сервере.
Вот собственно и все.
Так что пожалуйста если не трудно пример кода для указанных пунктов. Буду благодарен
Просто все это уже было не однократно сделано в таком стиле, о котором выше уже говорил:
ФормаВыбора=ПолучитьФорму("Справочник.Справочник1.ФормаВыбора",,ЭтаФорма);
ОбъектСсылка = ФормаВыбора.ОткрытьМодально(); // Так проходить без проблем
//ОбъектСсылка = ФормаВыбора.Открыть();  // А так выпердриваеться ... НИКАК НЕ ХОЧЕТ ....
Если ОбъектСсылка <> Неопределено Тогда
ФормаОбъектаСсылки = ПолучитьФорму("Справочник.Справочник1.ФормаОбъекта", новый Структура("Ключ", ОбъектСсылка));
Сообщить(ФормаОбъектаСсылки.Объект.Наименование);
ЗаписьПоСсылке(ОбъектСсылка);
КонецЕсли;

Не устраивает только режим МОДАЛЬНОГО ОТКРЫТИЯ. Вот и все
Так что кодовый пример указанных целей если не трудно
Буду весьма признателен!

Petre Подменю пользователя
сообщение 02.03.18, 15:39
Сообщение #10

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2371
Из: Київ, Україна
Спасибо сказали: 582 раз
Рейтинг: 541.8

Gigi @ Today, 14:02 * ,
Процедура МояКнопкаНажатие(Элемент)
    ФормаВыбора = ПолучитьФорму("Справочник.МойСправочник.ФормаВыбора", , ЭтаФорма);
    ФормаВыбора.Открыть();
КонецПроцедуры

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    Если ЗначениеВыбора <> Неопределено Тогда
        Сообщить(ЗначениеВыбора.Наименование);
    КонецЕсли;
КонецПроцедуры

где
- МояКнопкаНажатие - обработчик события "Нажатие" кнопки, которая нажимается;
- ОбработкаВыбора - обработчик события "ОбработкаВыбора" формы, где располагается кнопка.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: Gigi,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.07.18, 16:46
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне