Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Выбирается не та организация при создании заказа((          
Bulzavr Подменю пользователя
сообщение 30.01.18, 9:20
Сообщение #1

Рагуль
****
Группа: Ахтунги
Сообщений: 116
Спасибо сказали: 0 раз
Рейтинг: 0

В форме документа заказа клиента у нас сделано, чтобы при создании нового заказа всегда по-умолчанию выставлялось выбранное в настройках соглашение:
    Если Объект.Ссылка.Пустая() Тогда
        Объект.Соглашение = Константы.Соглашение.Получить();        
    КонецЕсли;


Но при этом почему-то организация всегда не соответствует той, что указана в соглашении.

Подскажите пожалуйста, что и куда дописать/изменить, чтобы организация тоже выставлялась по этому соглашению?

УТ 11,3 проф

Vidocq05 Подменю пользователя
сообщение 30.01.18, 10:03
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 165
Из: Сумы
Спасибо сказали: 25 раз
Рейтинг: 25

Bulzavr @ Сегодня, 10:20 * ,

Если я правильно понял вопрос то возможно так

Если Объект.Ссылка.Пустая() Тогда
        Объект.Соглашение = Константы.Соглашение.Получить();
        Объект.Организация= Объект.Соглашение.Организация;
КонецЕсли;

Спасибо сказали: Bulzavr,

Bulzavr Подменю пользователя
сообщение 30.01.18, 10:13
Сообщение #3

Рагуль
****
Группа: Ахтунги
Сообщений: 116
Спасибо сказали: 0 раз
Рейтинг: 0

В настройках сделали выбиралку "соглашение по-умолчанию"





Цитата(Vidocq05 @ 30.01.18, 11:03) *
Если я правильно понял вопрос то возможно так


Идеально! Спасибо Вам!!!

logist Подменю пользователя
сообщение 30.01.18, 13:35
Сообщение #4

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Цитата(Vidocq05 @ 30.01.18, 10:03) *
Если я правильно понял вопрос то возможно так

А лучше всего в таких случая вызывать событие "при изменении" соглашения, т.к. там по мимо установки организации может происходить еще кучу всего интересного.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Bulzavr Подменю пользователя
сообщение 31.01.18, 11:15
Сообщение #5

Рагуль
****
Группа: Ахтунги
Сообщений: 116
Спасибо сказали: 0 раз
Рейтинг: 0

Согласен. Только что напоролся..Организация выставилась, а НДС, факсимиле и тд. от другой организации. Подскажите, что прописать, чтобы соглашение не просто проставлялось по-умолчанию, а именно ВЫБИРАЛОСЬ (будто его мышкой кликнули)?
   Если Объект.Ссылка.Пустая() Тогда
        Объект.Соглашение = Константы.Соглашение.Получить();
??? СоглашениеПриИзменении() ???
    КонецЕсли;

logist Подменю пользователя
сообщение 31.01.18, 11:18
Сообщение #6

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

СоглашениеПриИзменении(Неопределено);



Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Bulzavr Подменю пользователя
сообщение 31.01.18, 11:25
Сообщение #7

Рагуль
****
Группа: Ахтунги
Сообщений: 116
Спасибо сказали: 0 раз
Рейтинг: 0

Сюда засунуть? Верно?

    Если Объект.Ссылка.Пустая() Тогда
        Объект.Соглашение = Константы.Соглашение.Получить();
        СоглашениеПриИзменении(Неопределено);        
    КонецЕсли;


Сообщение отредактировал logist - 31.01.18, 11:30

logist Подменю пользователя
сообщение 31.01.18, 11:30
Сообщение #8

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Верно


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Спасибо сказали: Bulzavr,

Bulzavr Подменю пользователя
сообщение 31.01.18, 11:32
Сообщение #9

Рагуль
****
Группа: Ахтунги
Сообщений: 116
Спасибо сказали: 0 раз
Рейтинг: 0

{Документ.ЗаказКлиента.Форма.ФормаДокумента.Форма(118,9)}: Процедура или функция с указанным именем не определена (СоглашениеПриИзменении)
        <<?>>СоглашениеПриИзменении(Неопределено);         (Проверка: Сервер)


logist Подменю пользователя
сообщение 31.01.18, 11:41
Сообщение #10

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Ну да. Так просто не выйдет smile.gif Попробуйте заменить на
ПриИзмененииСоглашенияСервер();


Если и это не поможет, тогда дерзайте самостоятельно, вам необходимо сделать так что бы при создании нового документа выполнилось всё что находится в процедуре СоглашениеПриИзменении, разумеется вы должны понимать что там есть клиентская и серверная часть.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Bulzavr Подменю пользователя
сообщение 31.01.18, 12:20
Сообщение #11

Рагуль
****
Группа: Ахтунги
Сообщений: 116
Спасибо сказали: 0 раз
Рейтинг: 0

Сделал спасибо))

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.18, 3:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне