Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Удаление всех изображений из товара , Как удалить все изображения ?          
Tseka Подменю пользователя
сообщение 07.03.19, 16:28
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 10
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

Как удалить все изображения в одном товаре ?

1С:Предприятие 8.3 (8.3.8.2027)

"Управление торговлей для Украины", редакция 2.3.



Процедура КнопкаУдалитьИзображениеНажатие(Элемент)
    Для Каждого Стр Из ТаблицаДанныхВрем Цикл
        
        Сообщить(Стр[3]);
        Товар = Справочники.Номенклатура.НайтиПоКоду(Стр[3]);
        
        
        ИзображениеНом = Товар.ОсновноеИзображение;
        ИзображениеНом = ИзображениеНом.Ссылка.ПолучитьОбъект();
        ИзображениеНом.Удалить();

        Сообщить(" удалена картинка "+Товар);
        

    КонецЦикла;

    КонецПроцедуры


Такой код не работает .

Bernet Подменю пользователя
сообщение 07.03.19, 16:37
Сообщение #2

Ветеран
Иконка группы
Группа: Местный
Сообщений: 786
Из: Хмельницкий
Спасибо сказали: 248 раз
Рейтинг: 224.7

Tseka @ Сегодня, 16:28 * ,
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
|    ХранилищеДопИнфы.Ссылка
|ИЗ
|    Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДопИнфы
|ГДЕ
|     ХранилищеДопИнфы.Объект = &Номенклатура
|";

Запрос.УстановитьПараметр("Номенклатура", ВАШАНОМЕНКЛАТУРА);

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий Цикл

    КартинкаОбъекта = Выборка.Ссылка.ПолучитьОбъект();
    КартинкаОбъект.ПометкаУдаления = ИСТИНА;
    КартинкаОбъект.Записать();

КонецЦикла;


Signature
Дописываю конфигурации на платформе 8.х.
- Управление торговым предприятием для Украины
- Управление производственным предприятием для Украины
- Управление небольшой фирмой для Украины
- Бухгалтерия для Украины;
- Общепит для Украины
- Ресторан (Рарус)
- Розница

Спасибо сказали: Tseka,

Tseka Подменю пользователя
сообщение 07.03.19, 18:18
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 10
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

Процедура КнопкаУдалитьИзображениеНажатие(Элемент)
    Для Каждого Стр Из ТаблицаДанныхВрем Цикл
        
        Сообщить(Стр[3]);
        Товар = Справочники.Номенклатура.НайтиПоКоду(Стр[3]);
        ТоварОбъект = Товар.ПолучитьОбъект();
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    ХранилищеДопИнфы.Ссылка
        |ИЗ
        |    Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДопИнфы
        |ГДЕ
        |     ХранилищеДопИнфы.Объект = &Номенклатура
        |";

        Запрос.УстановитьПараметр("Номенклатура", ТоварОбъект);

        Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий Цикл

            КартинкаОбъект = Выборка.Ссылка.ПолучитьОбъект();
            КартинкаОбъект.ПометкаУдаления = ИСТИНА;
            КартинкаОбъект.Записать();

        КонецЦикла;
        
        
    КонецЦикла;

КонецПроцедуры



{ВнешняяОбработка.ГрупповаяУстановкаОсновногоИзображения.Форма.Форма.Форма(1389)}: Ошибка при вызове метода контекста (Выполнить)
Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(6, 30)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
неограниченной длины и поля несовместимых типов.
ХранилищеДопИнфы.Объект <<?>>= &Номенклатура

help.gif






Tseka @ Сегодня, 18:06 * ,







Tseka Подменю пользователя
сообщение 08.03.19, 13:08
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 10
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

Всем спасибо ! Вот рабочий код .

Процедура КнопкаУдалитьИзображениеНажатие(Элемент)
    Для Каждого Стр Из ТаблицаДанныхВрем Цикл
        
        Сообщить(Стр[3]);
        Товар = Справочники.Номенклатура.НайтиПоКоду(Стр[3]);
        
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ХранилищеДополнительнойИнформации.Ссылка
        |ИЗ
        |    Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДополнительнойИнформации
        |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
        |        ПО ХранилищеДополнительнойИнформации.Объект = Номенклатура.Ссылка
        |ГДЕ
        |    Номенклатура.Ссылка = &Ссылка";

        Запрос.УстановитьПараметр("Ссылка", Товар);
        Результат = Запрос.Выполнить().Выбрать();
        Пока Результат.Следующий() Цикл
            Сообщить("Ставим пометку удаления изображения "+"для товара " + Товар.Наименование);    
            КартинкаОбъект = Результат.Ссылка.ПолучитьОбъект();
            КартинкаОбъект.ПометкаУдаления = ИСТИНА;
            КартинкаОбъект.Записать();

        КонецЦикла;
        
        
    КонецЦикла;

КонецПроцедуры

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 24.04.19, 22:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне