Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Только чтение для отдельной ячейки в ТЧ документа          
Constantus Подменю пользователя
сообщение 08.04.19, 18:13
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 788
Спасибо сказали: 5 раз
Рейтинг: 4

Приветствую, Форумчане!
1с8.3.6, УФ, самописная, БСП

Имеется документ "Заказ", ТЧ "Оформление", один из реквизитов "Цена"

Требуется, чтобы при определенных условиях эта ячейка цены была доступна или "только для чтения"

Условия доступности для редактирования:
1. (текущие данные строки)
Если ТекущиеДанные.ТипДанных = ПредопределенноеЗначение("Перечисление.ТипыДанныхОформления.П1") Или
        ТекущиеДанные.ТипДанных = ПредопределенноеЗначение("Перечисление.ТипыДанныхОформления.П2") Тогда

КонецЕсли;


2. Если доступна роль "ГлавныйНачальник"
3. Если подразделение имеет статус "Центр" (из шапки документа)

Подскажите как правильно и где прописать выполнение условий для данной ячейки?

Перепробовал несколько вариантов:
1. ПриАктивацииСтроки - грузит базу длительным расчетом
2. Перед началом изменения - блокирует всю строку для редактирования
3. Условное форматирование - смог прописать только условия №1

Как правильно организовать возможность или невозможность редактирования ячейки "Цена" при выполнении условий?



mut Подменю пользователя
сообщение 08.04.19, 19:01
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 48
Из: Новая Каховка
Спасибо сказали: 14 раз
Рейтинг: 13.3

Constantus @ Сегодня, 19:13 * ,
доступна роль или нет, статус подразделения, это можно определить при создании формы на сервере и поставить флажок (реквизит формы)
значения для сравнения - там-же - установить в дополнительные реквизиты на форме
ну и по совокупности уже проверять при активации строки

Petre Подменю пользователя
сообщение 09.04.19, 8:14
Сообщение #3

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2548
Из: Київ, Україна
Спасибо сказали: 665 раз
Рейтинг: 632.8

QUOTE (mut @ 08.04.19, 19:01) *
ну и по совокупности уже проверять при активации строки

Удобнее - в условном оформлении формы, раз уж УФ.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Constantus Подменю пользователя
сообщение 09.04.19, 9:28
Сообщение #4

Ветеран
*******
Группа: Пользователи
Сообщений: 788
Спасибо сказали: 5 раз
Рейтинг: 4

Попробовал активацию Ячейки

Процедура УсопшиеИОформлениеПриАктивизацииЯчейки(Элемент)
    // Вставить содержимое обработчика.
       //Если Элемент.ТекущаяКолонка.Имя = "Цена" Тогда
  //      Сообщить(Элемент);
    //КонецЕсли;
    
//    колонка - элементы.Список.ТекущийЭлемент.Имя;
//строка - элементы.список.текущиеданные;
    
КонецПроцедуры


Как применять этот "Элемент"? Т.е. обратиться к его свойствам и т.д.?

Элемент.ТекущаяКолонка.Имя = "Цена"


говорит, что нет такого "текущаяКолонка"

Идея в чем: чтобы когда тыкается в колонку с именем "Цена", то тогда идет проверка на всякое и ставится "Только чтение" на эту ячейку...

Подскажите как такое реализовать и как вообще работать с этим чудом "При активации Ячейки/Поля"?

pablo Подменю пользователя
сообщение 09.04.19, 11:50
Сообщение #5

Ветеран
*******
Группа: Команда (модераторы)
Сообщений: 985
Из: Одесса-Луганск
Спасибо сказали: 158 раз
Рейтинг: 119.9

Можно не привязываться к элементу, а проверять напрямую элементы формы
&НаКлиенте
Процедура ОбработкиПриАктивизацииЯчейки(Элемент)
    Если Элементы.Обработки.ТекущиеДанные<>Неопределено тогда
        Элементы.Обработки.ПодчиненныеЭлементы.ОбработкиПредставлениеНить.ТолькоПросмотр=не Элементы.Обработки.ТекущиеДанные.РедактироватьНить;




Signature
Правильно поставленный вопрос содержит до 90% ответа.

Спасибо сказали: Constantus,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.06.19, 7:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне