Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Связь основного документа с документом на основании          
Orion-PS Подменю пользователя
сообщение 03.05.18, 20:58
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 10
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день!
Возникла проблема по организации связи основного документа и документа на основании. Все необходимые интерактивные манипуляции в конфигураторе произведены (создан основной документ, к нему "привязан" документ на основании, созданы формы, соответственно, основного документа и документа на основании). Из дополнительных условий - документ на основании может быть ТОЛЬКО ОДИН. Отсюда, вроде бы, отпадает необходимость в списке документов на основании.
Проблема в том, что при вызове документа на основании из списка основных документов вызывается "пустая" форма документа на основании. Слово "пустая" указано в кавычках, потому, что данные из основного документа передаются в документ на основании корректно, но это и все. То есть, если документ на основании уже создан, то вызвать его из основного документа никак не получается.
Если все вышеописанное выглядит слишком размыто, сформулирую кратко суть задачи: при нажатии на кнопку "Документ на основании" из списка основных документов необходимо, чтобы происходило следующее: если документ на основании уже создан, он открывается. Если документ еще не создан, открывается форма для его создания. Это все!

P.S. Кстати, по умолчанию, кнопка для создания документа на основании размещается именно в списке основных документов, а не на форме конкретного документа, что было бы логичнее. Теперь уже не важно, почему разработчики сделали именно так, но возникает вопрос: как это исправить и создавать (или вызывать уже созданный) документ на основании из формы основного документа?


 ! 

Правила: 5
 


Сообщение отредактировал logist - 04.05.18, 0:49

logist Подменю пользователя
сообщение 04.05.18, 0:57
Сообщение #2

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Цитата(Orion-PS @ 03.05.18, 21:58) *
необходимо, чтобы происходило следующее: если документ на основании уже создан, он открывается. Если документ еще не создан, открывается форма для его создания.

Пропишите соответствующий код, если конфигурация на обычных формах это можно сделать в ОбработкеЗаполнения, если на управляемых то ПриОткрытии отказаться от открытия текущей и открыть нужную (через общий модуль).

Цитата(Orion-PS @ 03.05.18, 21:58) *
Кстати, по умолчанию, кнопка для создания документа на основании размещается именно в списке основных документов, а не на форме конкретного документа, что было бы логичнее.

Кнопки создания на основании размещаются и в списке и на форме, если у вас не так, значит вы что-то делаете не так.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Orion-PS Подменю пользователя
сообщение 04.05.18, 4:52
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 10
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(logist @ 04.05.18, 1:57) *
если у вас не так, значит вы что-то делаете не так

Это понятно, иначе я не задавал бы этот вопрос. Хотелось бы понять, что именно не так?

Основная проблема в том, что даже в книжках сведения приводятся по принципу "Два пишем (рассказываем самые общие сведения), три - в уме (об остальном читатель пусть догадывается сам, не догадался - его проблемы).
Например, совершенно очевидно, что основной документ (М) и документ на основании (S) должны быть связаны. То, что указывается в конфигураторе при создании документов M и S на вкладке "Ввод на основании", соответственно, в разделах "Вводится на основании" и "Является основанием для" - этого достаточно для организации необходимых связей или нет? Похоже, что нет.

А формы управляемые, используется 1С 8.3.12.

LOGIST, если у вас есть какой-нибудь реальный пример, в котором реализована вышеназванная возможность, приведите, пожалуйста...

logist Подменю пользователя
сообщение 04.05.18, 12:47
Сообщение #4

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Цитата(Orion-PS @ 04.05.18, 5:52) *
этого достаточно для организации необходимых связей или нет? Похоже, что нет.

Нет, не достаточно. "Ввод на основании" это лишь механизм платформы который отображает кнопку и запускает выполнение процедуры ОбработкаЗаполнения. Саму связь вы прописываете самостоятельно, путем добавления необходимых реквизитов.

Пример написан на коленке
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    СуществующееОснование = ФункцияКотораяВернетИмеющийсяДокумент(РеквизитФормыСДокументомОснованием);
    Если Не СуществующееОснование.Пустая() Тогда
        КакойТоОбщийМодуль.ОткрытьИмеющеесяОснование(ЭтаФорма, СуществующееОснование);
        Отказ = Истина;
    КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФункцияКотораяВернетИмеющийсяДокумент(Основание)
    Возврат Документы.ИмяДокументаОснования.НайтиПоРеквизиту("ИмяРеквизитаОснования", Основание);
КонецФункции


#Область КакойТоОбщийМодуль
Процедура ОткрытьИмеющеесяОснование(Форма, СуществующееОснование) Экспорт
    Форма.Закрыть();
    ПоказатьЗначение(,СуществующееОснование);
КонецПроцедуры
#КонецОбласти


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Спасибо сказали: Orion-PS,

хакерок Подменю пользователя
сообщение 04.05.18, 15:42
Сообщение #5

Оратор
*****
Группа: Пользователи
Сообщений: 254
Из: Київ
Спасибо сказали: 11 раз
Рейтинг: 11

Orion-PS @ Вчера, 21:58 * ,
создайТЕ запрос к базе данных который даст ВАМ ссылку на созданный документ и ВАША задача будет почти решена.

 ! 

Правила: 1
 


Сообщение отредактировал Vofka - 07.05.18, 8:46

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.18, 12:07
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне