Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Смена формы документа , По событию из формы списка, изменить форму документа          
Lexveritas Подменю пользователя
сообщение 20.02.18, 19:20
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 55
Спасибо сказали: 1 раз
Рейтинг: 1

Всем доброго вечера!

Задача то собственно говоря вообще никакая, но как то приуныл.
Уперся и никак даже приблизиться к ее решению не могу!

Есть форма списка, в ней события.
Нужно чтоб открывая документ всего то он открылся в той форме, которая необходима.

Самое большее чего добился - открытие и необходимой формы и той которая указана основной.

В свойствах табличного поля формы списка при событии "Выбор" вот какой обработчик

Процедура ДокументСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    А = Новый Структура;
   А.Вставить("Ключ", Документы.ОприходованиеТоваров);
    ОткрытьФорму("Документ.ОприходованиеТоваров.Форма.ФормаОприходования", А);    
КонецПроцедуры


В конечном итоге даже курение гугла и груды помоек ничего не дало!

Куда хоть копать подскажите!

sava1 Подменю пользователя
сообщение 20.02.18, 20:04
Сообщение #2

Крутой
Иконка группы
Группа: Местный
Сообщений: 1820
Из: Проскуров
Спасибо сказали: 426 раз
Рейтинг: 421.2

стандартнаяОбработка = ложь;

Lexveritas Подменю пользователя
сообщение 20.02.18, 21:05
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 55
Спасибо сказали: 1 раз
Рейтинг: 1

sava1 @ Сегодня, 20:04 * ,

А, извольте подсказать в событии чего, да и в каком событии это всё ваять? Я уж как то малость слишком потерялся!
Буду весьма признателен!

хакерок Подменю пользователя
сообщение 20.02.18, 22:27
Сообщение #4

Оратор
*****
Группа: Пользователи
Сообщений: 254
Из: Київ
Спасибо сказали: 11 раз
Рейтинг: 11

Lexveritas @ Сегодня, 21:05 * ,
Изменяется документ записывается а потом открывается это хотели?
&НаСервере
Функция ИзменитьДок(ДокСсылка)

   Объект = ДокСсылка.ПолучитьОбъект();
   Объект.Дата = НачалоМесяца(ТекущаяДата());
   Объект.Записать();
   Возврат Объект.Ссылка;

КонецФункции // ()

&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ложь;
    Док = ИзменитьДок(ВыбраннаяСтрока);
    ОткрытьЗначение(Док);
    
КонецПроцедуры


Если нужно при открытии менять то есть обработчик формы ПриОткрытии

Lexveritas Подменю пользователя
сообщение 20.02.18, 22:39
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 55
Спасибо сказали: 1 раз
Рейтинг: 1

хакерок @ Сегодня, 22:27 * ,


Вашпе совсем забыл дополнить то, что это не УФ, а обычное приложение. УПП...

И, вроде как нет. Есть общая форма, в ней ссылки на гору разных форм списков, из формы списка нужно открыть существующий документ. Ну и указать в какой форме открыть...

sava1 Подменю пользователя
сообщение 21.02.18, 7:54
Сообщение #6

Крутой
Иконка группы
Группа: Местный
Сообщений: 1820
Из: Проскуров
Спасибо сказали: 426 раз
Рейтинг: 421.2

Цитата(Lexveritas @ 20.02.18, 19:20) *
Самое большее чего добился - открытие и необходимой формы и той которая указана основной.

В свойствах табличного поля формы списка при событии "Выбор" вот какой обработчик

Процедура ДокументСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
А = Новый Структура;
А.Вставить("Ключ", Документы.ОприходованиеТоваров);
ОткрытьФорму("Документ.ОприходованиеТоваров.Форма.ФормаОприходования", А);
КонецПроцедуры


В этой процедуре. Для того, чтобы не открывалась основная форма.

Lexveritas Подменю пользователя
сообщение 21.02.18, 8:09
Сообщение #7

Говорящий
***
Группа: Пользователи
Сообщений: 55
Спасибо сказали: 1 раз
Рейтинг: 1

sava1 @ Сегодня, 7:54 * ,
Касательно основной формы я уже доехал, за что весьма признателен!
Открывается та форма которая мне необходима, но... Документ "такой то" создание... При попытке открыть существующий...
В любом случае создается новый документ, который мне не нужен! А, задача в том, чтоб открыть существующий документ в определенной форме.

sava1 Подменю пользователя
сообщение 21.02.18, 8:30
Сообщение #8

Крутой
Иконка группы
Группа: Местный
Сообщений: 1820
Из: Проскуров
Спасибо сказали: 426 раз
Рейтинг: 421.2

Типа так:

ТекДок = ЭлементыФормы.Список.ТекущиеДанные.Ссылка;
ТекДок.ПОлучитьФорму().Открыть();


Если "забанили" с справке 1с:

ПолучитьФорму(<Форма>, <Владелец>, <КлючУникальности>)

Спасибо сказали: Lexveritas,

Vofka Подменю пользователя
сообщение 21.02.18, 9:22
Сообщение #9

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12643
Из: Киев
Спасибо сказали: 3782 раз
Рейтинг: 2900.8

Цитата(Lexveritas @ 20.02.18, 21:05) *
А, извольте подсказать в событии чего, да и в каком событии это всё ваять?

В ДокументСписокВыбор


Signature
Услуги 1С программиста

Lexveritas Подменю пользователя
сообщение 21.02.18, 23:26
Сообщение #10

Говорящий
***
Группа: Пользователи
Сообщений: 55
Спасибо сказали: 1 раз
Рейтинг: 1

sava1 @ Сегодня, 8:30 * ,
Как же все элементарно оказалось!
Прокатило ДокументСписок...
Преогромное спасибо!

Vofka @ Сегодня, 9:22 * ,
Преогромное!
Вообще потерялся с событиями!

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.06.18, 17:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне