Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Работает ли СообщениеПользователю в управляемой форме обычного приложения? , Интересует привязка сообщения к реквизиту на управляемой форме          
Yevhenii Подменю пользователя
сообщение 19.01.17, 11:23
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 30
Из: Хмельницкий
Спасибо сказали: 0 раз
Рейтинг: 0

1С Предприятие 8.2 обычное приложение.
Конфигурация "Управление торговым предприятием для Украины", редакция 1.2.

Здравствуйте уважаемые.

Пытаюсь прикрутить вывод сообщения к полю ввода реквизита. Работаю в режиме обычного приложения, но форма управляемая.
Сообщение как бы выводит но только в нижней части, т.е. в некрасивой области сообщений. А хотелось бы выводить облачко именно на незаполненом поле.
Пробую вот так:
&НаКлиенте
Процедура ПродажаПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Если Элементы.ПолеКурс.ТекстРедактирования="0,00" Тогда
    
        Отказ=Истина;
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Сначала введите курс!";
                Сообщение.Поле  = "Курс";
            Сообщение.ПутьКДанным = "Объект";
            Сообщение.Сообщить();
    КонецЕсли;

КонецПроцедуры



и так:
&НаСервере
Процедура Сообщить4НаСервере()
    Сообщение4 = новый СообщениеПользователю;
    Сообщение4.УстановитьДанные(РеквизитФормыВЗначение("Объект"));
    Сообщение4.Текст = "Сначала введите курс!";
    Сообщение4.Поле = "Курс";
    Сообщение4.Сообщить();
КонецПроцедуры


&НаКлиенте
Процедура ПродажаПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    
    Если Элементы.ПолеКурс.ТекстРедактирования="0,00" Тогда
    
        Отказ=Истина;
            Сообщить4НаСервере();

    КонецЕсли;
КонецПроцедуры


Signature
Хороший код - работающий код.

Petre Подменю пользователя
сообщение 19.01.17, 11:41
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2111
Из: Київ, Україна
Спасибо сказали: 491 раз
Рейтинг: 459.6

Yevhenii @ Сегодня, 11:23 * ,
Не работает.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: Yevhenii,

podcast Подменю пользователя
сообщение 19.01.17, 11:54
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 186
Спасибо сказали: 33 раз
Рейтинг: 32.3

Yevhenii @ Сегодня, 11:23 * ,
Функции общего назначения помещайте в блок для клиента и сервера. Если в такой функции встречаются клиентские вызовы, например Сообщить или Состояние, то берите их в скобки ЕслиКлиент.

Спасибо сказали: Yevhenii,

Petre Подменю пользователя
сообщение 19.01.17, 12:40
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2111
Из: Київ, Україна
Спасибо сказали: 491 раз
Рейтинг: 459.6

podcast @ Сегодня, 11:54 * ,
К чему это?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

podcast Подменю пользователя
сообщение 19.01.17, 13:33
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 186
Спасибо сказали: 33 раз
Рейтинг: 32.3

Petre @ Сегодня, 12:40 * ,
К тому что когда база будет на скуле то будут ошибки, буквально пару дней назад столкнулся с такой ошибкой, в файловом варианте всё работала, а на скуле ошибка.

Petre Подменю пользователя
сообщение 19.01.17, 13:51
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2111
Из: Київ, Україна
Спасибо сказали: 491 раз
Рейтинг: 459.6

podcast @ Сегодня, 13:33 * ,
А можно конкретно указать, на какой строчке приведенного ТС кода будет ошибка "на скуле"?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

podcast Подменю пользователя
сообщение 19.01.17, 13:54
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 186
Спасибо сказали: 33 раз
Рейтинг: 32.3

Petre @ Сегодня, 13:51 * ,
А пардон,
Сообщить();

уже доступно на сервере.

Vofka Подменю пользователя
сообщение 19.01.17, 14:43
Сообщение #8

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12356
Из: Киев
Спасибо сказали: 3661 раз
Рейтинг: 2795.5

Цитата(podcast @ 19.01.17, 13:54) *
уже доступно на сервере.

Оно изначально было там доступно. Вы, наверное, перепутали с Предупреждение. Предупреждение на сервере недоступно.


Signature
Услуги 1С программиста

Yevhenii Подменю пользователя
сообщение 19.01.17, 16:35
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 30
Из: Хмельницкий
Спасибо сказали: 0 раз
Рейтинг: 0

На прикручивание забил, сделал ОповещениеПользователю и переходом фокуса на нужное поле.

Теперь другая проблемка:
Этот же документ где Форма документа является управляемой.
В обработке на ТабличномПоле с типом данных ДокументСписок.ИмяДокумента вывожу список данных документов, но при попытке открыть документ мне открывается документ со стандартной сконфигурируемой обычной формой. Т.е. не управляемая которая открывается при создании, а стандартная. С свойствах документа создана только одна управляемая форма, она же выбрана как основная и как дополнительная форма документа.
Как мне по клику открывать документ именно с моей управляемой формой?

 ! 

Правила: 6
 


Сообщение отредактировал logist - 26.01.17, 19:30


Signature
Хороший код - работающий код.

Petre Подменю пользователя
сообщение 19.01.17, 17:07
Сообщение #10

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2111
Из: Київ, Україна
Спасибо сказали: 491 раз
Рейтинг: 459.6

Yevhenii @ Сегодня, 16:35 * ,
8.3.9.2084: ситуация не воспроизводится...


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Тема закрыта Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.10.17, 21:20
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне