Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Работа в Хроме, Сафари          
alexkh75 Подменю пользователя
сообщение 30.03.18, 13:58
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день.

платформа 8.3.10.2667.
конфигурация Бухгалтерия для Украины, редакция 2.0. (2.0.8.1)

Интересуют только два рукописных отчета.
На компьютере в броузере (Хром, ИЕ) все работает.

На андроиде хром и на ios Сафари не работают полосы прокрутки у табличного документа.
и не работает расшифровка ячеек (должен открываться второй отчет).

Отчеты полностью делаются на сервере. На сервере же формируется табличный документ.
В броузеры все выводится табличный документ, но дальше проблемы.

Кто-то что-то может подсказать? куда копать и копать ли.
Спасибо.

Petre Подменю пользователя
сообщение 30.03.18, 14:29
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2312
Из: Київ, Україна
Спасибо сказали: 559 раз
Рейтинг: 516.4

alexkh75 @ Today, 13:58 * ,
QUOTE
При необходимости реализации расшифровки отчета, нужно понимать, что мобильное приложение самостоятельно может выполнить только просмотр значений, указанных в качестве расшифровки ячейки отчета. Остальные действия необходимо реализовывать на встроенном языке, включая получение нового варианта отчета с учетом наложенных отборов и т. д.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

alexkh75 Подменю пользователя
сообщение 30.03.18, 14:49
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

1. НЕ мобильное приложение.
2. есть процедура

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
//#Если ВебКлиент Тогда
//    ПараметрыОткрытия = Новый Структура("Ключ", Расшифровка);
//    ОткрытьФорму(ПолучитьИмяФормы(Расшифровка), ПараметрыОткрытия, ЭтотОбъект);
//#КонецЕсли
    Если ТипЗнч(Расшифровка) = Тип("Структура") Тогда
        СтандартнаяОбработка=Ложь;
        Парам = Новый Структура;
          Парам.Вставить("СформироватьПриОткрытии", Истина);
          Парам.Вставить("Расшифровка",Расшифровка);
          ОткрытьФорму("Отчет.ДвиженияДенежныхСредств.Форма", Парам, , Истина);
    КонецЕсли;
КонецПроцедуры


3. на компьютере в броузерах всё работает.


 ! 

Правила: 9
 


Сообщение отредактировал logist - 30.03.18, 14:55

logist Подменю пользователя
сообщение 30.03.18, 14:57
Сообщение #4

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Цитата(alexkh75 @ 30.03.18, 15:49) *
3. на компьютере в броузерах всё работает.

это не показатель. вэбклиент ведет себя по разному даже в "стационарных" браузерах, чего уж говорить про мобильный.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

alexkh75 Подменю пользователя
сообщение 30.03.18, 15:05
Сообщение #5

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

а мобильное приложение ведет себя устойчивее?
Лучше сделать и ставить его?

logist Подменю пользователя
сообщение 30.03.18, 15:22
Сообщение #6

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Цитата(alexkh75 @ 30.03.18, 16:05) *
а мобильное приложение ведет себя устойчивее?

Вопрос наверное не верно поставлен. Мобильное приложение это отдельная конфигурация, как вы его сделаете так оно и будет себя вести.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

alexkh75 Подменю пользователя
сообщение 30.03.18, 15:40
Сообщение #7

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

тогда еще вопрос.

В конце концов. нужно сделать этих два отчета для IOS.
Если буду их делать а затем отлаживть под андроид,
компиляция под IOS даст тотже результат или нужно делать и сразу смотреть на IOS?

logist Подменю пользователя
сообщение 30.03.18, 15:50
Сообщение #8

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Цитата(alexkh75 @ 30.03.18, 16:40) *
компиляция под IOS даст тотже результат

по идее тот же, но лучше проверять.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

alexkh75 Подменю пользователя
сообщение 30.03.18, 15:56
Сообщение #9

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

ок. если кто-то имеет что сказать за браузеры, то скажите.
Спасибо.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.04.18, 5:07
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне