Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Программное присваивание значения реквизита формы тип Картинка (1с 8.2 8.2.19.106)          
andrew76 Подменю пользователя
сообщение 30.07.18, 5:29
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 203
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 0

Доброе утро !

Есть ли возможность программно присвоить значение реквизиту Картинка на форме ?

пока работает такой вариант, а есть ли возможность присваивать значение программно ?

ЭлементыФормы.ПолеКартинки8.Картинка  = БиблиотекаКартинок.ОбщаяКартинка17;



Petre Подменю пользователя
сообщение 30.07.18, 7:57
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2530
Из: Київ, Україна
Спасибо сказали: 663 раз
Рейтинг: 630.8

andrew76 @ Today, 5:29 * ,
А вариант, что вы привели, не является программным? А каким же тогда?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

andrew76 Подменю пользователя
сообщение 30.07.18, 8:33
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 203
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 0

имелось в виду - присваивать динамически.

Vofka Подменю пользователя
сообщение 30.07.18, 9:43
Сообщение #4

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12939
Из: Киев
Спасибо сказали: 3930 раз
Рейтинг: 3061.4

andrew76, можно. Опишите что именно у вас не получается или что вы хотите сделать, потому что по тексту сообщения непонятно в чем проблема.


Signature
Услуги 1С программиста

TipsyKID Подменю пользователя
сообщение 30.07.18, 11:13
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 395
Из: Киев
Спасибо сказали: 157 раз
Рейтинг: 149.1

Применяю колдовство шамана 8-ого уровня, читаю мыслеконтур ТС..
Обычные формы:

Процедура ПутьККартинкеНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;

    ДиалогаВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогаВыбораФайла.ПолноеИмяФайла = "";
    ДиалогаВыбораФайла.Фильтр = "Файлы (*.jpg,*.*)|*.jpg;*.*";
    ДиалогаВыбораФайла.МножественныйВыбор = Ложь;
    ДиалогаВыбораФайла.Заголовок = "Выберите файл";

    Если Не ДиалогаВыбораФайла.Выбрать() Тогда
        Возврат;        
    КонецЕсли;
    
    ПутьККартинке = ДиалогаВыбораФайла.ПолноеИмяФайла;
    НоваяКартинка = Новый Картинка(ПутьККартинке);
    ЭлементыФормы.ПолеКартинки.Картинка = НоваяКартинка;
    
КонецПроцедуры


УФ
&НаКлиенте
Процедура ПутьККартинкеНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;

    ДиалогаВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогаВыбораФайла.ПолноеИмяФайла = "";
    ДиалогаВыбораФайла.Фильтр = "Файлы (*.jpg,*.*)|*.jpg;*.*";
    ДиалогаВыбораФайла.МножественныйВыбор = Ложь;
    ДиалогаВыбораФайла.Заголовок = "Выберите файл";

    Если Не ДиалогаВыбораФайла.Выбрать() Тогда
        Возврат;        
    КонецЕсли;
    
    Объект.ПутьККартинке = ДиалогаВыбораФайла.ПолноеИмяФайла;
    НоваяКартинка = Новый Картинка(Объект.ПутьККартинке);
    АдрессВременногоХранилища = ПоместитьВоВременноеХранилище(НоваяКартинка.ПолучитьДвоичныеДанные());
    
КонецПроцедуры



Signature
Специалист : Бухгалтерия для Украины, Управление торговлей для Украины, Зарплата и Управление Персоналом для Украины

Спасибо сказали: andrew76,

andrew76 Подменю пользователя
сообщение 30.07.18, 11:19
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 203
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 0

Цитата(Vofka @ 30.07.18, 12:43) *
Применяю колдовство шамана 8-ого уровня, читаю мыслеконтур ТС..


Ну , я так тоже могу...
а если объект Картинка сидит в ОбщихКартинках в конфигурации ? А у Вас пример с записью файла в ХранилищеДанных.

ЭлементыФормы.ПолеКартинки8.Картинка  = БиблиотекаКартинок.ОбщаяКартинка17;

Vofka Подменю пользователя
сообщение 30.07.18, 11:46
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12939
Из: Киев
Спасибо сказали: 3930 раз
Рейтинг: 3061.4

Цитата(andrew76 @ 30.07.18, 12:19) *
а если объект Картинка сидит в ОбщихКартинках в конфигурации ?

Попробую я применить свои телепатические способности.
ЭлементыФормы.ПолеКартинки8.Картинка  = БиблиотекаКартинок["ОбщаяКартинка17"];


Signature
Услуги 1С программиста

Спасибо сказали: andrew76,

andrew76 Подменю пользователя
сообщение 30.07.18, 12:30
Сообщение #8

Завсегдатай
****
Группа: Пользователи
Сообщений: 203
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 0

Цитата(Vofka @ 30.07.18, 14:46) *
Попробую я применить свои телепатические способности.


Спасибо,наверное этот вариант наилучший. (здаеця мини,цэй вариант наикрашчий , извиняюсь за плохую грамматику).

Vladal Подменю пользователя
сообщение 01.08.18, 9:06
Сообщение #9

Оратор
*****
Группа: Пользователи
Сообщений: 275
Из: Украина
Спасибо сказали: 47 раз
Рейтинг: 32

В типовой конфигурации в справочнике Номенклатура при активизации строки и включенной картинк товара есть такой код:

ТекущиеДанныеСписка = ЭлементыФормы.Список.Текущиеданные;
Если .... .... И НЕ ТекущиеДанныеСписка.ОсновноеИзображение.Пустая()
    ЭлементыФормы.ОсновноеИзображение.Картинка = ТекущиеДанныеСписка.ОсновноеИзображение.Хранилище.Получить();
Иначе
    ЭлементыФормы.ОсновноеИзображение.Картинка = мПустаяКартинка;
КонецЕсли
...


мПустаяКартинка = Новый Картинка;



ВОт тоже получение картинки. программно. Динамически из сохраненного значения.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.05.19, 15:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне