Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Программное Нажатие Кнопки , Нажатие средствами 1с.          
ukr.ray Подменю пользователя
сообщение 17.06.19, 10:43
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день, мне поставили задачу сделать автоматическое закрытие смены. Розница 1.0.
В определено время запускается форма.


 ! 

Правила: 8
 


Форме есть кнопка, как можно программно её нажать средствами 1с?

я пробовал такой вариант, присваивал кнопки "СочитаниеКлавишы" (Например кнопка F1)
Процедура ПриОткрытии()
    Shell= Новый COMОбъект("Wscript.Shell");
    Shell.SendKeys("{F1}");
КонецПроцедуры


Работает некорректно с 200 точек срабатывает примерно на 150.

У кого есть идеи как можно её нажать средствами 1с. ?

Объясняю почему надо именно нажать кнопку а не выполнить процедур которая прописана в кнопке.

Если просто запустить обработку закрытие смены (без физического нажатие кнопки), в момент закрытия смены, продавцы не читают что написано на экране и просто нажимают мышкой по открытой форме, появляется сообщение windows 1сv8 не отвечает Закрыть программу или Ожидание отклика от программы, ну конечно они нажимают Закрыть программу. и все смена не закрыта.

Сообщение отредактировал Vofka - 30.06.19, 10:20

nik389 Подменю пользователя
сообщение 17.06.19, 19:19
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 82
Из: Украина
Спасибо сказали: 23 раз
Рейтинг: 20

Используйте ПодключитьОбработчикОжидания.
и не нужно никаких извратов со скриптШеллом..

pablo Подменю пользователя
сообщение 18.06.19, 11:06
Сообщение #3

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1000
Из: Одесса-Луганск
Спасибо сказали: 159 раз
Рейтинг: 120.9

Сделайте в обработке нажатия кнопки нормальный прогресс-бар в виде отдельной формы. Такие готовые формы, например, есть в УПП ХодВыполненияОбработкиДанных, в БП - ДлительнаяОперация


Signature
Правильно поставленный вопрос содержит до 90% ответа.

ukr.ray Подменю пользователя
сообщение 20.06.19, 18:47
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(nik389 @ 17.06.19, 20:19) *
Используйте ПодключитьОбработчикОжидания.
и не нужно никаких извратов со скриптШеллом..

Не помогло

Цитата(pablo @ 18.06.19, 12:06) *
Сделайте в обработке нажатия кнопки нормальный прогресс-бар в виде отдельной формы. Такие готовые формы, например, есть в УПП ХодВыполненияОбработкиДанных, в БП - ДлительнаяОперация

я не пробовал но думаю это тоже не поможет
вод видео для примера что делают эти дау...
[необходимо зарегистрироваться для просмотра ссылки]

Видео для примера что делают продавцы [необходимо зарегистрироваться для просмотра ссылки]

ed.kharkov Подменю пользователя
сообщение 21.06.19, 7:39
Сообщение #5

Говорящий
Иконка группы
Группа: Mecтный
Сообщений: 54
Из: Бровары
Спасибо сказали: 19 раз
Рейтинг: 19

Попробуйте сделать так:

Процедура ПриОткрытии(Отказ)
    
    ПодключитьОбработчикОжидания("ПрограммноеНажатиеКнопки", 0.1, Истина);
    
КонецПроцедуры


Процедура ПрограммноеНажатиеКнопки()
    
    wsh = Новый COMОбъект("WScript.Shell");
    Shell.SendKeys("{F1}");
    
КонецПроцедуры


У меня таким образом при открытии формы в поле вставляется скопированные текст. Все работает корректно.

ukr.ray Подменю пользователя
сообщение 25.06.19, 11:47
Сообщение #6

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(ed.kharkov @ 21.06.19, 8:39) *
У меня таким образом при открытии формы в поле вставляется скопированные текст. Все работает корректно.

Если 1с будет не активна(то есть нажат ПУСК Windows), нечего не сработает.

pablo Подменю пользователя
сообщение 25.06.19, 12:06
Сообщение #7

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1000
Из: Одесса-Луганск
Спасибо сказали: 159 раз
Рейтинг: 120.9

Если пользователь увидит на экране большую форму с прогресс-баром, который визуально изменяется за пару секунд наблюдения, и/или подписью под ним большими буквами - он поймет, что программу пока лучше не трогать.


Signature
Правильно поставленный вопрос содержит до 90% ответа.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 17.07.19, 10:50
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!