Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Проблема с записью в общие реквизиты документа , Платформа 8.2.19.106          
andrew76 Подменю пользователя
сообщение 18.04.17, 16:05
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 162
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 2

Добрый всем вечер !

Возникла необходимость записать определённое значение в общий реквизит "Исправил" Документа ПлатежноеПоручение.
Общий реквизит "Исправил" имеет ссылочный тип.Ссылка на Справочник пользователей 1С. При попытке обновить ОбщийРеквизит "Исправил" туда записывается текущий Пользователь 1С,админ-в моём случае( я захожу в 1с под админом).
Как в реквизит "Исправил" записать другое (можно пустое значение) -нужное мне имя пользователя ?

//...выбрать документы
ТекДок=Выборка.ПолучитьОбъект();
ТекДок.Исправил=Неопределено;
ТекДок.Записать();

Petre Подменю пользователя
сообщение 18.04.17, 16:18
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2070
Из: Київ, Україна
Спасибо сказали: 484 раз
Рейтинг: 462

andrew76 @ Сегодня, 16:05 * ,
Если после строки записи остановиться отладчиком, чему равно значение "ТекДок.Исправил"?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Bernet Подменю пользователя
сообщение 18.04.17, 16:21
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 369
Из: Хмельницкий
Спасибо сказали: 97 раз
Рейтинг: 94.5

andrew76 @ Сегодня, 17:05 * ,
Попробуйте так:
ТекДок=Выборка.ПолучитьОбъект();
ТекДок.Исправил=Справочники.Пользователи.ПУстаяСсылка(); // если надо пустое значение или можете найти пользователя по наименованию/коду.
ТекДок.Записать(РежимЗаписиДокумента.Запись);


Signature
Дописываю конфигурации на платформе 8.х.
- Управление торговым предприятием для Украины
- Управление производственным предприятием для Украины
- Управление небольшой фирмой для Украины
- Бухгалтерия для Украины;
- Общепит для Украины
- Ресторан (Рарус)
- Розница

andrew76 Подменю пользователя
сообщение 19.04.17, 7:13
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 162
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 2

Цитата(Petre @ 18.04.17, 19:18) *
Если после строки записи остановиться отладчиком, чему равно значение "ТекДок.Исправил"?



Значение равно "Администратор".А если смотреть отладчиком до метода Записать,тогда всё правильно работает.

Цитата(andrew76 @ 19.04.17, 9:48) *
Попробуйте так:
ТекДок=Выборка.ПолучитьОбъект();
ТекДок.Исправил=Справочники.Пользователи.ПУстаяСсылка(); // если надо пустое значение или можете найти пользователя по наименованию/коду.
ТекДок.Записать(РежимЗаписиДокумента.Запись);


Так тоже не работает.

sava1 Подменю пользователя
сообщение 19.04.17, 7:28
Сообщение #5

Крутой
Иконка группы
Группа: Местный
Сообщений: 1522
Из: Проскуров
Спасибо сказали: 359 раз
Рейтинг: 355.9

В модуле документа или на Подписки смотрели ?

Спасибо сказали: andrew76,

andrew76 Подменю пользователя
сообщение 19.04.17, 8:00
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 162
Из: Узбекистан
Спасибо сказали: 2 раз
Рейтинг: 2

В модуле подписки есть:

Процедура ЗаписьОбщихРеквизитовПриЗаписи(Источник, Отказ) Экспорт
    Если Источник.Модифицированность() Тогда
        Если Метаданные.ОбщиеРеквизиты.Создал.Состав.Найти(Метаданные.НайтиПоТипу(ТипЗнч(Источник)).Имя).Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.Использовать Тогда
            Если ЗначениеНеЗаполнено(Источник.Создал) Тогда
                Источник.Создал = ПараметрыСеанса.ПользовательСсылка;
            КонецЕсли;
            Источник.Исправил = ПараметрыСеанса.ПользовательСсылка;
            Источник.Изменен = ТекущаяДатаНаСервере();
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры



Попробовать временно отменить строчку что-ли ? :

Источник.Исправил = ПараметрыСеанса.ПользовательСсылка;

sava1 Подменю пользователя
сообщение 19.04.17, 8:21
Сообщение #7

Крутой
Иконка группы
Группа: Местный
Сообщений: 1522
Из: Проскуров
Спасибо сказали: 359 раз
Рейтинг: 355.9

Цитата(andrew76 @ 19.04.17, 9:00) *
Попробовать временно отменить строчку что-ли ? :

конечно

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 25.09.17, 20:49
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне