Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> При открытии не вносить изменения в поле выбора          
Constantus Подменю пользователя
сообщение 03.08.18, 14:44
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 695
Спасибо сказали: 4 раз
Рейтинг: 4

Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

У меня при открытии формы (нетипового документа) стоит код, который заполняет реквизит "ПериодНачисления" (дата) в формате "Месяц год".
Этот реквизит оформлен как поле выбора. Код заполняет список выбора и в зависимости от даты (первый день месяца) заполняет в нужном формате.

    Если НЕ ЗначениеЗаполнено(ПериодНачисления) Тогда
        СформироватьСписокВыбораМесяца(Год(ТекущаяДата()));
    Иначе
        СформироватьСписокВыбораМесяца(Год(ПериодНачисления));
        ПериодНачисления = ЭлементыФормы.ПериодНачисления.СписокВыбора[Месяц(ПериодНачисления)+1].Значение;
    КонецЕсли;



Процедура СформироватьСписокВыбораМесяца(Знач Год)
    
    Год = Число(Год);
    СписокВыбора = ЭлементыФормы.ПериодНачисления.СписокВыбора;
    СписокВыбора.Очистить();
    СписокВыбора.Добавить(Null);
    СписокВыбора.Добавить(Формат(Год-1, "ЧГ=0"), Формат(Год-1, "ЧГ=0"));
    Для М = 1 По 12 Цикл
        СформДата = Дата(Год, М, 1);
        Наим = Формат(СформДата, "ДФ='ММММ гггг"" г.""'");
        СписокВыбора.Добавить(СформДата, Наим);    
    КонецЦикла;
    СписокВыбора.Добавить(Формат(Год+1, "ЧГ=0"), Формат(Год+1, "ЧГ=0"));
    
КонецПроцедуры



Но столкнулся с такой проблемой, получается так, что всегда при открытии этот код переопределяет значение "ПериодНачисления" и если ты даже просто открыл документ для просмотра, то при закрытии сообщает, что данные были изменены и требуется сохранить.

Как можно используя эти код, при открытии не проводить переопределение старого значения на новое?

Если ремачу
//ПериодНачисления = ЭлементыФормы.ПериодНачисления.СписокВыбора[Месяц(ПериодНачисления)+1].Значение;

то реквизит после открытия пустой.

Vidocq05 Подменю пользователя
сообщение 03.08.18, 15:06
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 175
Из: Сумы
Спасибо сказали: 28 раз
Рейтинг: 28

Constantus @ Сегодня, 15:44 * ,
Поцепите этот код на "НачалоВыбораИзСписка".

Спасибо сказали: ed.kharkov,

ed.kharkov Подменю пользователя
сообщение 03.08.18, 15:08
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 49
Из: Бровары
Спасибо сказали: 16 раз
Рейтинг: 16

Constantus @ Сегодня, 15:44 * ,
Добрый день.
Так может список выбора формировать в момент начала выбора даты, а не при открытии документа?

Constantus Подменю пользователя
сообщение 03.08.18, 15:23
Сообщение #4

Почти ветеран
******
Группа: Пользователи
Сообщений: 695
Спасибо сказали: 4 раз
Рейтинг: 4

Vidocq05 @ Сегодня, 18:06 * ,

Может быть, но перенос этого кода не помог. При открытии формы данное поле пустое, хотя когда тыкаешь, то он фокусирует в списке нужное значение, а визуально всё пусто

Vidocq05 Подменю пользователя
сообщение 03.08.18, 15:35
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 175
Из: Сумы
Спасибо сказали: 28 раз
Рейтинг: 28

Цитата(Constantus @ 03.08.18, 15:44) *
"ПериодНачисления" (дата)

Это реквизит формы или объекта?

Constantus Подменю пользователя
сообщение 03.08.18, 15:40
Сообщение #6

Почти ветеран
******
Группа: Пользователи
Сообщений: 695
Спасибо сказали: 4 раз
Рейтинг: 4

Vidocq05 @ Сегодня, 18:35 * ,

Это реквизит объекта...

Vidocq05 Подменю пользователя
сообщение 03.08.18, 15:46
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 175
Из: Сумы
Спасибо сказали: 28 раз
Рейтинг: 28

Constantus @ Сегодня, 16:40 * ,
В свойствах элемента формы в поле "Данные" выбран "ПериодНачисления" как реквизит объекта?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.12.18, 10:56
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне