Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Позиционирование в динамическом списке.          
Alex78 Подменю пользователя
сообщение 21.03.18, 11:28
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 33
Спасибо сказали: 2 раз
Рейтинг: 2

Доброго времени суток.
Есть управляемая форма.
Есть реквизит формы "СписокНоменклатура", тип - ДинамическийСписок.
Есть соответствующий ему элемент формы - "СписокНоменклатура1".
Вопрос - как в "СписокНоменклатура1" спозиционироваться на конкретном товаре?
Платформа 8.3.10.2252.

logist Подменю пользователя
сообщение 21.03.18, 12:03
Сообщение #2

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

В динамическом списке нет возможности позиционироваться.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Alex78 Подменю пользователя
сообщение 21.03.18, 12:04
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 33
Спасибо сказали: 2 раз
Рейтинг: 2

(((

Petre Подменю пользователя
сообщение 21.03.18, 12:48
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2312
Из: Київ, Україна
Спасибо сказали: 559 раз
Рейтинг: 516.4

Alex78 @ Today, 11:28 * ,
Есть такой параметр формы динамического списка, как "ТекущаяСтрока".


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Vofka Подменю пользователя
сообщение 21.03.18, 13:31
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12579
Из: Киев
Спасибо сказали: 3760 раз
Рейтинг: 2879.1

Цитата(logist @ 21.03.18, 12:03) *
В динамическом списке нет возможности позиционироваться.

http://pro1c.org.ua/index.php?s=&showt...st&p=139649


Signature
Услуги 1С программиста

хакерок Подменю пользователя
сообщение 21.03.18, 15:17
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 246
Из: Київ
Спасибо сказали: 11 раз
Рейтинг: 11

Alex78 @ Сегодня, 11:28 * ,
    Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию("Картопля");
  Если Не Номенклатура.Пустая() Тогда
      Элементы.СписокНоменклатура1.ТекущаяСтрока =Номенклатура;
  КонецЕсли;

Bernet Подменю пользователя
сообщение 21.03.18, 15:22
Сообщение #7

Почти ветеран
Иконка группы
Группа: Местный
Сообщений: 567
Из: Хмельницкий
Спасибо сказали: 171 раз
Рейтинг: 150.8

хакерок @ Сегодня, 15:17 * ,
не взлетит


Signature
Дописываю конфигурации на платформе 8.х.
- Управление торговым предприятием для Украины
- Управление производственным предприятием для Украины
- Управление небольшой фирмой для Украины
- Бухгалтерия для Украины;
- Общепит для Украины
- Ресторан (Рарус)
- Розница

хакерок Подменю пользователя
сообщение 21.03.18, 16:06
Сообщение #8

Завсегдатай
****
Группа: Пользователи
Сообщений: 246
Из: Київ
Спасибо сказали: 11 раз
Рейтинг: 11

Bernet @ Сегодня, 15:22 * ,
у меня вот этот кусок работает

&НаКлиенте
Процедура ВводКодаПриИзменении(Элемент)
    
    Номенклатура = БазовыйНоменклатура.ПолучитьНоменклатуруПоКодуТовара(Число(ВводКода));
  Если Не Номенклатура.Пустая() Тогда
      Элементы.Дерево.ТекущаяСтрока =БазовыйНоменклатура.ПолучитьГруппуНоменклатуры(Номенклатура);
      Элементы.Список.ТекущаяСтрока =Номенклатура;
  Иначе
      ВводКода= "";
  КонецЕсли;

КонецПроцедуры


Цитата(хакерок @ 21.03.18, 15:17) *
  Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию("Картопля");
  Если Не Номенклатура.Пустая() Тогда
      Элементы.СписокНоменклатура1.ТекущаяСтрока =Номенклатура;
  КонецЕсли;


И ещё чтобы это работало нужно в реквизите СписокНоменклатура там где Настройка списка указать Основная таблица Справочник.Номенклатура

logist Подменю пользователя
сообщение 21.03.18, 17:16
Сообщение #9

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Vofka, каюсь. Что не день то открытия smile.gif


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Alex78 Подменю пользователя
сообщение 23.03.18, 10:26
Сообщение #10

Общительный
**
Группа: Пользователи
Сообщений: 33
Спасибо сказали: 2 раз
Рейтинг: 2

Цитата(Petre @ 21.03.18, 12:48) *
Есть такой параметр формы динамического списка, как "ТекущаяСтрока".

пробовал, не работает

хакерок @ 21.03.18, 15:17 * ,
пробовал, не работает

основная таблица - СправочникСсылка.Номенклатура, варианты с ТекущаяСтрока не работают

хакерок Подменю пользователя
сообщение 23.03.18, 17:36
Сообщение #11

Завсегдатай
****
Группа: Пользователи
Сообщений: 246
Из: Київ
Спасибо сказали: 11 раз
Рейтинг: 11

Alex78 @ Сегодня, 10:26 * ,
В числе полей запроса обязательно должно быть поле ссылка и галочка Использовать всегда.

Vofka @ Сегодня, 9:19 * ,
Стоит поднять тему какие типовые конфигурации будут востребованы ?

Petre Подменю пользователя
сообщение 23.03.18, 18:03
Сообщение #12

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2312
Из: Київ, Україна
Спасибо сказали: 559 раз
Рейтинг: 516.4

QUOTE (Alex78 @ 23.03.18, 10:26) *
пробовал, не работает

Бывает. Я пробовал - работает.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.04.18, 4:58
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне