Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Подписка на событие: ошибка при обмене РИБ          
Constantus Подменю пользователя
сообщение 16.07.18, 12:00
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал подписку на события с целью "мягкой" проверки правильного заполнения статей движения денежных средств с возможностью отказа запрета "ПередЗаписью":

Код
Для Каждого СТЧ из Источник.РасшифровкаПлатежа Цикл
        Если СТЧ.СтатьяДвиженияДенежныхСредств.ВаловаяПрибыль
            И НЕ ЗначениеЗаполнено(Источник.ДатаВП) Тогда
            Сообщить("Данная статья (" + СТЧ.СтатьяДвиженияДенежныхСредств + ") предусматривает участие в Отчете по валовой прибыли." + Символы.ПС + "Рекомендуется указать период учета по данной статье. Иначе данные средства не войдут в учет по валовой прибыли.");
            
            Ответ = Вопрос("Требуется ли указать период учета?", РежимДиалогаВопрос.ДаНет,0);
            Если Ответ = КодВозвратаДиалога.Нет Тогда
                Отказ = Ложь;
            Иначе
                Отказ = Истина;  
            КонецЕсли;
            
        КонецЕсли;    
    КонецЦикла;


Ну т.е. была попытка только рекомендовать, если не надо, то и не надо, документ проводится спокойно.

Когда тестировал, всё срабатывало без проблем. Обновил конфигурацию. Запустил обмен РИБ. Сначала автообмен с полными правами и выдало ошибку:


Цитата
{ОбщийМодуль.Мой.Модуль(958,57)}: Переменная не определена (РежимДиалогаВопрос)
Ответ = Вопрос("Требуется ли указать период учета?", <<?>>РежимДиалогаВопрос.ДаНет,0);
{ОбщийМодуль.Мой.Модуль(959,17)}: Переменная не определена (КодВозвратаДиалога)
Если Ответ = <<?>>КодВозвратаДиалога.Нет Тогда
{ОбщийМодуль.Мой.Модуль(958,12)}: Процедура или функция с указанным именем не определена (Вопрос)
Ответ = <<?>>Вопрос("Требуется ли указать период учета?", РежимДиалогаВопрос.ДаНет,0);


Отключил у всех своих обменников "обмен с полными правами". Обмены работают, но автообмен нет, теперь вынужден только в ручную обмен задействовать.

Почему такое случилось? Почему неопределенность переменных и функции "Вопрос" увиделось только при обмене данными? Ну и соответственно автообмен упал.
Что нужно предпринять?

Сообщение отредактировал Vofka - 17.07.18, 8:23

Petre Подменю пользователя
сообщение 16.07.18, 12:58
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2443
Из: Київ, Україна
Спасибо сказали: 608 раз
Рейтинг: 567

QUOTE (Constantus @ 16.07.18, 12:00) *
Что нужно предпринять?

Использовать инструкции препроцессора.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Constantus Подменю пользователя
сообщение 16.07.18, 13:05
Сообщение #3

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

Petre @ Сегодня, 15:58 * ,


#Если Клиент Тогда???

Куда вставить лучше? На весь код подписок на событие или только на код диалога?

sava1 Подменю пользователя
сообщение 16.07.18, 13:17
Сообщение #4

Крутой
Иконка группы
Группа: Местный
Сообщений: 1914
Из: Проскуров
Спасибо сказали: 446 раз
Рейтинг: 435.8

Если обмен - вооще отказаться от проверки - нафика ?

Constantus Подменю пользователя
сообщение 16.07.18, 14:58
Сообщение #5

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

Цитата(sava1 @ 16.07.18, 16:17) *
Если обмен - вооще отказаться от проверки - нафика ?


Вот не совсем понял эту фразу icon_beer17.gif
Так как правильно поступить?

ПС: зря я кажется связался с этими подписками...

Constantus Подменю пользователя
сообщение 17.07.18, 7:40
Сообщение #6

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

Что-то я совсем не понял ситуацию... Взял эту ошибочную конфигурацию, сделал для нее узел РИБ, запустил обмен, никаких ошибок по вышеизложенному не стал давать. Всё работает как часы...

Что тогда могло случится?

Vofka Подменю пользователя
сообщение 17.07.18, 8:24
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12738
Из: Киев
Спасибо сказали: 3836 раз
Рейтинг: 2958.4

Цитата(Constantus @ 16.07.18, 15:58) *
Вот не совсем понял эту фразу
Так как правильно поступить?

Если обмен происходит в атоматическом режиме по расписанию, то кому по вашему будет адресован Вопрос? Точнее даже так: кто на него ответит?


Signature
Услуги 1С программиста

sava1 Подменю пользователя
сообщение 17.07.18, 10:05
Сообщение #8

Крутой
Иконка группы
Группа: Местный
Сообщений: 1914
Из: Проскуров
Спасибо сказали: 446 раз
Рейтинг: 435.8

Цитата(Constantus @ 16.07.18, 15:58) *
Вот не совсем понял эту фразу icon_beer17.gif


перед записью:

Если ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.11.18, 20:33
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне