Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> ПланСчетов Ограничение использования , Ограничить доступ пользователю в выборе счета          
avel1976 Подменю пользователя
сообщение 27.10.18, 16:28
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 25
Из: Україна, Миргород
Спасибо сказали: 3 раз
Рейтинг: 3

Добрый день. Поставили такую задачу: необходимо пользователю ограничить выбор бух.счетов в оборотно-сальдовой ведомости и остальных отчетах, скажем чтобы пользователь мог сделать отчет по 311, 361, но не мог сделать отчет по 661. Подскажите, пожалуйста, возможно ли такое сделать программно? Спасибо за ответ.

Конфигурация
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.45.2), Обычные формы

1С:Предприятие 8.3 (8.3.10.2561)

Vofka Подменю пользователя
сообщение 29.10.18, 8:46
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12755
Из: Киев
Спасибо сказали: 3841 раз
Рейтинг: 2964

Возможно.


Signature
Услуги 1С программиста

avel1976 Подменю пользователя
сообщение 29.10.18, 8:53
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 25
Из: Україна, Миргород
Спасибо сказали: 3 раз
Рейтинг: 3

Vofka @ Сегодня, 9:46 * ,
А как лучше реализавать? Через планы видов характеристик или может есть попроще вариант?

Vofka Подменю пользователя
сообщение 29.10.18, 9:13
Сообщение #4

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12755
Из: Киев
Спасибо сказали: 3841 раз
Рейтинг: 2964

avel1976, задача сводится к тому, что надо написать какую-то проверку или при выборе счета или при формировании отчета

Если ... Тогда
   Сообщить("...");
   Возврат;
КонецЕсли;


Что написать в Если вам виднее: либо это какая-то настройка пользователя будет, либо проверка на наличие/отсутствие какой-то роли, либо любой другой нужный конкретно в вашем случае сценарий.


Signature
Услуги 1С программиста

Спасибо сказали: avel1976,

avel1976 Подменю пользователя
сообщение 29.10.18, 17:26
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 25
Из: Україна, Миргород
Спасибо сказали: 3 раз
Рейтинг: 3

Задача решена. Делюсь, может кому пригодится. В модуле формы "Список" и в модуле формы "Выбор" создаем процедуру "ПередОткрытием" и пишем следующий код:
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если РольДоступна("ВашаРоль") Тогда
        ЭтаФорма.Отбор.Код.ВидСравнения = ВидСравнения.ВСписке;
        СЗ = Новый СписокЗначений;
        СЗ.Добавить("311");
        СЗ.Добавить("361");
        СЗ.Добавить("69");
        СЗ.Добавить("6431");
        СЗ.Добавить("6432");
        СЗ.Добавить("6412");
        ЭтаФорма.Отбор.Код.Значение = СЗ;
        ЭтаФорма.Отбор.Код.Использование = ИСТИНА;
                //Запретим пользователю менять установленные счета
        ЭлементыФормы.Список.НастройкаОтбора.Код.Доступность = Ложь;
    КонецЕсли;
КонецПроцедуры

Спасибо сказали: Gazulo,

avel1976 Подменю пользователя
сообщение 29.10.18, 21:46
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 25
Из: Україна, Миргород
Спасибо сказали: 3 раз
Рейтинг: 3

И еще в догонку в процедуре при изменении счета
Процедура СчетПриИзменении(Элемент)
    Если РольДоступна("ВашаРоль") Тогда        
        Если Счет.Код = "311" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли  Счет.Код = "361" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли  Счет.Код = "362" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли Счет.Код = "69" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли Счет.Код = "683" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        Иначе
            Предупреждение("Рахунок " + Счет + " для перегляду заборонено! ");
            Счет = "";
            Возврат;
        КонецЕсли;    
    КонецЕсли;    
    ОбработкаИзмененияСчета();
    ОбновитьПанельНастроек();
    
КонецПроцедуры

Moloko Подменю пользователя
сообщение 29.10.18, 22:49
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 3 раз
Рейтинг: 3

Продвинутый пользователь помимо 661-го счета может еще полюбопытствовать зарплатными регистровыми отчетами, просто пройтись по регистрам по взаиморасчётам с сотрудниками, по расчетам по налогам (там есть база налогообложения), по регистрам расчетов и, наконец, открыть универсальный отчет или консоль запросов.
Да, еще можно открыть зарплатную ведомость через платежное поручение.
Помню, мне приходилось заваривать все эти отверстия.

avel1976 Подменю пользователя
сообщение 29.10.18, 22:57
Сообщение #8

Общительный
**
Группа: Пользователи
Сообщений: 25
Из: Україна, Миргород
Спасибо сказали: 3 раз
Рейтинг: 3

Moloko @ Сегодня, 23:49 * ,
Интерфейс пользователя написан только с теми документами и отчетами которые ему нужны. До оборотно-сальдовой, к регистрам у него нет доступа, кнопки "Операции", "Сервис" и "Переключение интерфейса" убраны.

Petre Подменю пользователя
сообщение 30.10.18, 9:08
Сообщение #9

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2451
Из: Київ, Україна
Спасибо сказали: 610 раз
Рейтинг: 569.6

avel1976 @ Yesterday, 21:46 * ,
А если набрать с клавиатуры в поле?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

avel1976 Подменю пользователя
сообщение 01.11.18, 18:54
Сообщение #10

Общительный
**
Группа: Пользователи
Сообщений: 25
Из: Україна, Миргород
Спасибо сказали: 3 раз
Рейтинг: 3

Petre @ 30.10.18, 10:08 * ,
А там вторая часть кода, которая проверяет.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.11.18, 6:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне