Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Передать и вставить значение в ФормыВыбора          
Gigi Подменю пользователя
сообщение 18.06.17, 12:16
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 137
Спасибо сказали: 0 раз
Рейтинг: 0

Всем привет!
Сталкнулся с проблемой ... требуеться Ваша помощь.
Нужно два раза запустить ФормуВыбора и в самим всавленную поля пойска каждой вставитть нужное значения выбора элемента.
Внизу процедура кнопки.
И дело в том, что то, что обозначено коментарием: "ЗАПУСК 1" работает нормально. Т.е. когда форма открылась нужное значение успешно всавляеться в нужное поле Формы на верхней ее панели.
А уже во втором судчае (в месте обозначеном: "ЗАПУСК 2"), никак не получаеться получить то же самое, что и при ЗАПУСКЕ 1
Т.е. перемнные: Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения); актуальны, но вторая: "ТочкаСнабжения" НУ НИКАК НЕ ВСТАВЛЯЕТЬСЯ в поле формы: "ТочкаСнабжения"
Не пойму в чем причина.
Расчитываю на Вашу помощь
&НаКлиенте
Процедура СубТочка_Выбрать(Команда)
Если Объект.Код = ""  Тогда
Предупреждение("Для определения суб-точек учета объект не сохранен!");
Перейти ~Выход;
Иначе
ОБЪЕКТимя=Объект.Найменование;
КонецЕсли;
//=============== ЗАПУСК 1 ============================
ФормаВыбор_ТочкаСнабжение=ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
ФормаВыбор_ТочкаСнабжение.ОбъектПринадлежности=ОБЪЕКТимя;
//-------------------------------------------
Выбор_ТочкаСнабжение = ФормаВыбор_ТочкаСнабжение.ОткрытьМодально();
//=====================================================
Если Выбор_ТочкаСнабжение <> Неопределено Тогда
//=============== ЗАПУСК 2 ============================
знВыборПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", новый Структура("Ключ", Выбор_ТочкаСнабжение));
знТочкаСнабжения=знВыборПолучить.Объект.Найменование;
//################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,); //ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.Форма.ФормаВыбора",,);
//ТУТ ПОЛЕ ФормыВыбора: "ТочкаСнабжения", НУ НИКАК НЕ ХОЧЕТ ПРИНИМАТЬ ЗНАЧЕНИЕ ПЕРЕМЕННОЙ; "ТочкаСнабжения". НИКАК ЗАРАЗА!
//УЖЕ ПРИ ВТОРОМ ЗАПУСКЕ ФормыВыбора ПРОСТО ИГНОРИРУЕТ ЕЕ ... ПРОПУСКАЕТ
ФормаВыбор_ТочкаПодключение.ТочкаСнабжения=знТочкаСнабжения;
ФормаВыбор_ТочкаПодключение.Открыть();
Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения);
//################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
КонецЕсли;
//===========================================
~Выход:;
КонецПроцедуры

Буду очень признателен Вам!

Gigi Подменю пользователя
сообщение 19.06.17, 8:30
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 137
Спасибо сказали: 0 раз
Рейтинг: 0

Gigi @ Вчера, 13:16 * ,
Понял ошибку...
Для тех, которые тоже сталкивались...
&НаКлиенте
Процедура СубТочка_Выбрать(Команда)
Если Объект.Код = ""  Тогда
Предупреждение("Для определения суб-точек учета объект не сохранен!");
Перейти ~Выход;
КонецЕсли;
//================= ЗАПУСК 1==========================
ФормаВыбор_ТочкиСнабж=ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
//-------------------------------------------
ВыбранныйЭл_ТочкиСнабж = ФормаВыбор_ТочкиСнабж.ОткрытьМодально();
//-------------------------------------------
Если ВыбранныйЭл_ТочкиСнабж=Неопределено Тогда Перейти ~Выход; КонецЕсли;
//-------------------------------------------
ПараметрыЭлемента = Новый Структура("Ключ",ВыбранныйЭл_ТочкиСнабж);
ФормаОбъектаПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", ПараметрыЭлемента);
            ТочкаСнабж_Имя=ФормаОбъектаПолучить.Объект.Наименование;
//==================== ЗАПУСК 2 =======================
ФормаВыбор_ТочкиПодключ = ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
ВыбранныйЭл_ТочкиПодключ = ФормаВыбор_ТочкиПодключ.ОткрытьМодально();
//-------------------------------------------
Если ВыбранныйЭл_ТочкиПодключ=Неопределено Тогда Перейти ~Выход; КонецЕсли;
//-------------------------------------------
ПараметрыЭлемента = Новый Структура("Ключ",ВыбранныйЭл_ТочкиПодключ);
ФормаОбъектаПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", ПараметрыЭлемента);
            ТочкаПодключ_Имя=ФормаОбъектаПолучить.Объект.Наименование;
//=======================================================
Если ВыбранныйЭл_ТочкиСнабж<>Неопределено и ВыбранныйЭл_ТочкиПодключ<>Неопределено Тогда
Если Вопрос("Определить подключение учетной точки: «"+ТочкаПодключ_Имя+"» к точке учета: «"+ТочкаСнабж_Имя+"»?",РежимДиалогаВопрос.ДаНет,,,"Создение суб-точки учета")=КодВозвратаДиалога.Да Тогда
// Действие ....    
КонецЕсли;
КонецЕсли;
//=======================================================
~Выход:;
КонецПроцедуры

Если кто доработает то буду признателен.

Gangar Подменю пользователя
сообщение 23.06.17, 7:32
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

через Оповестить() => ОбработкаОповещения() не предлагать?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 22.10.17, 14:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне