Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Печать штрихкода , не выводит картинку штрихкода          
zimelya Подменю пользователя
сообщение 02.07.18, 15:50
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день! Прошу помощи, обыскал все интернеты и пусто.
Суть проблемы, в обработке делаю печать этикетки и рисунок штрихкода никак не изменяется, выводится стандартный(Скрин прилагается)

1с 8.3.8 1635
Розница 1.0 (1.0.11.1)

Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
    Макет = Обработки.тест.ПолучитьМакет("Макет");
    ОбластьМакет = Макет.ПолучитьОбласть("Обл");
    ОбластьМакет.Параметры.Пар = "Текст";    
    
    Код = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
    ТипКода = ПолучитьЗначениеТипаШтрихкодаДляЭУ(Код);    
    ПредставлениеШтрихкода = "";
    КодШтрихкода = "110000123456";
    
    Если ТипКода > -1 Тогда
        Для Каждого Рисунок Из Макет.Рисунки Цикл
            Если Рисунок.ТипРисунка = ТипРисункаТабличногоДокумента.Объект
                       И ТипЗнч(Рисунок.Объект) = Тип("ActiveX") Тогда
                        
                        //предположим что этот рисунок - штрихкод
                        Попытка
                            Рисунок.Объект.ТипКода   = ТипКода;
                            Рисунок.Объект.Сообщение = ?(ПустаяСтрока(ПредставлениеШтрихкода),
                                                         КодШтрихкода,
                                                         ПредставлениеШтрихкода);
                        Исключение
                        КонецПопытки;
            КонецЕсли;
        КонецЦикла;
                
    КонецЕсли;
    
    Таб = Новый ТабличныйДокумент;
    Таб.Вывести(ОбластьМакет);
    Таб.Показать();
    
    
КонецПроцедуры

[необходимо зарегистрироваться для просмотра ссылки]

andr_andrey Подменю пользователя
сообщение 02.07.18, 19:04
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 383
Спасибо сказали: 85 раз
Рейтинг: 64.3

zimelya @ Сегодня, 16:50 * ,
ОбластьМакет.Рисунки.Barcode.Объект.Сообщение = КодШтрихкода;


Сообщение отредактировал andr_andrey - 02.07.18, 19:13


Signature
#define private public

Спасибо сказали: takefive, zimelya,

zimelya Подменю пользователя
сообщение 03.07.18, 3:51
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

andr_andrey @ Вчера, 20:04 * ,

Спасибо добрый человек, в жизни бы не додумался что оно именно так работает.
Синтаксис помощник меня ввел в заблуждение что рисунки отбирает только через макет.рисунки. и тд.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.07.18, 0:09
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне