Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Печать из обработки с учетом фильтрации данных          
Constantus Подменю пользователя
сообщение 09.08.18, 12:19
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Создал обработку. В обработке имеется командная панель с фильтрами отбора данных.

Создал кнопку печати

Код
    ТабДок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Макет");
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.ДатаНачала = Формат(ДатаНачала,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.ДатаОкончания = Формат(ДатаОкончания,    "ДФ='dd.MM.yyyy'");
    ТабДок.Вывести(ОбластьМакета);

    
    ОбластьМакета = Макет.ПолучитьОбласть("ОбластьПечати");
    
    Для Каждого Стр Из Детально Цикл
        
    ОбластьМакета.Параметры.Снят = Стр.Снят;
    ОбластьМакета.Параметры.Удален = Стр.Удален;
    ОбластьМакета.Параметры.Дата = Формат(Стр.Дата,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.Номер = Стр.Номер;
*************
    
    ТабДок.Вывести(ОбластьМакета);
    КонецЦикла;
    
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДок, 1, Ложь, "Отчет по счет-фактурам (аналитический) за период с " + Формат(ДатаНачала, "ДФ='dd.MM.yyyy'") + " по " + Формат(ДатаОкончания,    "ДФ='dd.MM.yyyy'") );


Печатает как надо, но если я на командной панели ставлю отбор, то кнопка печати срабатывает без учета фильтров и печатает опять таки все данные, полученные обработкой

Как нужно изменить код печати из обработки с учетом фильтров, установленных на командной панели?

Сообщение отредактировал Vofka - 10.08.18, 7:56

ed.kharkov Подменю пользователя
сообщение 09.08.18, 14:22
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 49
Из: Бровары
Спасибо сказали: 16 раз
Рейтинг: 16

Constantus @ Сегодня, 13:19 * ,
Добрый день.

Попробуйте так
Для Каждого Стр Из Детально Цикл

    Если Не ЭлементыФормы.Детально.ПроверитьСтроку(Стр) Тогда
         Продолжить;  
    КонецЕсли;
  
    ОбластьМакета.Параметры.Снят = Стр.Снят;
    ОбластьМакета.Параметры.Удален = Стр.Удален;
    ОбластьМакета.Параметры.Дата = Формат(Стр.Дата,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.Номер = Стр.Номер;
*************
    
    ТабДок.Вывести(ОбластьМакета);
КонецЦикла;

Спасибо сказали: Constantus,

Constantus Подменю пользователя
сообщение 09.08.18, 14:34
Сообщение #3

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

ed.kharkov @ Сегодня, 17:22 * ,

Вроде сработало, но объясните логику работы кода!!!

ed.kharkov Подменю пользователя
сообщение 09.08.18, 14:36
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 49
Из: Бровары
Спасибо сказали: 16 раз
Рейтинг: 16

Constantus @ Сегодня, 15:34 * ,
ПроверитьСтроку() проверяет соответствие строки установленному отбору, вот и вся логика)))

Constantus Подменю пользователя
сообщение 29.08.18, 10:03
Сообщение #5

Почти ветеран
******
Группа: Пользователи
Сообщений: 691
Спасибо сказали: 4 раз
Рейтинг: 4

данный пример сработал для Обработки.

Теперь пытаюсь вывести на печать данные из табличной части документа с учетом отбора.

Печать идет из Модуля Объекта классическим способом...

    Для каждого СТР Из Начисления Цикл
        
    //Если НЕ ПроверитьСтроку(СТР) Тогда
        // Продолжить;  
        //КонецЕсли;

        
        
    Если СТР.ОфициальныйОклад > 0 Тогда;    
        
    ОбластьМакета.Параметры.Н = Н;
    ОбластьМакета.Параметры.ТН = СТР.Сотрудник.Код;
.....................................


Как в случае печати из модуля объекта вывести на печать только отобранные фильтром данные?

ЭлементыФормы.Начисления.ПроверитьСтроку(Стр)
- как применить или что применить?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 15.11.18, 19:22
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне