Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Печать доверенности          
Constantus Подменю пользователя
сообщение 28.03.17, 6:37
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 550
Спасибо сказали: 2 раз
Рейтинг: 2

Приветствую, форумчане!
БИТ.АППЕТИТ.Управляющий рестораном (1.1.15.9)
1С:Первый БИТ (1С:Предприятие 8.3 (8.3.8.2054))

Потребовалось в документ "РеализациюТоваровИУслуг" добавить возможность печати "Доверенности" (в типовой такой печати нет)

На форме документа "РеализациюТоваровИУслуг" имеется кнопка "Печать" и при нажатии на нее выходит форма печати "Торг-12"

Каким образом мне можно добраться до данной формы, чтобы туда прописать еще одну форму печати "Доверенность"

Petre Подменю пользователя
сообщение 28.03.17, 8:15
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2177
Из: Київ, Україна
Спасибо сказали: 513 раз
Рейтинг: 480.7

Constantus @ Сегодня, 6:37 * ,
Конфигурация не поддерживает механизм внешних печатных форм?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Constantus Подменю пользователя
сообщение 28.03.17, 10:40
Сообщение #3

Почти ветеран
******
Группа: Пользователи
Сообщений: 550
Спасибо сказали: 2 раз
Рейтинг: 2

Petre @ Сегодня, 11:15 * ,

У меня не внешняя печатная форма. Простой макет, который я могу разместить в Общих Макетах...

Неужели нельзя добавить другой макет или распечатать его другим способом?

logist Подменю пользователя
сообщение 28.03.17, 12:36
Сообщение #4

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 8979
Из: Харьков
Спасибо сказали: 2388 раз
Рейтинг: 1466.5

Посмотрите как реализована печать имеющейся формы, и сделайте по аналогии.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Constantus Подменю пользователя
сообщение 28.03.17, 12:54
Сообщение #5

Почти ветеран
******
Группа: Пользователи
Сообщений: 550
Спасибо сказали: 2 раз
Рейтинг: 2

logist @ Сегодня, 15:36 * ,
В модуле Менеджера стоит код

Функция Печать(Ссылка, ИмяПечатнойФормы=Неопределено) Экспорт
    Если ИмяПечатнойФормы = Неопределено Тогда
        Возврат Новый Структура("ТОРГ12", "ТОРГ-12 (Товарная накладная) за покупателя");
    ИначеЕсли ИмяПечатнойФормы = "ТОРГ12" Тогда
        Возврат СформироватьТОРГ12(Ссылка);
    КонецЕсли;
    
КонецФункции


Открывает форму выбора печатных форм и только одну "Торг12"

В том же модуле работает СформироватьТОРГ12(Ссылка);

Никак не могу сообразить как добавить в список свое имя печати, например "Доверенность" и запустить код СформироватьДоверенность()

По отладчику не нашел источник перечня форм печати для данного документа... Как добавить свою печатную форму?

Petre Подменю пользователя
сообщение 28.03.17, 13:14
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2177
Из: Київ, Україна
Спасибо сказали: 513 раз
Рейтинг: 480.7

Цитата(Constantus @ 28.03.17, 10:40) *
У меня не внешняя печатная форма. Простой макет, который я могу разместить в Общих Макетах...

Неужели вы думаете, что, просто добавив "макет", у вас заработает формирование печатной формы?
Если же у вас кроме "макета" есть код его заполнения, то почему не хотите сделать печатную форму по методике дополнительных обработок (если конфигурация на БСП) или внешних печатных форм?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Constantus Подменю пользователя
сообщение 28.03.17, 13:24
Сообщение #7

Почти ветеран
******
Группа: Пользователи
Сообщений: 550
Спасибо сказали: 2 раз
Рейтинг: 2

Petre @ Сегодня, 16:14 * ,


Т.е., Вы хотите сказать, что мне необходимо сделать обработку, которая сформирует Доверенность.
Потом эту обработку сохранить как внешнюю, сохранив на диске...
Потом зайти в справочник "Дополнительные отчеты и обработки", далее её каким-то образом закрепить за документом "Поступления"?

Если так, то сохранится ли эта печать при миграции приложения?

Есть подробная инструкция как добавить свои печатные формы кроме тех, которые каким-то образом 1с прописали для себя?

Petre Подменю пользователя
сообщение 28.03.17, 14:25
Сообщение #8

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2177
Из: Київ, Україна
Спасибо сказали: 513 раз
Рейтинг: 480.7

Цитата(Constantus @ 28.03.17, 13:24) *
Есть подробная инструкция как добавить свои печатные формы кроме тех, которые каким-то образом 1с прописали для себя?

Считаю, что информации в помощи из окна справочника "Дополнительные отчеты и обработки" вполне достаточно (во всяком случае, в типовых). Кроме того, можно сказать какой-нибудь пример, которых в этих интернетах тоже хватает.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

logist Подменю пользователя
сообщение 28.03.17, 15:01
Сообщение #9

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 8979
Из: Харьков
Спасибо сказали: 2388 раз
Рейтинг: 1466.5

Цитата(Constantus @ 28.03.17, 13:54) *
Никак не могу сообразить как добавить в список свое имя печати, например "Доверенность" и запустить код СформироватьДоверенность()

Где-то там же есть процедура похожая на "ПолучитьСтруктуруПечатныхФорм" или как-то так, вот в нее надо добавить свою "кнопку", а потом уже в "Печать" ее формирование.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Constantus Подменю пользователя
сообщение 28.03.17, 15:13
Сообщение #10

Почти ветеран
******
Группа: Пользователи
Сообщений: 550
Спасибо сказали: 2 раз
Рейтинг: 2

logist @ Сегодня, 18:01 * ,

Такой функции нет... есть:

БИТ_ОбщегоНазначения.ПолучитьДеревоМакетовПечати


После ссылается на:

ВнутренниеПечатныеФормы = ПолучитьМенеджер(СсылкаОбъекта).Печать(СсылкаОбъекта);


С этого момента дерево сформировано...

Про какие кнопки идет речь?

// Если ИмяПечатнойФормы=Неопределено, то возвращается список встроенных в конфигурацию макетов для переданной ссылки
//иначе возвращается список встроенных в конфигурацию макетов для переданной ссылки
Функция Печать(Ссылка, ИмяПечатнойФормы=Неопределено) Экспорт
    Если ИмяПечатнойФормы = Неопределено Тогда
        Возврат Новый Структура("ТОРГ12", "ТОРГ-12 (Товарная накладная) за покупателя");
    ИначеЕсли ИмяПечатнойФормы = "ТОРГ12" Тогда
        Возврат СформироватьТОРГ12(Ссылка);
    КонецЕсли;
    
КонецФункции


Petre Подменю пользователя
сообщение 28.03.17, 15:33
Сообщение #11

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2177
Из: Київ, Україна
Спасибо сказали: 513 раз
Рейтинг: 480.7

Constantus @ Сегодня, 15:13 * ,
Приведите текст функции "Печать()" любого другого документа, в котором список форм состоит из более чем одной.

Если собираетесь все-таки редактировать конфигурацию, то, думаю, вам надо следующее:
Функция Печать(Ссылка, ИмяПечатнойФормы = Неопределено) Экспорт
    Если ИмяПечатнойФормы = Неопределено Тогда
        Возврат Новый Структура("ТОРГ12, Доверенность", "ТОРГ-12 (Товарная накладная) за покупателя", "Доверенность");
    ИначеЕсли ИмяПечатнойФормы = "ТОРГ12" Тогда
        Возврат СформироватьТОРГ12(Ссылка);
    ИначеЕсли ИмяПечатнойФормы = "Доверенность" Тогда
        Возврат СформироватьДоверенность(Ссылка);
    КонецЕсли;
КонецФункции


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: Constantus,

Constantus Подменю пользователя
сообщение 28.03.17, 15:54
Сообщение #12

Почти ветеран
******
Группа: Пользователи
Сообщений: 550
Спасибо сказали: 2 раз
Рейтинг: 2

Petre @ Сегодня, 18:33 * ,


Вот это наводка!!!
Попробовал изменить структуру:

Функция Печать(Ссылка, ИмяПечатнойФормы=Неопределено) Экспорт
    Если ИмяПечатнойФормы = Неопределено Тогда
        Возврат Новый Структура("ТОРГ12, ППП", "ТОРГ-12 (Товарная накладная) за покупателя", "рррр");
    ИначеЕсли ИмяПечатнойФормы = "ТОРГ12" Тогда
        Возврат СформироватьТОРГ12(Ссылка);
    ИначеЕсли ИмяПечатнойФормы = "ППП" Тогда
        Возврат СформироватьТОРГ12(Ссылка);
    
    КонецЕсли;
    
КонецФункции


Вроде "ППП" сработало и открыла "Торг12"

Будет работать, если сделать другую СформироватьТОРГ12+ХХХХХХХХХХХХХ(Ссылка)?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.12.17, 0:31
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне