Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Открыть форму созданного и существующего документа по ДокументуОснования          
Constantus Подменю пользователя
сообщение 14.06.19, 11:02
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 801
Спасибо сказали: 5 раз
Рейтинг: 4

Приветствую, Форумчане!
1с8.2.6, БСП, самопис, УФ

В Документе есть кнопка, которая должна создавать дополнительный другой новый документ с заполнением и открытием вновь созданного документа, либо в случае, если такой документ уже существует, просто открыть его форму...

&НаКлиенте
Процедура УведомитьЗаказчикаОГотовностиСтелы(Команда)
    СоздатьОткрытьДокументУведомления();
    ОткрытьФорму("Документ.УведомлениеЗаказчикаОГотовностиСтелы.ФормаОбъекта", Новый Структура("ДокументОснование", Объект.Ссылка),ЭтотОбъект);
КонецПроцедуры


&НаСервере
Процедура СоздатьОткрытьДокументУведомления()
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    УведомлениеЗаказчикаОГотовностиСтелы.Ссылка
        |ИЗ
        |    Документ.УведомлениеЗаказчикаОГотовностиСтелы КАК УведомлениеЗаказчикаОГотовностиСтелы
        |ГДЕ
        |    УведомлениеЗаказчикаОГотовностиСтелы.ДокментОснование = &ДокментОснование";
    
    Запрос.УстановитьПараметр("ДокментОснование", Объект.Ссылка);

    Результат = Запрос.Выполнить();
    Если НЕ Результат.Пустой() Тогда
        Выборка = Результат.Выбрать();
        Выборка.Следующий();    
        ДокУведомление = Выборка.Ссылка;
    Иначе
        ДокУведомление = Документы.УведомлениеЗаказчикаОГотовностиСтелы.СоздатьДокумент();
        ДокУведомление.Дата = ТекущаяДата();
        ДокУведомление.Автор = ПараметрыСеанса.ТекущийПользователь;
        ДокУведомление.ДокментОснование = Объект.Ссылка;
        ДокУведомление.Заказчик = Объект.Заказчик;
        ДокУведомление.Записать();
    КонецЕсли;    
    
КонецПроцедуры


Докмуент создается, документОснование заполняется... Подскажите как правильно открывать формы для вновь созданных документов и для уже существующих...
Никак этот параметр открытия подобрать не могу...



fly Подменю пользователя
сообщение 14.06.19, 11:47
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 17
Спасибо сказали: 3 раз
Рейтинг: 2

Constantus @ Сегодня, 12:02 * ,


&НаКлиенте
Процедура УведомитьЗаказчикаОГотовностиСтелы(Команда)
    СоздатьОткрытьДокументУведомления();
    ОткрытьФорму("Документ.УведомлениеЗаказчикаОГотовностиСтелы.ФормаОбъекта", ВыбранныйДокумент);
КонецПроцедуры;



&НаСервере
Процедура СоздатьОткрытьДокументУведомления()
...
...
...
    Если НЕ Результат.Пустой() Тогда
        Выборка = Результат.Выбрать();
        Пока Выборка.Следующий() Цикл
                ВыбранныйДокумент = Выборка.Ссылка.ПолучитьОбъект();
        КонецЦикла;
    Иначе
        ДокУведомление = Документы.УведомлениеЗаказчикаОГотовностиСтелы.СоздатьДокумент();
        ДокУведомление.Дата = ТекущаяДата();
        ДокУведомление.Автор = ПараметрыСеанса.ТекущийПользователь;
        ДокУведомление.ДокментОснование = Объект.Ссылка;
        ДокУведомление.Заказчик = Объект.Заказчик;
        ДокУведомление.Записать();

        ВыбранныйДокумент = ДокУведомление;
    КонецЕсли;    
КонецПроцедуры


fly @ Сегодня, 12:24 * ,
или

 Пока Выборка.Следующий() Цикл
                ВыбранныйДокумент = Выборка.Ссылка;
КонецЦикла;




ВыбранныйДокумент = ДокУведомление.Ссылка;


вроде как надо ссылку на объект передать, а не сам объект

Спасибо сказали: Constantus,

Vladal Подменю пользователя
сообщение 20.06.19, 8:00
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 302
Из: Украина
Спасибо сказали: 50 раз
Рейтинг: 35

Цитата(fly @ 14.06.19, 12:47) *
вроде как надо ссылку на объект передать, а не сам объект

Да.
Я иногда делаю так:
(сферический пример в вакууме)
&НаСервере
Функция СоздатьРТУНаСервере()
    ДокОбъект = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
    ДокОбъект.Дата = ТекущаяДата();
    ДокОбъект.Записать();
    Возврат ДокОбъект.Ссылка;
КонецФункции

&НаКлиенте
Процедура СоздатьРТУ(Команда)
    СсылкаНаДокумент = СоздатьРТУНаСервере();
    ОткрытьЗначение(СсылкаНаДокумент);
КонецПроцедуры

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.07.19, 0:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!