Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Отчетка о выборе, множественный выбор          
kosalex Подменю пользователя
сообщение 28.03.18, 23:13
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 770
Спасибо сказали: 9 раз
Рейтинг: 9.9

Доброго времени суток! Есть форма выбора, если нажать на "Выбор нескольких" появляется колонка слева с зеленой галкой.

Как программно получить появление этой колонки с зеленой галкой?

Сделал кнопку "Выделить все", при ее нажатии список выделяется, но вот колонка не появляется.

Prospero Подменю пользователя
сообщение 29.03.18, 6:41
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 32
Из: Киев
Спасибо сказали: 6 раз
Рейтинг: 6

kosalex, имеется ввиду установка свойства "МножественныйВыбор" формы как Истина программно?

kosalex Подменю пользователя
сообщение 29.03.18, 11:49
Сообщение #3

Ветеран
*******
Группа: Пользователи
Сообщений: 770
Спасибо сказали: 9 раз
Рейтинг: 9.9

Prospero @ Сегодня, 6:41 * ,
Установил МножественныйВыбор программно в Истина, колонка не появилась :-(

kosalex Подменю пользователя
сообщение 01.04.18, 22:11
Сообщение #4

Ветеран
*******
Группа: Пользователи
Сообщений: 770
Спасибо сказали: 9 раз
Рейтинг: 9.9

Добрый вечер! Еще одна проблемка с этой зеленой галкой. При программном добавлении строк в "выделенные строки" эта галка не ставится на первой строке, на против остальных строк галка ставится. На скрине показана одна строка при нажатой кнопке "Выделить все". Строка добавлена в "выделенные строки", при закрытии формы передается дальше, но вот ГАЛКА....не ставится на первой строке ни в какую.... теряется наглядность...

В чем может быть дело?


kosalex Подменю пользователя
сообщение 02.04.18, 15:57
Сообщение #5

Ветеран
*******
Группа: Пользователи
Сообщений: 770
Спасибо сказали: 9 раз
Рейтинг: 9.9

Может ошибка в коде?

&НаСервере
Функция ПолучитьМассивСтрокДляВыделенияОткрытыеЗаказы(Стол)

    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Заказы.Ссылка КАК Ссылка
        |ИЗ
        |    Документ.Заказы КАК Заказы
        |ГДЕ
        |    Заказы.Стол = &Стол
        |    И Заказы.Проведен
        |    И Заказы.СостояниеЗаказа = &СостояниеЗаказа";
    
    Запрос.УстановитьПараметр("СостояниеЗаказа", Перечисления.СостоянияЗаказа.Открыт);
    Запрос.УстановитьПараметр("Стол", Стол);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    мЗаказов = РезультатЗапроса.Выгрузить().ВыгрузитьКолонку("Ссылка");
    
    Возврат  мЗаказов;
КонецФункции

&НаКлиенте
Процедура ВыбратьВсеЗаказы(Команда)
    мЗаказов = ПолучитьМассивСтрокДляВыделенияОткрытыеЗаказы(ВыбранныйСтол);
    Элементы.Список.ВыделенныеСтроки.Очистить();
    Для Каждого Заказ Из мЗаказов Цикл
        Элементы.Список.ВыделенныеСтроки.Добавить(Заказ);
    КонецЦикла;
    ЭтаФорма.ОбновитьОтображениеДанных(Элементы.Список);
КонецПроцедуры


На клиенте отрабатывает правильно, выделяет все строки, а в мобильном приложении не хочет...

kosalex Подменю пользователя
сообщение 02.04.18, 18:10
Сообщение #6

Ветеран
*******
Группа: Пользователи
Сообщений: 770
Спасибо сказали: 9 раз
Рейтинг: 9.9

Мобильная версия платформы 8.3.11.57

kosalex Подменю пользователя
сообщение 03.04.18, 12:52
Сообщение #7

Ветеран
*******
Группа: Пользователи
Сообщений: 770
Спасибо сказали: 9 раз
Рейтинг: 9.9

Дурному не скучно и самому 32542460.gif

Подскажите версию мобильной платформы из последних - стабильную?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 22.07.18, 20:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне