Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Отбор Контрагента-как сделать , отбор          
fardo Подменю пользователя
сообщение 20.04.19, 18:58
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Привет всем
не могу сделать отбор контрагента
Этот код где надо изменить..или пожалуйста напишите код сюда в ответе



Процедура ПриОткрытии() 
    Если Открыта() Тогда
        //УстановитьСтандартныйИнтервалОтчета(ДатаНач,ДатаКон);
    КонецЕсли;
    ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);    
КонецПроцедуры


Процедура ДействияФормыПечать(Кнопка)
    табдок = ЭлементыФормы.Результат;
    табдок.Записать(КаталогВременныхФайлов()+"\TABLE.xls",ТипФайлаТабличногоДокумента.XLS97);
    ЗапуститьПриложение(КаталогВременныхФайлов()+"\TABLE.xls");
КонецПроцедуры

Процедура ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, Форма) Экспорт
    
    ЗначениеПараметраНачалоПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаНач"));
    ЗначениеПараметраКонецПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ДатаКон"));
    ЗначениеПараметраСЧ = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("СЧ"));
    
    Если ЗначениеПараметраНачалоПериода <> Неопределено Тогда
        ЗначениеПараметраНачалоПериода.Значение = Форма.ДатаНач;
        ЗначениеПараметраНачалоПериода.Использование = (Форма.ДатаНач <> '0001-01-01');
    КонецЕсли;
    
    Если ЗначениеПараметраКонецПериода <> Неопределено Тогда
        ЗначениеПараметраКонецПериода.Значение = ?(Форма.ДатаКон = '0001-01-01', Форма.ДатаКон, КонецДня(Форма.ДатаКон));
        ЗначениеПараметраКонецПериода.Использование = (Форма.ДатаКон <> '0001-01-01');
    КонецЕсли;
    Сч = Новый Массив;
    Сч.Добавить("004");
    Сч.Добавить("29.10");
    
    Если ЗначениеПараметраСЧ <> Неопределено Тогда
        ЗначениеПараметраСЧ.Значение = Сч;
        ЗначениеПараметраСЧ.Использование = Истина;
    КонецЕсли;
    
КонецПроцедуры

Процедура НастройкаПериодаНажатие(Элемент)
    Если НП.Редактировать() Тогда
        ДатаНач = НП.ПолучитьДатуНачала();
        ДатаКон = НП.ПолучитьДатуОкончания();
        ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);
    КонецЕсли;
КонецПроцедуры

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    НП = Новый НастройкаПериода;
    НП.ВариантНастройки = ВариантНастройкиПериода.Период;
    НП.УстановитьПериод(НачалоДня(ДатаНач), ?(ДатаКон = '00010101', ДатаКон, КонецДня(ДатаКон)));
    ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек,ЭтаФорма);
КонецПроцедуры

Процедура КонтрагентПриИзмении(Элемент)
ОбновитьПараметрыКонтрагента(КомпоновщикНастроек,ЭтаФорма);
КонецПроцедуры

Процедура ОбновитьПараметрыКонтрагента(КомпоновщикНастроек, Форма) Экспорт

ЗначениеКонтрагент = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Контрагент"));
    
    Если ЗначениеКонтрагент <> Неопределено Тогда
        ЗначениеКонтрагент .Значение = Форма.Контрагент;
        ЗначениеКонтрагент .Использование = ЗначениеЗаполнено(Форма.Контрагент);
    КонецЕсли;
КонецПроцедуры

Vidocq05 Подменю пользователя
сообщение 22.04.19, 11:10
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 205
Из: Сумы
Спасибо сказали: 36 раз
Рейтинг: 36

fardo @ 20.04.19, 18:58 * ,

Процедура ОбновитьПараметрыКонтрагента(КомпоновщикНастроек, Форма) Экспорт 

КонтрагентПараметр =  КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Контрагент");
    
    Если КонтрагентПараметр <> Неопределено Тогда
        КонтрагентПараметр.Значение = Форма.Контрагент;
        КонтрагентПараметр.Использование = ЗначениеЗаполнено(Форма.Контрагент);
    КонецЕсли;

КонецПроцедуры

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.05.19, 2:50
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне