Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Обработка для выгрузки документов с УТ в самописную базу , нужно имено перезапись уже созданных 2 страниц V   1 2 >          
burza Подменю пользователя
сообщение 08.05.18, 10:23
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте! Есть обработка для втягивание документов из одной базы в другую.
Проблема в том как перезаписывать уже имеющиеся документы при выгрузке если там есть изменения.
Сейчас я просто сравниваю на изменение по сумме ну и по коду чтобы дублей не было.Если сумма разная делается новый документ.
То есть номер не меняется, меняться может только сумма, и если она изменилась значит перезаписываем только сумму в уже созданном.


Тут проверка
&НаСервере
Функция ПроверитьСуществованиеДокумента(Номер,СуммаДокумента, НачалоИнтервала, КонецИнтервала)
    Запрос = новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
        |СписокЗаявокУТ.Ссылка
        |ИЗ
        |Документ.СписокЗаявокУТ КАК СписокЗаявокУТ
        |ГДЕ
        |СписокЗаявокУТ.НомерЗаявки = &ПараметрСправочныйНомер
        |И СписокЗаявокУТ.Дата МЕЖДУ &ПараметрНачалоИнтервала И &ПараметрКонецИнтервала
        |И СписокЗаявокУТ.СуммаДокумента = &СуммаДокумента";
                  
    Запрос.УстановитьПараметр("СуммаДокумента", СуммаДокумента);
    Запрос.УстановитьПараметр("ПараметрСправочныйНомер", Номер);
    Запрос.УстановитьПараметр("ПараметрНачалоИнтервала", НачалоИнтервала);
    Запрос.УстановитьПараметр("ПараметрКонецИнтервала",  КонецИнтервала);    
    Результат = Запрос.Выполнить().Выбрать();
    
      Если Результат.Количество() = 0 Тогда
        Возврат Ложь;
    Иначе
        Возврат Истина;
    КонецЕсли;
    
КонецФункции


Запрос
    запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
            |    ЗаказКлиента.Номер КАК Номер,
            |    ЗаказКлиента.Дата,
            |    ЗаказКлиента.СуммаОплаты КАК СуммаОплаты,
            |    ЗаказКлиента.СуммаДокумента КАК СуммаДокумента,
            |    ЗаказКлиента.ЧислоПутевок КАК ЧислоПутевок,
            |    ЗаказКлиента.Санаторий.Наименование КАК Санаторий,
            |    ЗаказКлиента.Партнер.Наименование КАК Партнер,
            |    ЗаказКлиента.РуководительГруппы.Наименование КАК РуководительГруппы,
            |    ЗаказКлиента.Контрагент.Наименование КАК  Контрагент
            |ИЗ
            |    Документ.ЗаказКлиента КАК ЗаказКлиента
            |ГДЕ
            |    ЗаказКлиента.Дата МЕЖДУ &НачалоПериода И &КонецПериода
            |    И ЗаказКлиента.Проведен = ИСТИНА
            |    И ЗаказКлиента.ПометкаУдаления = ЛОЖЬ";
            
            запр.УстановитьПараметр("НачалоПериода", Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода", Объект.КонецПериода);
            

            Выборка = запр.Выполнить().Выбрать();
            
                        
            Пока Выборка.Следующий() Цикл
                Сообщить("Загрузка документа №" + Выборка.Номер);
                Если ПроверитьСуществованиеДокумента(Выборка.Номер, Выборка.СуммаДокумента, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                        Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");                
                    Иначе    
                    НачатьТранзакцию();
                    НовыйСписокЗаявокУТ = Документы.СписокЗаявокУТ.СоздатьДокумент();
                    НовыйСписокЗаявокУТ.Контрагент = Выборка.Контрагент;
                    НовыйСписокЗаявокУТ.ЧислоПутевок = Выборка.ЧислоПутевок;
                    НовыйСписокЗаявокУТ.СуммаДокумента = Выборка.СуммаДокумента;
                    НовыйСписокЗаявокУТ.НомерЗаявки = Выборка.Номер;
                    НовыйСписокЗаявокУТ.Санаторий =  ПодобратьСанаторий(Выборка.Санаторий);
                    НовыйСписокЗаявокУТ.РуководительГруппы = Выборка.РуководительГруппы;
                    НовыйСписокЗаявокУТ.Партнер   = Выборка.Партнер;
                    НовыйСписокЗаявокУТ.Дата  = Выборка.Дата;
                    НовыйСписокЗаявокУТ.Оплачено  = Выборка.СуммаОплаты;
                    НовыйСписокЗаявокУТ.Записать();
                    ЗафиксироватьТранзакцию();
                КонецЕсли;

            КонецЦикла;

logist Подменю пользователя
сообщение 08.05.18, 12:46
Сообщение #2

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2450 раз
Рейтинг: 1520.4

Цитата(burza @ 08.05.18, 11:23) *
как перезаписывать уже имеющиеся документы при выгрузке если там есть изменения.

Точно так же как и создание, только вместо СоздатьДокумент() - ПолучитьОбъект() ссылки найденного документа


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

burza Подменю пользователя
сообщение 08.05.18, 12:50
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 13:46 * ,

какой код и где нужно дописать?)

burza Подменю пользователя
сообщение 08.05.18, 14:53
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

burza @ Сегодня, 13:50 * ,
{Обработка.ОбменДаннымиСТорговлей.Форма.Форма.Форма(145)}: Метод объекта не обнаружен (ПолучитьОбъект)
НовыйСписокЗаявокУТ = Документы.СписокЗаявокУТ.ПолучитьОбъект();

sava1 Подменю пользователя
сообщение 08.05.18, 14:59
Сообщение #5

Крутой
Иконка группы
Группа: Местный
Сообщений: 1891
Из: Проскуров
Спасибо сказали: 437 раз
Рейтинг: 429.2

Цитата(burza @ 08.05.18, 15:53) *
НовыйСписокЗаявокУТ = Документы.СписокЗаявокУТ.ПолучитьОбъект();


Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер)

burza Подменю пользователя
сообщение 08.05.18, 15:04
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 15:59 * ,
вот что вылазит {Обработка.ОбменДаннымиСТорговлей.Форма.Форма.Форма(148)}: Поле объекта недоступно для записи (СуммаДокумента)
НовыйСписокЗаявокУТ.СуммаДокумента = Выборка.СуммаДокумента;

logist Подменю пользователя
сообщение 08.05.18, 15:33
Сообщение #7

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2450 раз
Рейтинг: 1520.4

Цитата(burza @ 08.05.18, 16:04) *
вот что вылазит

вы принципиально не хотите думать? Какой смысл в программировании методом тыка...


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

burza Подменю пользователя
сообщение 10.05.18, 8:07
Сообщение #8

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Никто больше не поможет. Только саркастические сообщение и все?!

burza Подменю пользователя
сообщение 10.05.18, 9:37
Сообщение #9

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Что не так?
{Обработка.ОбменДаннымиСТорговлей.Форма.Форма.Форма(150)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
Док = Док.ПолучитьОбъект();
по причине:
Элемент не выбран!

НачатьТранзакцию();
                    Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер);
                    Док = Док.ПолучитьОбъект();
                    Док.Контрагент = Выборка.Контрагент;
                    Док.ЧислоПутевок = Выборка.ЧислоПутевок;
                    Док.СуммаДокумента = Выборка.СуммаДокумента;
                    Док.НомерЗаявки = Выборка.Номер;
                    Док.Санаторий =  ПодобратьСанаторий(Выборка.Санаторий);
                    Док.РуководительГруппы = Выборка.РуководительГруппы;
                    Док.Партнер   = Выборка.Партнер;
                    Док.Дата  = Выборка.Дата;
                    Док.Оплачено  = Выборка.СуммаОплаты;
                    Док.Записать();
                    ЗафиксироватьТранзакцию();

Vidocq05 Подменю пользователя
сообщение 10.05.18, 9:59
Сообщение #10

Завсегдатай
****
Группа: Пользователи
Сообщений: 159
Из: Сумы
Спасибо сказали: 24 раз
Рейтинг: 24

burza @ Сегодня, 10:37 * ,
Если у Вас документы с периодической нумерацией, тогда нужно так:
Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

burza Подменю пользователя
сообщение 10.05.18, 10:02
Сообщение #11

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Vidocq05 @ Сегодня, 10:59 * ,
не работает(

Vidocq05 Подменю пользователя
сообщение 10.05.18, 10:06
Сообщение #12

Завсегдатай
****
Группа: Пользователи
Сообщений: 159
Из: Сумы
Спасибо сказали: 24 раз
Рейтинг: 24

burza @ Сегодня, 11:02 * ,
Выложите полностью код.

burza Подменю пользователя
сообщение 10.05.18, 10:09
Сообщение #13

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Vidocq05 @ Сегодня, 11:06 * ,
&НаСервере
Процедура ПровестиИмпортВходящихПлатежей()
    
    ВыборкаБазДляИмпорта = РегистрыСведений.СоединенияСБазамиДанныхУТ.Выбрать();
    
    Пока ВыборкаБазДляИмпорта.Следующий() Цикл
        Если (ВыборкаБазДляИмпорта.ЗагружатьПриходБезналичный) Тогда
            Сообщить(ВыборкаБазДляИмпорта.СтрокаСоединения);
            
            СоединениеБух = СоединитьсяСБазой(ВыборкаБазДляИмпорта.СтрокаСоединения);
            Если СоединениеБух = неопределено тогда
                Сообщить("Произошла ошибка при соединении с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Внимание);
            Продолжить;
            иначе
                Сообщить("Успешно соединились с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Информация);
            конецЕсли;

            // Создаём запрос для выборки всех исходящих платежей за период
            запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
            |    ЗаказКлиента.Номер КАК Номер,
            |    ЗаказКлиента.Дата,
            |    ЗаказКлиента.СуммаОплаты КАК СуммаОплаты,
            |    ЗаказКлиента.СуммаДокумента КАК СуммаДокумента,
            |    ЗаказКлиента.ЧислоПутевок КАК ЧислоПутевок,
            |    ЗаказКлиента.Санаторий.Наименование КАК Санаторий,
            |    ЗаказКлиента.Партнер.Наименование КАК Партнер,
            |    ЗаказКлиента.РуководительГруппы.Наименование КАК РуководительГруппы,
            |    ЗаказКлиента.Контрагент.Наименование КАК  Контрагент
            |ИЗ
            |    Документ.ЗаказКлиента КАК ЗаказКлиента
            |ГДЕ
            |    ЗаказКлиента.Дата МЕЖДУ &НачалоПериода И &КонецПериода
            |    И ЗаказКлиента.Проведен = ИСТИНА
            |    И ЗаказКлиента.ПометкаУдаления = ЛОЖЬ
            |   И НЕ ЗаказКлиента.СуммаДокумента = &СуммаДокумента";
            
            запр.УстановитьПараметр("НачалоПериода", Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода", Объект.КонецПериода);
            запр.УстановитьПараметр("СуммаДокумента", 0);
        

            Выборка = запр.Выполнить().Выбрать();
            
                        
            Пока Выборка.Следующий() Цикл
                Сообщить("Загрузка документа №" + Выборка.Номер);
                Если ПроверитьСуществованиеДокумента(Выборка.Номер, Выборка.СуммаДокумента, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                        Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                        
                
                    Иначе    
        

                        
                    НачатьТранзакцию();
                    Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер);
                    Док = Док.ПолучитьОбъект();
                    Док.Контрагент = Выборка.Контрагент;
                    Док.ЧислоПутевок = Выборка.ЧислоПутевок;
                    Док.СуммаДокумента = Выборка.СуммаДокумента;
                    Док.НомерЗаявки = Выборка.Номер;
                    Док.Санаторий =  ПодобратьСанаторий(Выборка.Санаторий);
                    Док.РуководительГруппы = Выборка.РуководительГруппы;
                    Док.Партнер   = Выборка.Партнер;
                    Док.Дата  = Выборка.Дата;
                    Док.Оплачено  = Выборка.СуммаОплаты;
                    Док.Записать();
                    ЗафиксироватьТранзакцию();

                КонецЕсли;

            КонецЦикла;
            

        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры


&НаСервере
Функция ПроверитьСуществованиеДокумента(Номер,СуммаДокумента, НачалоИнтервала, КонецИнтервала)
    Запрос = новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
        |СписокЗаявокУТ.Ссылка
        |ИЗ
        |Документ.СписокЗаявокУТ КАК СписокЗаявокУТ
        |ГДЕ
        |СписокЗаявокУТ.НомерЗаявки = &ПараметрСправочныйНомер
        |И СписокЗаявокУТ.Дата МЕЖДУ &ПараметрНачалоИнтервала И &ПараметрКонецИнтервала
        |И СписокЗаявокУТ.СуммаДокумента = &СуммаДокумента";
                  
    Запрос.УстановитьПараметр("СуммаДокумента", СуммаДокумента);
    Запрос.УстановитьПараметр("ПараметрСправочныйНомер", Номер);
    Запрос.УстановитьПараметр("ПараметрНачалоИнтервала", НачалоИнтервала);
    Запрос.УстановитьПараметр("ПараметрКонецИнтервала",  КонецИнтервала);    
    Результат = Запрос.Выполнить().Выбрать();

             Если Результат.Количество() = 0 Тогда
        Возврат Ложь;
    Иначе
        Возврат Истина;
    КонецЕсли;

    
КонецФункции

Vidocq05 Подменю пользователя
сообщение 10.05.18, 10:25
Сообщение #14

Завсегдатай
****
Группа: Пользователи
Сообщений: 159
Из: Сумы
Спасибо сказали: 24 раз
Рейтинг: 24

burza @ Сегодня, 11:09 * ,
Конечно не работает. Вы вдумайтесь в смысл выполнения кода.
&НаСервере
Процедура ПровестиИмпортВходящихПлатежей()
    
    ВыборкаБазДляИмпорта = РегистрыСведений.СоединенияСБазамиДанныхУТ.Выбрать();
    
    Пока ВыборкаБазДляИмпорта.Следующий() Цикл
        Если (ВыборкаБазДляИмпорта.ЗагружатьПриходБезналичный) Тогда
            Сообщить(ВыборкаБазДляИмпорта.СтрокаСоединения);
            
            СоединениеБух = СоединитьсяСБазой(ВыборкаБазДляИмпорта.СтрокаСоединения);
            Если СоединениеБух = неопределено тогда
                Сообщить("Произошла ошибка при соединении с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Внимание);
            Продолжить;
            иначе
                Сообщить("Успешно соединились с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Информация);
            конецЕсли;

            // Создаём запрос для выборки всех исходящих платежей за период
            запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
            |    ЗаказКлиента.Номер КАК Номер,
            |    ЗаказКлиента.Дата,
            |    ЗаказКлиента.СуммаОплаты КАК СуммаОплаты,
            |    ЗаказКлиента.СуммаДокумента КАК СуммаДокумента,
            |    ЗаказКлиента.ЧислоПутевок КАК ЧислоПутевок,
            |    ЗаказКлиента.Санаторий.Наименование КАК Санаторий,
            |    ЗаказКлиента.Партнер.Наименование КАК Партнер,
            |    ЗаказКлиента.РуководительГруппы.Наименование КАК РуководительГруппы,
            |    ЗаказКлиента.Контрагент.Наименование КАК  Контрагент
            |ИЗ
            |    Документ.ЗаказКлиента КАК ЗаказКлиента
            |ГДЕ
            |    ЗаказКлиента.Дата МЕЖДУ &НачалоПериода И &КонецПериода
            |    И ЗаказКлиента.Проведен = ИСТИНА
            |    И ЗаказКлиента.ПометкаУдаления = ЛОЖЬ
            |   И НЕ ЗаказКлиента.СуммаДокумента = &СуммаДокумента";
            
            запр.УстановитьПараметр("НачалоПериода", Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода", Объект.КонецПериода);
            запр.УстановитьПараметр("СуммаДокумента", 0);
        

            Выборка = запр.Выполнить().Выбрать();
            
                        
            Пока Выборка.Следующий() Цикл
                Сообщить("Загрузка документа №" + Выборка.Номер);

                // Это уже не нужно и функцию можете удалить
                //Если ПроверитьСуществованиеДокумента(Выборка.Номер, Выборка.СуммаДокумента, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                        //Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                        
                
                   // Иначе    
        
                    Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

                    Если НЕ Док.Пустая Тогда

                           Если Док.СуммаДокумента = Выборка.СуммаДокумента Тогда
                                  Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                                  Продолжить;
                           КонецЕсли;

                           НачатьТранзакцию();
                           Док = Док.ПолучитьОбъект();

                    Иначе
                          
                           НачатьТранзакцию();
                           Док = Документы.СписокЗаявокУТ.СоздатьДокумент();

                    КонецЕсли;
                    
                    Док.Контрагент = Выборка.Контрагент;
                    Док.ЧислоПутевок = Выборка.ЧислоПутевок;
                    Док.СуммаДокумента = Выборка.СуммаДокумента;
                    Док.НомерЗаявки = Выборка.Номер;
                    Док.Санаторий =  ПодобратьСанаторий(Выборка.Санаторий);
                    Док.РуководительГруппы = Выборка.РуководительГруппы;
                    Док.Партнер   = Выборка.Партнер;
                    Док.Дата  = Выборка.Дата;
                    Док.Оплачено  = Выборка.СуммаОплаты;
                    Док.Записать();
                    ЗафиксироватьТранзакцию();

                //КонецЕсли;

            КонецЦикла;
            

        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры

Спасибо сказали: burza,

Petre Подменю пользователя
сообщение 10.05.18, 10:26
Сообщение #15

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2415
Из: Київ, Україна
Спасибо сказали: 597 раз
Рейтинг: 556.2

burza @ Today, 10:09 * ,
Судя по коду, вы уверены, что НайтиПоНомеру всегда возвращает ссылку на документ. Судя по ошибке, возвращается что-то другое...


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Vidocq05 Подменю пользователя
сообщение 10.05.18, 10:30
Сообщение #16

Завсегдатай
****
Группа: Пользователи
Сообщений: 159
Из: Сумы
Спасибо сказали: 24 раз
Рейтинг: 24

Допустил ошибку. Вот так правильно

Если НЕ Док.Пустая() Тогда


Цитата(Petre @ 10.05.18, 11:26) *
Судя по ошибке, возвращается что-то другое...

Возвращает пустую ссылку.

Спасибо сказали: burza,

burza Подменю пользователя
сообщение 10.05.18, 10:38
Сообщение #17

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Vidocq05 @ Сегодня, 11:25 * ,
Этот код взял и просто создал все документы по новому(они уже есть)! Мне не нужно загружать документы каждый раз новые.
Мне чтобы менялись только данные в документе а документы оставались прежние.
То есть так нету проверки на уже имеющиеся документы.

Petre Подменю пользователя
сообщение 10.05.18, 10:49
Сообщение #18

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2415
Из: Київ, Україна
Спасибо сказали: 597 раз
Рейтинг: 556.2

burza @ Today, 10:38 * ,
Вы ищите по номеру, но не находите. Что значит документы "уже есть"?


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Vidocq05 Подменю пользователя
сообщение 10.05.18, 10:51
Сообщение #19

Завсегдатай
****
Группа: Пользователи
Сообщений: 159
Из: Сумы
Спасибо сказали: 24 раз
Рейтинг: 24

burza @ Сегодня, 11:38 * ,
Тогда так:
Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

                    Если НЕ Док.Пустая Тогда

                           Если Док.СуммаДокумента = Выборка.СуммаДокумента Тогда
                                  Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                                  Продолжить;
                           КонецЕсли;

                           НачатьТранзакцию();
                           Док = Док.ПолучитьОбъект;
                           Док.СуммаДокумента = Выборка.СуммаДокумента;
                           Док.Записать();
                           ЗафиксироватьТранзакцию();
                    
                    КонецЕсли;

Спасибо сказали: burza,

burza Подменю пользователя
сообщение 10.05.18, 10:56
Сообщение #20

Завсегдатай
****
Группа: Пользователи
Сообщений: 164
Спасибо сказали: 0 раз
Рейтинг: 0

Vidocq05
Извините тупанул, не там номер записывал. Все работает СПАСИБО)

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


2 страниц V   1 2 >
Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 25.09.18, 3:52
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне