Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 9
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Не работает отбор для набора данных объект          
Destrox Подменю пользователя
сообщение 25.07.18, 8:19
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте, уважаемые форумчане! Как заставить работать отбор для набора данных - объект. В СКД есть наборы данных объединение, который объединяет наборы - запрос и набор - объект. Для данных из запросов отбор работает, а для данных из объекта нет. Отчет просто выводит все данные, которые есть в объекте, а данные из запросов согласно отбору.

Наборы данных:


Отбор:



Результат:



В 1-м столбце данные из набора-объект, а а в остальных из запросов. Должно выводить данные только по одному подразделению указанному в отборе но почему-то в 1-м столбце выводит по всем подразделениям.

Код заполнения набора данных объект написан в УПП 8.3, обычные формы:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;    
    
    
    ВнешнийНаборДанных = Новый Структура("ДанныеПоЧисленностиНабор", ПолучитьДанныеПоЧисленности());
    
    
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();
    ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
    
        
    ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешнийНаборДанных, ДанныеРасшифровки, Истина);    
        
    
    ДокументРезультат.Очистить();
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);

    
    ПроцессорВывода.НачатьВывод();
    
    Пока Истина Цикл
      
        ЭлементРезультата = ПроцессорКомпоновкиДанных.Следующий();
        
        Если ЭлементРезультата = Неопределено Тогда        
          
            Прервать;
            
        Иначе
            
        
         ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
            
        КонецЕсли;
        
    КонецЦикла;
    
    ПроцессорВывода.ЗакончитьВывод();

          
КонецПроцедуры


Destrox Подменю пользователя
сообщение 26.07.18, 10:40
Сообщение #2

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(Destrox @ 25.07.18, 9:19) *
Как заставить работать отбор для набора данных - объект.

Это вопрос. Забыл вопросительный знак поставить.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 16.10.18, 14:54
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне