Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 11, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> не могу найти печатную форму 1C:Предприятие 7.7          
4andriy Подменю пользователя
сообщение 19.09.18, 15:43
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 47
Спасибо сказали: 0 раз
Рейтинг: 0

Процедура Печать()
    
    Работа = 0; ПечататьРаботуВНакладной = 0;
    Если глПечатьДокументовСписком = 0 Тогда
        спПечатныхФорм = глПолучитьСписокПечатныхФорм("Документ."+Вид());
        Если СчетВзаиморасчетов.Валютный = 1 Тогда
            глУдалитьЗначение(спПечатныхФорм,"РасходнаяНакладная_М20");
            глУдалитьЗначение(спПечатныхФорм,"РасходнаяНакладная_1ТН");
        КонецЕсли;
        
        Если ОдинВидТМЦ > 0 Тогда//по одному виду ТМЦ
            Если ВидТМЦ.ВидТМЦ <> Перечисление.ВидыТМЦ.Работа Тогда
                глУдалитьЗначение(спПечатныхФорм,"РасходнаяНакладная_Акт");
            Иначе
                Работа = 1;
            КонецЕсли;
        Иначе//по многим видам ТМЦ        
            тз = СоздатьОбъект("ТаблицаЗначений");
            ВыгрузитьТабличнуюЧасть(тз,"ВидТМЦвСтроке");
            тз.Свернуть("ВидТМЦвСтроке",);
            тз.ВыбратьСтроки();
            Пока тз.ПолучитьСтроку() = 1 Цикл
                Если тз.ВидТМЦвСтроке.ВидТМЦ = Перечисление.ВидыТМЦ.Работа Тогда
                    Работа = 1;
                КонецЕсли;
            КонецЦикла;
            Если Работа = 0 Тогда
                глУдалитьЗначение(спПечатныхФорм,"РасходнаяНакладная_Акт");
            КонецЕсли;    
        КонецЕсли;
        РежимПечати = глПечать(Контекст,"Документ." + Вид(), спПечатныхФорм);
        Если ПустоеЗначение(РежимПечати) = 1 Тогда
            Возврат;
        КонецЕсли;
    Иначе
        РежимПечати = глРежимПечатиСписком;
    КонецЕсли;
    Если (РежимПечати = "РасходнаяНакладнаяФакс") или (РежимПечати = "РасходнаяНакладнаяПечать") или
         (РежимПечати = "РасходнаяНакладная_Акт") Тогда
        глПараметрыТаблицы(,1);
    ИначеЕсли (РежимПечати = "РасходнаяНакладная_М20") или (РежимПечати = "РасходнаяНакладная_1ТН") Тогда
        глПараметрыТаблицы(,2);
    КонецЕсли;
    Если глУстановкаПараметровПечати(РежимПечати) = 0 Тогда Возврат КонецЕсли;
    //Сформировать(РежимПечати);
    Если ((РежимПечати = "РасходнаяНакладнаяФакс") или (РежимПечати = "РасходнаяНакладнаяПечать")) и
         (Работа = 1) Тогда
         ПечататьРаботуВНакладной = Вопрос("Включати роботи в документ ?",4);    
    КонецЕсли;


Интересует гжде можно поправить форму из РежимПечати = "РасходнаяНакладнаяПечать". Никак не могу найти.

cos12 Подменю пользователя
сообщение 19.09.18, 16:19
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 195
Спасибо сказали: 15 раз
Рейтинг: 13.6

4andriy @ Сегодня, 16:43 * ,
спПечатныхФорм = глПолучитьСписокПечатныхФорм("Документ."+Вид());
глПолучитьСписокПечатныхФорм - смотрите какой список форм он вам возвращает и откуда берет

1Cv77 Подменю пользователя
сообщение 19.09.18, 16:21
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 185
Из: Украина, Мелитополь
Спасибо сказали: 58 раз
Рейтинг: 14

4andriy @ Сегодня, 14:43 * ,

СмотриТЕ в глобальном модуле Процедуру глПараметрыТаблицы(.... (или функцию)

Там же, в глобалке и таблицы нужные


 ! 

Правила: 1
 


Сообщение отредактировал Vofka - 20.09.18, 13:18

4andriy Подменю пользователя
сообщение 19.09.18, 19:44
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 47
Спасибо сказали: 0 раз
Рейтинг: 0

1Cv77 @ Сегодня, 17:21 * ,
Функция глПолучитьСписокПечатныхФорм(Объект) Экспорт
    Перем сп;                                    
          
    сп = СоздатьОбъект("СписокЗначений");
    
    //по таблице заданных в системе форм
    глПечатныеФормы.ВыбратьСтроки();
    Пока глПечатныеФормы.ПолучитьСтроку() = 1 Цикл
        Если глПечатныеФормы.Объект = Объект Тогда
            сп.ДобавитьЗначение(глПечатныеФормы.Идентификатор,глПечатныеФормы.Представление);
        КонецЕсли;
    КонецЦикла;
    
    //дополнительные формы
    Спр = СоздатьОбъект("Справочник.ПечатныеФормы");
    Спр.ВыбратьЭлементыПоРеквизиту("Объект",Объект);
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        Если Спр.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Спр.ФлагПечатнойФормы = 3 Тогда
            сп.ДобавитьЗначение("Дополнительно","==Додаткові==");
            Прервать;
        КонецЕсли;
    КонецЦикла;


функцию нашел, а сам бланк, который можно редактировать не могу найти.

4andriy @ Сегодня, 20:41 * ,

нашел!!! в общих таблицах!!! всем спасибо!!!

1Cv77 Подменю пользователя
сообщение 19.09.18, 22:33
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 185
Из: Украина, Мелитополь
Спасибо сказали: 58 раз
Рейтинг: 14

4andriy @ Сегодня, 18:44 * ,
Кто ищет, то - всегда найдет )))))))))

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 22.10.18, 8:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне