Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Макет табличного документа , Свертка табличного документа          
cao0603 Подменю пользователя
сообщение 26.01.18, 17:15
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 58
Спасибо сказали: 0 раз
Рейтинг: 0

У меня есть табличный документ, в котором вывожу сразу несколько отчетов,все это происходит в одном макете,и мне необходимо на определенном куске макета сделать так чтобы поля свернулись и рядом появился знак + для раскрытия ,если применяю обход по группировкам и свернуть то это применяется ко всему табличному документу,как быть ? Если можно то хотелось бы ответов с конкретным кодом

Gazulo Подменю пользователя
сообщение 26.01.18, 22:39
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 147
Спасибо сказали: 17 раз
Рейтинг: 17

cao0603 @ Сегодня, 17:15 * ,
напишите код для сворачивания только для той части что должна свернуться..


"применяю обход по группировкам и свернуть" напишите код как это делается , чтобы знать чем помочь

cao0603 Подменю пользователя
сообщение 27.01.18, 9:45
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 58
Спасибо сказали: 0 раз
Рейтинг: 0

Функция свертки я должен применить для всего табдок иначе она не срабатывает

Gazulo @ Вчера, 23:39 * ,
Покажите свой вариант кода

Gazulo Подменю пользователя
сообщение 28.01.18, 18:25
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 147
Спасибо сказали: 17 раз
Рейтинг: 17

cao0603 @ Вчера, 9:45 * ,
//где надо сворачивать
Таб.НачатьАвтогруппировкуСтрок();
Для Каждого текСтрока Из ТЗ Цикл    
        Таб.Вывести(Обл,1);
КонецЦикла;
Таб.ЗакончитьАвтогруппировкуСтрок();


//где не надо
Для Каждого текСтрока Из ТЗ Цикл    
        Таб.Вывести(Обл);
КонецЦикла;

Vofka Подменю пользователя
сообщение 29.01.18, 9:28
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12624
Из: Киев
Спасибо сказали: 3770 раз
Рейтинг: 2887.7

Таб1.НачатьАвтогруппировкуСтрок();
Для Каждого текСтрока Из ТЗ Цикл    
        Таб1.Вывести(Обл,1);
КонецЦикла;
Таб1.ЗакончитьАвтогруппировкуСтрок();

Таб2.Вывести(Таб1);
Для Каждого текСтрока Из ТЗ Цикл    
        Таб2.Вывести(Обл);
КонецЦикла;


Signature
Услуги 1С программиста

Gazulo Подменю пользователя
сообщение 29.01.18, 10:07
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 147
Спасибо сказали: 17 раз
Рейтинг: 17

Vofka @ Сегодня, 9:28 * ,
я не те саме вище написав?

Vofka Подменю пользователя
сообщение 29.01.18, 10:13
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12624
Из: Киев
Спасибо сказали: 3770 раз
Рейтинг: 2887.7

Gazulo @ Сегодня, 10:07 * ,
нет


Signature
Услуги 1С программиста

Gazulo Подменю пользователя
сообщение 29.01.18, 10:31
Сообщение #8

Завсегдатай
****
Группа: Пользователи
Сообщений: 147
Спасибо сказали: 17 раз
Рейтинг: 17

Vofka @ Сегодня, 10:13 * ,
аа...різниця в таб1 і таб2

logist Подменю пользователя
сообщение 29.01.18, 11:54
Сообщение #9

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9322
Из: Харьков
Спасибо сказали: 2447 раз
Рейтинг: 1517.1

Цитата(Gazulo @ 29.01.18, 10:31) *
різниця в таб1 і таб2

Різниця в тому, що потім таб1 і таб2 виводяься в результуючий Таб


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 25.05.18, 7:08
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне