Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> как вывести на печать адрес организации?          
Юля Подменю пользователя
сообщение 03.07.18, 13:36
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 388
Из: Хмельницький
Спасибо сказали: 17 раз
Рейтинг: 12

Бух.2.0, как в внешнею печатную форму втащить на печать адрес организации?? Где он храниться, так как сведений "КонтактнаяИнформация" в новой редакции нету? спасибо

Petre Подменю пользователя
сообщение 03.07.18, 13:56
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2434
Из: Київ, Україна
Спасибо сказали: 605 раз
Рейтинг: 564.4

Юля @ Today, 13:36 * ,
В табличной части соответствующего объекта. Но и там вас ждет сюрприз. Поэтому пользуйтесь программным интерфейсом БСП.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Юля Подменю пользователя
сообщение 03.07.18, 14:00
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 388
Из: Хмельницький
Спасибо сказали: 17 раз
Рейтинг: 12

Цитата(Petre @ 03.07.18, 14:56) *
В табличной части соответствующего объекта

это я уже увидела, а вот дальше даже не знаю что делать, только начинаю разбираться, а было так все просто в 1.2(((

Prospero Подменю пользователя
сообщение 04.07.18, 8:46
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 32
Из: Киев
Спасибо сказали: 6 раз
Рейтинг: 6

Юля,
[необходимо зарегистрироваться для просмотра ссылки] не поможет?

Юля Подменю пользователя
сообщение 04.07.18, 9:40
Сообщение #5

Оратор
*****
Группа: Пользователи
Сообщений: 388
Из: Хмельницький
Спасибо сказали: 17 раз
Рейтинг: 12

Prospero @ Сегодня, 9:46 * ,
или я что-то не понимаю:
СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(СсылкаНаОбъект.Организация, СсылкаНаОбъект.Дата);
Адрес = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "ЮридическийАдрес");
Это для бух 2.0
А так адреса хранятся в регистре сведений "КонтактнаяИнформация"

регистра сведений "КонтактнаяИнформация" нету в новой редакции, в том и вся проблема. Или я ошибаюсь, тогда "отредактируйте " меня)))

andreydv87 Подменю пользователя
сообщение 04.07.18, 10:04
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 2 раз
Рейтинг: 2

а так пробовали?

НСтр("ru='Адресс: ';uk='Адреса: '",КодЯзыкаПечать)+ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике,"ЮридическийАдрес",,КодЯзыкаПечать)

andr_andrey Подменю пользователя
сообщение 04.07.18, 10:10
Сообщение #7

Оратор
Иконка группы
Группа: Местный
Сообщений: 427
Спасибо сказали: 93 раз
Рейтинг: 71.6

Исчерпывающий ответ уже дан во втором сообщении.

Сообщение отредактировал andr_andrey - 04.07.18, 10:15


Signature
#define private public

sava1 Подменю пользователя
сообщение 04.07.18, 10:20
Сообщение #8

Крутой
Иконка группы
Группа: Местный
Сообщений: 1906
Из: Проскуров
Спасибо сказали: 444 раз
Рейтинг: 433.5

А просто "скопип...ть" ?

СведенияОГрузоотправитель = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузоотправитель, Шапка.ДатаДокумента);

ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать)

andr_andrey Подменю пользователя
сообщение 04.07.18, 10:31
Сообщение #9

Оратор
Иконка группы
Группа: Местный
Сообщений: 427
Спасибо сказали: 93 раз
Рейтинг: 71.6

sava1 @ Сегодня, 11:20 * ,
Цитата(Юля @ 03.07.18, 14:36) *
втащить на печать адрес организации??

Раз не хотят использовать стандартные процедуры, пусть берут
СсылкаНаОбъект.Организация.КонтактнаяИнформация.Представление

П.С. В запросе конечно выберут "Юридична адреса" или "Поштова адреса"

Сообщение отредактировал andr_andrey - 04.07.18, 10:33


Signature
#define private public

sava1 Подменю пользователя
сообщение 04.07.18, 11:37
Сообщение #10

Крутой
Иконка группы
Группа: Местный
Сообщений: 1906
Из: Проскуров
Спасибо сказали: 444 раз
Рейтинг: 433.5

Цитата(andr_andrey @ 04.07.18, 11:31) *
sava1 @ Сегодня, 11:20 * ,
Цитата(Юля @ 03.07.18, 14:36) *
втащить на печать адрес организации??


А открыть функцию и увидеть
Если ТипЗнч(ЮрФизЛицо) = Тип("СправочникСсылка.Организации") Тогда


Все уже давно придумано.
Слышали про инкапсуляцию (применительно к классам и БД) ?

Сообщение отредактировал sava1 - 04.07.18, 11:38

Юля Подменю пользователя
сообщение 06.07.18, 14:26
Сообщение #11

Оратор
*****
Группа: Пользователи
Сообщений: 388
Из: Хмельницький
Спасибо сказали: 17 раз
Рейтинг: 12

Процедура СформироватьНаСервере()
    // Вставить содержимое обработчика.
    
    Для Каждого ТекущаяСтрока Из Организация.КонтактнаяИнформация Цикл
            
    
        
        Если ТекущаяСтрока.Вид.Наименование="Юридична адреса" Тогда
                    
        
            
            ЮрАдр=ТекущаяСтрока.Представление;
            
            
        КонецЕсли;    
        
        Если ТекущаяСтрока.Вид.Наименование="Телефон" Тогда
                    
        
            Телеф=ТекущаяСтрока.Представление;
            
        КонецЕсли;    
        
        
            
    КонецЦикла;    

    
    Сообщить("Юридична адреса: "+ЮрАдр+"; тел.: "+ Телеф);
    
    
КонецПроцедуры


Сделала как то так haha.gif

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.18, 22:50
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне