Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как вывести группу номенклатуры в отчет          
lolmatrix Подменю пользователя
сообщение 15.01.19, 15:27
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте помогите пожалуйста новичку, пишу собственную конфигурацию на 1с 8.3 , вывожу список номенклатуры на печатную форму в обработке, и мне нужно вывести группировку чтобы над номенклатурой из одной группы выводился родитель в макете
Функция СформироватьПечатнуюФормуИзТабличногоДокумента()
      // Получаем макет, сохраненный в нашей обработке.
   Макет = Обработки.сформировать.ПолучитьМакет("КалькуляцияКПП");    
      
        ПечатнаяФорма = Новый ТабличныйДокумент;
            
    ТабличнаяЧастьСтрока = Макет.ПолучитьОбласть("строка");
        Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Наименование КАК Наименование,
        |    Номенклатура.Родитель КАК Родитель
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |
        |СГРУППИРОВАТЬ ПО
        |    Номенклатура.Родитель,
        |    Номенклатура.Наименование";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Родитель = ВыборкаДетальныеЗаписи.Родитель
            Ном = ВыборкаДетальныеЗаписи.Наименование;
ТабличнаяЧастьСтрока.параметры.Номенклатура = Ном;
ТабличнаяЧастьСтрока.параметры.Родитель = Родитель;
    КонецЦикла;


Заранее багодарен


 ! 

Правила: 9
 


Сообщение отредактировал Vofka - 15.01.19, 15:51

Gazulo Подменю пользователя
сообщение 15.01.19, 20:29
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 176
Спасибо сказали: 19 раз
Рейтинг: 19

lolmatrix @ Сегодня, 15:27 * ,


    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Ссылка КАК Ссылка,
        |    Номенклатура.Родитель КАК Родитель
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ИТОГИ ПО
        |    Родитель";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаРодитель = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока ВыборкаРодитель.Следующий() Цикл
        // Вставити обробку вибірки ВыборкаРодитель
    
        ВыборкаДетальныеЗаписи = ВыборкаРодитель.Выбрать();
    
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            // Вставити обробку вибірки ВыборкаДетальныеЗаписи
        КонецЦикла;
    КонецЦикла;

lolmatrix Подменю пользователя
сообщение 16.01.19, 15:07
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

 РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам)

Значения нет, тип значения не определено
родитель ошибка чтения значения
ссылка ошибка чтения значения

Gazulo Подменю пользователя
сообщение 16.01.19, 22:20
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 176
Спасибо сказали: 19 раз
Рейтинг: 19

lolmatrix @ Сегодня, 15:07 * ,
в запросе ошибка или при выборке?

lolmatrix Подменю пользователя
сообщение 17.01.19, 8:22
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

результат запроса пустой в отладчике ошибки

lolmatrix Подменю пользователя
сообщение 18.01.19, 8:09
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

вопрос остался открытым

Gazulo Подменю пользователя
сообщение 18.01.19, 12:07
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 176
Спасибо сказали: 19 раз
Рейтинг: 19

lolmatrix @ Сегодня, 8:09 * ,
могу подключиться и посмотреть..

lolmatrix Подменю пользователя
сообщение 18.01.19, 15:34
Сообщение #8

Общительный
**
Группа: Пользователи
Сообщений: 15
Спасибо сказали: 0 раз
Рейтинг: 0

Gazulo, сколько это стоит

lolmatrix @ Сегодня, 16:27 * ,
Спасибо, работает

Gazulo Подменю пользователя
сообщение 18.01.19, 15:56
Сообщение #9

Завсегдатай
****
Группа: Пользователи
Сообщений: 176
Спасибо сказали: 19 раз
Рейтинг: 19

lolmatrix @ Сегодня, 15:34 * ,
А почему не работало?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.04.19, 10:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне