Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как получить файл из вложения документа Эл.письма входящего , ут 11.3 УП          
djmn_alexander Подменю пользователя
сообщение 16.05.18, 13:18
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 24
Спасибо сказали: 1 раз
Рейтинг: 1

Есть код:
Процедура ДобавитьДанные(Хранилище)
    Данные = Хранилище.Получить();
КонецПроцедуры

&НаСервере
Процедура ЗагрузитьНаСервере()
    // Вставить содержимое обработчика.
    УправлениеЭлектроннойПочтой.ПолучениеИОтправкаЭлектронныхПисем();
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ЭлектронноеПисьмоВходящее.Ссылка
                   |ИЗ
                   |    Документ.ЭлектронноеПисьмоВходящее КАК ЭлектронноеПисьмоВходящее
                   |ГДЕ
                   |    ЭлектронноеПисьмоВходящее.УчетнаяЗапись.Наименование = &УчетнаяЗапись
                   |    И ЭлектронноеПисьмоВходящее.Тема ПОДОБНО &Тема
                   |    И ЭлектронноеПисьмоВходящее.Дата МЕЖДУ &Дата1 И &Дата2";
    
    Запрос.УстановитьПараметр("Тема","%"+Объект.Тема+"%");
    Запрос.УстановитьПараметр("УчетнаяЗапись",Объект.ИмяУчетнойЗаписи);
    Запрос.УстановитьПараметр("Дата1",КонецДня(ТекущаяДата()) - 24*3600*10);
    Запрос.УстановитьПараметр("Дата2",КонецДня(ТекущаяДата()));
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        ТаблицаВложения = УправлениеЭлектроннойПочтой.ПолучитьВложенияЭлектронногоПисьма(Выборка.Ссылка, Истина);
        Для Каждого Стр Из ТаблицаВложения Цикл
            Если Найти(Стр.ИмяФайла,Объект.ИмяФайла) > 0 Тогда
                ДобавитьДанные(Стр.Ссылка.ФайлХранилище);                
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
КонецПроцедуры


В процедуре ДобавитьДанные пробую Данные.Записать("..."), Данные - почему-то равно Неопределено, хотя размер у файла есть, и из формы его можно открыть. Если Хранилище.Записать - пишет нет метода (у Хранилища нет метода Записать)

logist Подменю пользователя
сообщение 16.05.18, 16:20
Сообщение #2

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2450 раз
Рейтинг: 1520.4

Файл в базе хранится, может в папке на диске?


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

djmn_alexander Подменю пользователя
сообщение 16.05.18, 18:13
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 24
Спасибо сказали: 1 раз
Рейтинг: 1

logist @ Сегодня, 17:20 * ,
пишется что в конфигурации, путькфайлу пустой

logist Подменю пользователя
сообщение 16.05.18, 18:53
Сообщение #4

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2450 раз
Рейтинг: 1520.4

Есть вариант что файл хранится в РС ПрисоединенныеФайлы, а не в справочнике.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Спасибо сказали: djmn_alexander,

djmn_alexander Подменю пользователя
сообщение 17.05.18, 13:18
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 24
Спасибо сказали: 1 раз
Рейтинг: 1

logist @ Вчера, 19:53 * ,
Да действительно там и хранится спасибо

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 25.09.18, 3:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне