Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как подключить внешнюю обработку к документу          
martynovalena Подменю пользователя
сообщение 12.12.17, 13:22
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

Всем ,здравствуйте. 1С:Предприятие 8.3 (8.3.10.2299) Бухгалтерия предприятия, редакция 3.0 БИТ.ФИНАНС 3.1
У меня задача, нужно чтобы из документа (Допсоглашение) можно было вызвать внеш обработку ,на форме которой ,выбрать договор и заполнить по нему данные доп соглашения.
Внешняя обработка есть , а вот при подключении нет возможности выбрать документ из которого мне нужно. чтобы она вызывалась, только Разделы.
Что делаю не так? или вообще так нельзя сделать при подключении внешней обработки? только прописывать в конфигурации.
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.бит_ПроектДоговора"); //Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ЗаполнениеДоговора"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ложь);
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Информация", "Заполнение реквизитов допсоглашения из основного договора процесса");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "ЗаполнениеДоговора", "Заполнение Договора", "ОткрытиеФормы", Истина, "");
    //ДобавитьКоманду(ТаблицаКоманд, "ЗаполнениеРеквизитовДоговора", "ЗаполнениеРеквизитовДоговора", "ВызовСерверногоМетода", Истина, "");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
КонецФункции




Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
    
КонецПроцедуры



 ! 

Правила: 4,5
 


Сообщение отредактировал logist - 12.12.17, 17:19

Petre Подменю пользователя
сообщение 12.12.17, 14:20
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2415
Из: Київ, Україна
Спасибо сказали: 597 раз
Рейтинг: 556.2

martynovalena @ Сегодня, 13:22 * ,
ПараметрыРегистрации.Вставить("Вид", "ЗаполнениеОбъекта");


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: martynovalena,

martynovalena Подменю пользователя
сообщение 12.12.17, 14:26
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 9
Спасибо сказали: 0 раз
Рейтинг: 0

А как обратиться к объекту(Доп Соглашению) из которого открыли форму внешней обработки? Для дальнейшего заполнения его реквизитов?

Petre Подменю пользователя
сообщение 12.12.17, 14:56
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2415
Из: Київ, Україна
Спасибо сказали: 597 раз
Рейтинг: 556.2

martynovalena @ Сегодня, 14:26 * ,
В форме обработки создать параметр ОбъектыНазначения произвольного типа, куда передастся массив ссылок.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: martynovalena,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.09.18, 15:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне