Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> как передать переменную с клиента на сервер          
lolmatrix Подменю пользователя
сообщение 19.06.18, 14:33
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуй, уважаемые специалисты, помогите пожалуйста новичку, НаКлиенте получаю переменную , ее надо передать наСервер, как можно это сделать ,
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    Запчасть = СтрокаТЧ.Наименование;

Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";

    Запрос.УстановитьПараметр("Запчасть", Запчасть);

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ТД.Цена =  ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;

КонецПроцедуры

Vofka Подменю пользователя
сообщение 19.06.18, 15:57
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12750
Из: Киев
Спасибо сказали: 3838 раз
Рейтинг: 2958.4

&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    СписокЗЧНаименованиеПриИзмененииНаСервере(СтрокаТЧ.Наименование);
КонецПроцедуры


Signature
Услуги 1С программиста

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 03.07.18, 14:15
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Vofka @ 19.06.18, 16:57 * ,
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'

Vofka @ 19.06.18, 16:57 * ,
а как передать всю строку

Petre Подменю пользователя
сообщение 03.07.18, 14:25
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2451
Из: Київ, Україна
Спасибо сказали: 608 раз
Рейтинг: 567

lolmatrix @ Today, 14:15 * ,
А зачем ее передавать?
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    
    // . . .

КонецПроцедуры


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: lolmatrix,

ed.kharkov Подменю пользователя
сообщение 03.07.18, 14:38
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 49
Из: Бровары
Спасибо сказали: 16 раз
Рейтинг: 16

Petre @ Сегодня, 15:25 * ,
ТекущиеДанные недоступны на сервере.

На сервере можно получить так:

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    СтрокаТЧ = Объект.СписокЗЧ[Элементы.СписокЗЧ.ТекущаяСтрока];
    
    // . . .

КонецПроцедуры

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 03.07.18, 15:06
Сообщение #6

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

ed.kharkov @ Сегодня, 15:38 * ,
ed.kharkov @ Сегодня, 15:38 * ,
теперь вопрос цена попала в оттладчике она есть, но на форме не отразилась

lolmatrix @ Сегодня, 15:55 * ,
огромное спасибо, за помощь вопрос решен ответом Ed. kharkov
НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
СтрокаТЧ = Объект.СписокЗЧ[Элементы.СписокЗЧ.ТекущаяСтрока];

// . . .

КонецПроцедуры

ed.kharkov Подменю пользователя
сообщение 03.07.18, 15:07
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 49
Из: Бровары
Спасибо сказали: 16 раз
Рейтинг: 16

lolmatrix @ Сегодня, 15:55 * ,
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
   СписокЗЧНаименованиеПриИзмененииНаСервере();
   Прочитать();
КонецПроцедуры

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 15.11.18, 19:35
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне